mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 06:33:41 +00:00
a2d4b5711a
Removed upstreamed: pending-5.10/841-USB-serial-option-add-ZTE-MF286D-modem.patch[1] bcm27xx/950-0592-drm-vc4-Allow-DBLCLK-modes-even-if-horz-timing-is-od.patch[2] All other patches automatically rebased. 1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.10.101&id=7113440a36c741efd7c76e3d70b3634100120cdb 2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.10.101&id=21c890ca8eaecea06cabb92be2a53a6f26f56383 Build system: x86_64 Build-tested: bcm2711/RPi4B, mt7622/RT3200 Run-tested: bcm2711/RPi4B, mt7622/RT3200 Signed-off-by: John Audia <graysky@archlinux.us>
36 lines
1.1 KiB
Diff
36 lines
1.1 KiB
Diff
From 72d78ec8b6898976ea46b1c0cb9780707985cd80 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.com>
|
|
Date: Thu, 19 Aug 2021 14:28:56 +0100
|
|
Subject: [PATCH] Makefiles: dt: Always set '-@' on ARCH_BCM2835
|
|
|
|
On the BCM2835 architecture, always add the '-@' option to enable the
|
|
generation of symbols, rather than relying on DTC_FLAGS being empty
|
|
or correct.
|
|
|
|
See: https://github.com/raspberrypi/linux/issues/3846
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.com>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 2 +-
|
|
arch/arm64/boot/dts/broadcom/Makefile | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -1433,5 +1433,5 @@ subdir-y := overlays
|
|
|
|
# Enable fixups to support overlays on BCM2835 platforms
|
|
ifeq ($(CONFIG_ARCH_BCM2835),y)
|
|
- DTC_FLAGS ?= -@
|
|
+ DTC_FLAGS += -@
|
|
endif
|
|
--- a/arch/arm64/boot/dts/broadcom/Makefile
|
|
+++ b/arch/arm64/boot/dts/broadcom/Makefile
|
|
@@ -16,5 +16,5 @@ subdir-y += stingray
|
|
|
|
# Enable fixups to support overlays on BCM2835 platforms
|
|
ifeq ($(CONFIG_ARCH_BCM2835),y)
|
|
- DTC_FLAGS ?= -@
|
|
+ DTC_FLAGS += -@
|
|
endif
|