mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
f5919b65d4
Patch generation process: - rebase rpi/rpi-4.14.y on v4.14.89 from linux-stable - git format-patch v4.14.89 Patches skipped during rebase: - lan78xx: Read MAC address from DT if present - lan78xx: Enable LEDs and auto-negotiation - Revert "softirq: Let ksoftirqd do its job" - sc16is7xx: Fix for multi-channel stall - lan78xx: Ignore DT MAC address if already valid - lan78xx: Simple patch to prevent some crashes - tcp_write_queue_purge clears all the SKBs in the write queue - Revert "lan78xx: Simple patch to prevent some crashes" - lan78xx: Connect phy early - Arm: mm: ftrace: Only set text back to ro after kernel has been marked ro - Revert "Revert "softirq: Let ksoftirqd do its job"" - ASoC: cs4265: SOC_SINGLE register value error fix - Revert "ASoC: cs4265: SOC_SINGLE register value error fix" - Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends" - Revert "Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"" Patches dropped after rebase: - net: Add non-mainline source for rtl8192cu wlan - net: Fix rtl8192cu build errors on other platforms - brcm: adds support for BCM43341 wifi - brcmfmac: Mute expected startup 'errors' - ARM64: Fix build break for RTL8187/RTL8192CU wifi - ARM64: Enable RTL8187/RTL8192CU wifi in build config - This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator - brcmfmac: add CLM download support - brcmfmac: request_firmware_direct is quieter - Sets the BCDC priority to constant 0 - brcmfmac: Disable ARP offloading when promiscuous - brcmfmac: Avoid possible out-of-bounds read - brcmfmac: Delete redundant length check - net: rtl8192cu: Normalize indentation - net: rtl8192cu: Fix implicit fallthrough warnings - Revert "Sets the BCDC priority to constant 0" - media: cxd2880: Bump to match 4.18.y version - media: cxd2880-spi: Bump to match 4.18.y version - Revert "mm: alloc_contig: re-allow CMA to compact FS pages" - Revert "Revert "mm: alloc_contig: re-allow CMA to compact FS pages"" - cxd2880: CXD2880_SPI_DRV should select DVB_CXD2880 with MEDIA_SUBDRV_AUTOSELECT - 950-0421-HID-hid-bigbenff-driver-for-BigBen-Interactive-PS3OF.patch - 950-0453-Add-hid-bigbenff-to-list-of-have_special_driver-for-.patch Make I2C built-in instead of modular as in upstream defconfig; also the easiest way to get MFD_ARIZONA enabled, which is required by kmod-sound-soc-rpi-cirrus. Add missing compatible strings from 4.9/960-add-rasbperrypi-compatible.patch, using upstream names for compute modules. Add extra patch to enable the LEDs on lan78xx. Compile-tested: bcm2708, bcm2709, bcm2710 (with CONFIG_ALL_KMODS=y) Runtime-tested: bcm2708, bcm2710 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
115 lines
3.6 KiB
Diff
115 lines
3.6 KiB
Diff
From 498dfe7d12a047e4a3b466683b0b8138ea74ed9b Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Tue, 18 Sep 2018 11:08:07 +0100
|
|
Subject: [PATCH 417/454] BCM270X_DT: Add gpio-fan overlay
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 8 +++
|
|
.../boot/dts/overlays/gpio-fan-overlay.dts | 71 +++++++++++++++++++
|
|
3 files changed, 80 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/gpio-fan-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -35,6 +35,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
fe-pi-audio.dtbo \
|
|
goodix.dtbo \
|
|
googlevoicehat-soundcard.dtbo \
|
|
+ gpio-fan.dtbo \
|
|
gpio-ir.dtbo \
|
|
gpio-ir-tx.dtbo \
|
|
gpio-key.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -563,6 +563,14 @@ Load: dtoverlay=googlevoicehat-soundca
|
|
Params: <None>
|
|
|
|
|
|
+Name: gpio-fan
|
|
+Info: Configure a GPIO pin to control a cooling fan.
|
|
+Load: dtoverlay=gpio-fan,<param>=<val>
|
|
+Params: gpiopin GPIO used to control the fan (default 12)
|
|
+ temp Temperature at which the fan switches on, in
|
|
+ millicelcius (default 55000)
|
|
+
|
|
+
|
|
Name: gpio-ir
|
|
Info: Use GPIO pin as rc-core style infrared receiver input. The rc-core-
|
|
based gpio_ir_recv driver maps received keys directly to a
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/gpio-fan-overlay.dts
|
|
@@ -0,0 +1,71 @@
|
|
+/*
|
|
+ * Overlay for the Raspberry Pi GPIO Fan @ BCM GPIO12.
|
|
+ * Optional parameters:
|
|
+ * - "gpiopin" - default GPIO12
|
|
+ * - "temp" - default 55000
|
|
+ * Requires:
|
|
+ * - kernel configurations: CONFIG_SENSORS_GPIO_FAN=m and CONFIG_SENSORS_PWM_FAN=m;
|
|
+ * - kernel rebuid;
|
|
+ * - DC Fan connected to GPIO via a N-MOSFET (2N7002)
|
|
+ *
|
|
+ * ┌─────────────────────┐
|
|
+ * │Fan negative terminal│
|
|
+ * └┬────────────────────┘
|
|
+ * │
|
|
+ * │──┘
|
|
+ * [GPIO12]──────┤ │<─┐ 2N7002
|
|
+ * │──┤
|
|
+ * │
|
|
+ * ─┴─
|
|
+ * GND
|
|
+ *
|
|
+ * sudo dtc -W no-unit_address_vs_reg -@ -I dts -O dtb -o /boot/overlays/gpio-fan.dtbo gpio-fan.dts
|
|
+ * sudo nano /boot/config.txt add "dtoverlay=gpio-fan" or "dtoverlay=gpio-fan,gpiopin=12,temp=45000"
|
|
+ * or
|
|
+ * sudo sh -c "echo '\n# Enable PI GPIO-Fan\ndtoverlay=gpio-fan\n' >> /boot/config.txt"
|
|
+ * sudo sh -c "echo '\n# Enable PI GPIO-Fan\ndtoverlay=gpio-fan,gpiopin=12\n' >> /boot/config.txt"
|
|
+ *
|
|
+ */
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm2708";
|
|
+
|
|
+ fragment@0 {
|
|
+ target-path = "/";
|
|
+ __overlay__ {
|
|
+ fan0: gpio-fan@0 {
|
|
+ compatible = "gpio-fan";
|
|
+ gpios = <&gpio 12 1>;
|
|
+ gpio-fan,speed-map = <0 0>,
|
|
+ <5000 1>;
|
|
+ #cooling-cells = <2>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@1 {
|
|
+ target = <&cpu_thermal>;
|
|
+ polling-delay = <2000>; /* milliseconds */
|
|
+ __overlay__ {
|
|
+ trips {
|
|
+ cpu_hot: trip-point@0 {
|
|
+ temperature = <55000>; /* (millicelsius) Fan started at 55°C */
|
|
+ hysteresis = <5000>; /* (millicelsius) Fan stopped at 50°C */
|
|
+ type = "active";
|
|
+ };
|
|
+ };
|
|
+ cooling-maps {
|
|
+ map0 {
|
|
+ trip = <&cpu_hot>;
|
|
+ cooling-device = <&fan0 1 1>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ __overrides__ {
|
|
+ gpiopin = <&fan0>,"gpios:4", <&fan0>,"brcm,pins:0";
|
|
+ temp = <&cpu_hot>,"temperature:0";
|
|
+ };
|
|
+};
|