mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
f5919b65d4
Patch generation process: - rebase rpi/rpi-4.14.y on v4.14.89 from linux-stable - git format-patch v4.14.89 Patches skipped during rebase: - lan78xx: Read MAC address from DT if present - lan78xx: Enable LEDs and auto-negotiation - Revert "softirq: Let ksoftirqd do its job" - sc16is7xx: Fix for multi-channel stall - lan78xx: Ignore DT MAC address if already valid - lan78xx: Simple patch to prevent some crashes - tcp_write_queue_purge clears all the SKBs in the write queue - Revert "lan78xx: Simple patch to prevent some crashes" - lan78xx: Connect phy early - Arm: mm: ftrace: Only set text back to ro after kernel has been marked ro - Revert "Revert "softirq: Let ksoftirqd do its job"" - ASoC: cs4265: SOC_SINGLE register value error fix - Revert "ASoC: cs4265: SOC_SINGLE register value error fix" - Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends" - Revert "Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"" Patches dropped after rebase: - net: Add non-mainline source for rtl8192cu wlan - net: Fix rtl8192cu build errors on other platforms - brcm: adds support for BCM43341 wifi - brcmfmac: Mute expected startup 'errors' - ARM64: Fix build break for RTL8187/RTL8192CU wifi - ARM64: Enable RTL8187/RTL8192CU wifi in build config - This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator - brcmfmac: add CLM download support - brcmfmac: request_firmware_direct is quieter - Sets the BCDC priority to constant 0 - brcmfmac: Disable ARP offloading when promiscuous - brcmfmac: Avoid possible out-of-bounds read - brcmfmac: Delete redundant length check - net: rtl8192cu: Normalize indentation - net: rtl8192cu: Fix implicit fallthrough warnings - Revert "Sets the BCDC priority to constant 0" - media: cxd2880: Bump to match 4.18.y version - media: cxd2880-spi: Bump to match 4.18.y version - Revert "mm: alloc_contig: re-allow CMA to compact FS pages" - Revert "Revert "mm: alloc_contig: re-allow CMA to compact FS pages"" - cxd2880: CXD2880_SPI_DRV should select DVB_CXD2880 with MEDIA_SUBDRV_AUTOSELECT - 950-0421-HID-hid-bigbenff-driver-for-BigBen-Interactive-PS3OF.patch - 950-0453-Add-hid-bigbenff-to-list-of-have_special_driver-for-.patch Make I2C built-in instead of modular as in upstream defconfig; also the easiest way to get MFD_ARIZONA enabled, which is required by kmod-sound-soc-rpi-cirrus. Add missing compatible strings from 4.9/960-add-rasbperrypi-compatible.patch, using upstream names for compute modules. Add extra patch to enable the LEDs on lan78xx. Compile-tested: bcm2708, bcm2709, bcm2710 (with CONFIG_ALL_KMODS=y) Runtime-tested: bcm2708, bcm2710 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
122 lines
2.9 KiB
Diff
122 lines
2.9 KiB
Diff
From 09e843542826ad1241d77d5ef9abb2bce21a0984 Mon Sep 17 00:00:00 2001
|
|
From: Florin Sarbu <florin@resin.io>
|
|
Date: Mon, 30 Apr 2018 09:11:52 +0200
|
|
Subject: [PATCH 290/454] overlays: Add support for Balena Fin board
|
|
|
|
Signed-off-by: Florin Sarbu <florin@resin.io>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 7 ++
|
|
.../boot/dts/overlays/balena-fin-overlay.dts | 79 +++++++++++++++++++
|
|
3 files changed, 87 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/balena-fin-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -17,6 +17,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
audioinjector-addons.dtbo \
|
|
audioinjector-wm8731-audio.dtbo \
|
|
audremap.dtbo \
|
|
+ balena-fin.dtbo \
|
|
bmp085_i2c-sensor.dtbo \
|
|
dht11.dtbo \
|
|
dionaudio-loco.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -404,6 +404,13 @@ Params: swap_lr Reverse
|
|
(default off)
|
|
|
|
|
|
+Name: balena-fin
|
|
+Info: Overlay that enables WiFi, Bluetooth and the GPIO expander on the
|
|
+ Balena Fin board.
|
|
+Load: dtoverlay=balena-fin
|
|
+Params: <None>
|
|
+
|
|
+
|
|
Name: bmp085_i2c-sensor
|
|
Info: This overlay is now deprecated - see i2c-sensor
|
|
Load: dtoverlay=bmp085_i2c-sensor
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/balena-fin-overlay.dts
|
|
@@ -0,0 +1,79 @@
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/{
|
|
+ compatible = "brcm,bcm2708";
|
|
+
|
|
+ fragment@0 {
|
|
+ target = <&mmc>;
|
|
+ sdio_wifi: __overlay__ {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&sdio_pins>;
|
|
+ bus-width = <4>;
|
|
+ brcm,overclock-50 = <35>;
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@1 {
|
|
+ target = <&gpio>;
|
|
+ __overlay__ {
|
|
+ sdio_pins: sdio_pins {
|
|
+ brcm,pins = <34 35 36 37 38 39>;
|
|
+ brcm,function = <7>; /* ALT3 = SD1 */
|
|
+ brcm,pull = <0 2 2 2 2 2>;
|
|
+ };
|
|
+
|
|
+ power_ctrl_pins: power_ctrl_pins {
|
|
+ brcm,pins = <40>;
|
|
+ brcm,function = <1>; // out
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@2 {
|
|
+ target-path = "/";
|
|
+ __overlay__ {
|
|
+ // We should investigate how to switch to mmc-pwrseq-sd8787
|
|
+ // Currently that module requires two GPIOs to function since it
|
|
+ // targets a slightly different chip
|
|
+ power_ctrl: power_ctrl {
|
|
+ compatible = "gpio-poweroff";
|
|
+ gpios = <&gpio 40 1>;
|
|
+ force;
|
|
+ };
|
|
+
|
|
+ i2c_soft: i2c@0 {
|
|
+ compatible = "i2c-gpio";
|
|
+ gpios = <&gpio 43 0 /* sda */ &gpio 42 0 /* scl */>;
|
|
+ i2c-gpio,delay-us = <2>; /* ~100 kHz */
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@3 {
|
|
+ target = <&i2c_soft>;
|
|
+ __overlay__ {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ status = "okay";
|
|
+
|
|
+ gpio_expander: gpio_expander@20 {
|
|
+ compatible = "nxp,pca9554";
|
|
+ gpio-controller;
|
|
+ #gpio-cells = <2>;
|
|
+ reg = <0x20>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ // rtc clock
|
|
+ ds1307: ds1307@68 {
|
|
+ compatible = "maxim,ds1307";
|
|
+ reg = <0x68>;
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|