mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
f5919b65d4
Patch generation process: - rebase rpi/rpi-4.14.y on v4.14.89 from linux-stable - git format-patch v4.14.89 Patches skipped during rebase: - lan78xx: Read MAC address from DT if present - lan78xx: Enable LEDs and auto-negotiation - Revert "softirq: Let ksoftirqd do its job" - sc16is7xx: Fix for multi-channel stall - lan78xx: Ignore DT MAC address if already valid - lan78xx: Simple patch to prevent some crashes - tcp_write_queue_purge clears all the SKBs in the write queue - Revert "lan78xx: Simple patch to prevent some crashes" - lan78xx: Connect phy early - Arm: mm: ftrace: Only set text back to ro after kernel has been marked ro - Revert "Revert "softirq: Let ksoftirqd do its job"" - ASoC: cs4265: SOC_SINGLE register value error fix - Revert "ASoC: cs4265: SOC_SINGLE register value error fix" - Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends" - Revert "Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"" Patches dropped after rebase: - net: Add non-mainline source for rtl8192cu wlan - net: Fix rtl8192cu build errors on other platforms - brcm: adds support for BCM43341 wifi - brcmfmac: Mute expected startup 'errors' - ARM64: Fix build break for RTL8187/RTL8192CU wifi - ARM64: Enable RTL8187/RTL8192CU wifi in build config - This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator - brcmfmac: add CLM download support - brcmfmac: request_firmware_direct is quieter - Sets the BCDC priority to constant 0 - brcmfmac: Disable ARP offloading when promiscuous - brcmfmac: Avoid possible out-of-bounds read - brcmfmac: Delete redundant length check - net: rtl8192cu: Normalize indentation - net: rtl8192cu: Fix implicit fallthrough warnings - Revert "Sets the BCDC priority to constant 0" - media: cxd2880: Bump to match 4.18.y version - media: cxd2880-spi: Bump to match 4.18.y version - Revert "mm: alloc_contig: re-allow CMA to compact FS pages" - Revert "Revert "mm: alloc_contig: re-allow CMA to compact FS pages"" - cxd2880: CXD2880_SPI_DRV should select DVB_CXD2880 with MEDIA_SUBDRV_AUTOSELECT - 950-0421-HID-hid-bigbenff-driver-for-BigBen-Interactive-PS3OF.patch - 950-0453-Add-hid-bigbenff-to-list-of-have_special_driver-for-.patch Make I2C built-in instead of modular as in upstream defconfig; also the easiest way to get MFD_ARIZONA enabled, which is required by kmod-sound-soc-rpi-cirrus. Add missing compatible strings from 4.9/960-add-rasbperrypi-compatible.patch, using upstream names for compute modules. Add extra patch to enable the LEDs on lan78xx. Compile-tested: bcm2708, bcm2709, bcm2710 (with CONFIG_ALL_KMODS=y) Runtime-tested: bcm2708, bcm2710 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
148 lines
3.9 KiB
Diff
148 lines
3.9 KiB
Diff
From 98f993e9d2b66f3219ac9841ad836ef79a341908 Mon Sep 17 00:00:00 2001
|
|
From: RF William Hollender <whollender@gmail.com>
|
|
Date: Sun, 18 Feb 2018 14:41:43 -0600
|
|
Subject: [PATCH 219/454] Add support for SuperAudioBoard sound card (#2386)
|
|
|
|
SuperAudioBoard support using simple-audio-card driver.
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 6 ++
|
|
.../dts/overlays/superaudioboard-overlay.dts | 73 +++++++++++++++++++
|
|
arch/arm/configs/bcm2709_defconfig | 1 +
|
|
arch/arm/configs/bcmrpi_defconfig | 1 +
|
|
arch/arm64/configs/bcmrpi3_defconfig | 1 +
|
|
6 files changed, 83 insertions(+)
|
|
create mode 100755 arch/arm/boot/dts/overlays/superaudioboard-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -118,6 +118,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
spi2-1cs.dtbo \
|
|
spi2-2cs.dtbo \
|
|
spi2-3cs.dtbo \
|
|
+ superaudioboard.dtbo \
|
|
tinylcd35.dtbo \
|
|
uart0.dtbo \
|
|
uart1.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -1658,6 +1658,12 @@ Params: cs0_pin GPIO pin
|
|
is 'okay' or enabled).
|
|
|
|
|
|
+Name: superaudioboard
|
|
+Info: Configures the SuperAudioBoard sound card
|
|
+Load: dtoverlay=superaudioboard,<param>=<val>
|
|
+Params: gpiopin GPIO pin for codec reset
|
|
+
|
|
+
|
|
Name: tinylcd35
|
|
Info: 3.5" Color TFT Display by www.tinylcd.com
|
|
Options: Touch, RTC, keypad
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/superaudioboard-overlay.dts
|
|
@@ -0,0 +1,73 @@
|
|
+// Definitions for SuperAudioBoard
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm2708";
|
|
+
|
|
+ fragment@0 {
|
|
+ target = <&sound>;
|
|
+ __overlay__ {
|
|
+ compatible = "simple-audio-card";
|
|
+ i2s-controller = <&i2s>;
|
|
+ status = "okay";
|
|
+
|
|
+ simple-audio-card,name = "SuperAudioBoard";
|
|
+
|
|
+ simple-audio-card,widgets =
|
|
+ "Line", "Line In",
|
|
+ "Line", "Line Out";
|
|
+
|
|
+ simple-audio-card,routing =
|
|
+ "Line Out","AOUTA+",
|
|
+ "Line Out","AOUTA-",
|
|
+ "Line Out","AOUTB+",
|
|
+ "Line Out","AOUTB-",
|
|
+ "AINA","Line In",
|
|
+ "AINB","Line In";
|
|
+
|
|
+ simple-audio-card,format = "i2s";
|
|
+
|
|
+ simple-audio-card,bitclock-master = <&sound_master>;
|
|
+ simple-audio-card,frame-master = <&sound_master>;
|
|
+
|
|
+ simple-audio-card,cpu {
|
|
+ sound-dai = <&i2s>;
|
|
+ dai-tdm-slot-num = <2>;
|
|
+ dai-tdm-slot-width = <32>;
|
|
+ };
|
|
+
|
|
+ sound_master: simple-audio-card,codec {
|
|
+ sound-dai = <&cs4271>;
|
|
+ system-clock-frequency = <24576000>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@1 {
|
|
+ target = <&i2s>;
|
|
+ __overlay__ {
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@2 {
|
|
+ target = <&i2c1>;
|
|
+ __overlay__ {
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ status = "okay";
|
|
+
|
|
+ cs4271: cs4271@10 {
|
|
+ #sound-dai-cells = <0>;
|
|
+ compatible = "cirrus,cs4271";
|
|
+ reg = <0x10>;
|
|
+ status = "okay";
|
|
+ reset-gpio = <&gpio 26 0>; /* Pin 26, active high */
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ __overrides__ {
|
|
+ gpiopin = <&cs4271>,"reset-gpio:4";
|
|
+ };
|
|
+};
|
|
--- a/arch/arm/configs/bcm2709_defconfig
|
|
+++ b/arch/arm/configs/bcm2709_defconfig
|
|
@@ -895,6 +895,7 @@ CONFIG_SND_PISOUND=m
|
|
CONFIG_SND_SOC_ADAU1701=m
|
|
CONFIG_SND_SOC_ADAU7002=m
|
|
CONFIG_SND_SOC_AK4554=m
|
|
+CONFIG_SND_SOC_CS4271_I2C=m
|
|
CONFIG_SND_SOC_SPDIF=m
|
|
CONFIG_SND_SOC_WM8804_I2C=m
|
|
CONFIG_SND_SIMPLE_CARD=m
|
|
--- a/arch/arm/configs/bcmrpi_defconfig
|
|
+++ b/arch/arm/configs/bcmrpi_defconfig
|
|
@@ -888,6 +888,7 @@ CONFIG_SND_PISOUND=m
|
|
CONFIG_SND_SOC_ADAU1701=m
|
|
CONFIG_SND_SOC_ADAU7002=m
|
|
CONFIG_SND_SOC_AK4554=m
|
|
+CONFIG_SND_SOC_CS4271_I2C=m
|
|
CONFIG_SND_SOC_SPDIF=m
|
|
CONFIG_SND_SOC_WM8804_I2C=m
|
|
CONFIG_SND_SIMPLE_CARD=m
|
|
--- a/arch/arm64/configs/bcmrpi3_defconfig
|
|
+++ b/arch/arm64/configs/bcmrpi3_defconfig
|
|
@@ -870,6 +870,7 @@ CONFIG_SND_BCM2708_SOC_ALLO_PIANO_DAC=m
|
|
CONFIG_SND_PISOUND=m
|
|
CONFIG_SND_SOC_ADAU1701=m
|
|
CONFIG_SND_SOC_AK4554=m
|
|
+CONFIG_SND_SOC_CS4271_I2C=m
|
|
CONFIG_SND_SOC_WM8804_I2C=m
|
|
CONFIG_SND_SIMPLE_CARD=m
|
|
CONFIG_SOUND_PRIME=m
|