mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-30 02:29:01 +00:00
7d7aa2fd92
This change makes the names of Broadcom targets consistent by using the common notation based on SoC/CPU ID (which is used internally anyway), bcmXXXX instead of brcmXXXX. This is even used for target TITLE in make menuconfig already, only the short target name used brcm so far. Despite, since subtargets range from bcm2708 to bcm2711, it seems appropriate to use bcm27xx instead of bcm2708 (again, as already done for BOARDNAME). This also renames the packages brcm2708-userland and brcm2708-gpu-fw. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Álvaro Fernández Rojas <noltari@gmail.com>
61 lines
1.9 KiB
Diff
61 lines
1.9 KiB
Diff
From afe88750090d60d94b365250968e116ec88448c1 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Wed, 18 Jul 2018 17:25:00 +0100
|
|
Subject: [PATCH] overlays: Add gpio-no-bank0-irq overlay
|
|
|
|
See: https://github.com/raspberrypi/linux/issues/2590
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 9 +++++++++
|
|
.../dts/overlays/gpio-no-bank0-irq-overlay.dts | 14 ++++++++++++++
|
|
3 files changed, 24 insertions(+)
|
|
create mode 100755 arch/arm/boot/dts/overlays/gpio-no-bank0-irq-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -37,6 +37,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
gpio-ir.dtbo \
|
|
gpio-ir-tx.dtbo \
|
|
gpio-key.dtbo \
|
|
+ gpio-no-bank0-irq.dtbo \
|
|
gpio-no-irq.dtbo \
|
|
gpio-poweroff.dtbo \
|
|
gpio-shutdown.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -597,6 +597,15 @@ Params: gpio GPIO pin
|
|
keycode Set the key code for the button
|
|
|
|
|
|
+Name: gpio-no-bank0-irq
|
|
+Info: Use this overlay to disable GPIO interrupts for GPIOs in bank 0 (0-27),
|
|
+ which can be useful for UIO drivers.
|
|
+ N.B. Using this overlay will trigger a kernel WARN during booting, but
|
|
+ this can safely be ignored - the system should work as expected.
|
|
+Load: dtoverlay=gpio-no-bank0-irq
|
|
+Params: <None>
|
|
+
|
|
+
|
|
Name: gpio-no-irq
|
|
Info: Use this overlay to disable all GPIO interrupts, which can be useful
|
|
for user-space GPIO edge detection systems.
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/gpio-no-bank0-irq-overlay.dts
|
|
@@ -0,0 +1,14 @@
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm2835";
|
|
+
|
|
+ fragment@0 {
|
|
+ // Configure the gpio pin controller
|
|
+ target = <&gpio>;
|
|
+ __overlay__ {
|
|
+ interrupts = <255 255>, <2 18>;
|
|
+ };
|
|
+ };
|
|
+};
|