mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
aa3b6a08c5
The ledtrig-netdev was added to upstream Linux kernel 4.16, replace our own version with the patch based on the upstream version. This will remove the ledtrig-netdev support from kernel 3.18, because I not want to spend time on backporting it to 3.18. This will make it easier to use the upstream version with kernel 4.19, by just not applying this patch. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
23 lines
684 B
Diff
23 lines
684 B
Diff
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -508,4 +508,12 @@ config LEDS_VERSATILE
|
|
comment "LED Triggers"
|
|
source "drivers/leds/trigger/Kconfig"
|
|
|
|
+config LEDS_TRIGGER_ADM5120_SWITCH
|
|
+ tristate "LED ADM5120 Switch Port Status Trigger"
|
|
+ depends on LEDS_TRIGGERS && ADM5120
|
|
+ help
|
|
+ This allows LEDs to be controlled by the port states of
|
|
+ the ADM5120 built-in Ethernet Switch
|
|
+ If unsure, say N.
|
|
+
|
|
endif # NEW_LEDS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -62,3 +62,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-d
|
|
|
|
# LED Triggers
|
|
obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
|
|
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o
|