mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
51 lines
1.7 KiB
Diff
51 lines
1.7 KiB
Diff
From decd99704aba1800c3e62a7ed1f5cbd9c5f6526a Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Fri, 29 Sep 2017 10:32:19 +0100
|
|
Subject: [PATCH] amba_pl011: Add cts-event-workaround DT property
|
|
|
|
The BCM2835 PL011 implementation seems to have a bug that can lead to a
|
|
transmission lockup if CTS changes frequently. A workaround was added to
|
|
the driver with a vendor-specific flag to enable it, but this flag is
|
|
currently not set for ARM implementations.
|
|
|
|
Add a "cts-event-workaround" property to Pi DTBs and use the presence
|
|
of that property to force the flag to be enabled in the driver.
|
|
|
|
See: https://github.com/raspberrypi/linux/issues/1280
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
Documentation/devicetree/bindings/serial/pl011.yaml | 6 ++++++
|
|
drivers/tty/serial/amba-pl011.c | 5 +++++
|
|
2 files changed, 11 insertions(+)
|
|
|
|
--- a/Documentation/devicetree/bindings/serial/pl011.yaml
|
|
+++ b/Documentation/devicetree/bindings/serial/pl011.yaml
|
|
@@ -91,6 +91,12 @@ properties:
|
|
3000ms.
|
|
default: 3000
|
|
|
|
+ cts-event-workaround:
|
|
+ description:
|
|
+ Enables the (otherwise vendor-specific) workaround for the
|
|
+ CTS-induced TX lockup.
|
|
+ type: boolean
|
|
+
|
|
required:
|
|
- compatible
|
|
- reg
|
|
--- a/drivers/tty/serial/amba-pl011.c
|
|
+++ b/drivers/tty/serial/amba-pl011.c
|
|
@@ -2847,6 +2847,11 @@ static int pl011_probe(struct amba_devic
|
|
if (IS_ERR(uap->clk))
|
|
return PTR_ERR(uap->clk);
|
|
|
|
+ if (of_property_read_bool(dev->dev.of_node, "cts-event-workaround")) {
|
|
+ vendor->cts_event_workaround = true;
|
|
+ dev_info(&dev->dev, "cts_event_workaround enabled\n");
|
|
+ }
|
|
+
|
|
uap->reg_offset = vendor->reg_offset;
|
|
uap->vendor = vendor;
|
|
uap->fifosize = vendor->get_fifosize(dev);
|