mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
87 lines
2.5 KiB
Diff
87 lines
2.5 KiB
Diff
From 307744a359bddf354711e54836e4757788c9dfc4 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Wed, 1 Mar 2017 16:07:39 +0000
|
|
Subject: [PATCH] amba_pl011: Round input clock up
|
|
|
|
The UART clock is initialised to be as close to the requested
|
|
frequency as possible without exceeding it. Now that there is a
|
|
clock manager that returns the actual frequencies, an expected
|
|
48MHz clock is reported as 47999625. If the requested baudrate
|
|
== requested clock/16, there is no headroom and the slight
|
|
reduction in actual clock rate results in failure.
|
|
|
|
Detect cases where it looks like a "round" clock was chosen and
|
|
adjust the reported clock to match that "round" value. As the
|
|
code comment says:
|
|
|
|
/*
|
|
* If increasing a clock by less than 0.1% changes it
|
|
* from ..999.. to ..000.., round up.
|
|
*/
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
drivers/tty/serial/amba-pl011.c | 23 +++++++++++++++++++++--
|
|
1 file changed, 21 insertions(+), 2 deletions(-)
|
|
|
|
--- a/drivers/tty/serial/amba-pl011.c
|
|
+++ b/drivers/tty/serial/amba-pl011.c
|
|
@@ -1730,6 +1730,23 @@ static void pl011_put_poll_char(struct u
|
|
|
|
#endif /* CONFIG_CONSOLE_POLL */
|
|
|
|
+unsigned long pl011_clk_round(unsigned long clk)
|
|
+{
|
|
+ unsigned long scaler;
|
|
+
|
|
+ /*
|
|
+ * If increasing a clock by less than 0.1% changes it
|
|
+ * from ..999.. to ..000.., round up.
|
|
+ */
|
|
+ scaler = 1;
|
|
+ while (scaler * 100000 < clk)
|
|
+ scaler *= 10;
|
|
+ if ((clk + scaler - 1)/scaler % 1000 == 0)
|
|
+ clk = (clk/scaler + 1) * scaler;
|
|
+
|
|
+ return clk;
|
|
+}
|
|
+
|
|
static int pl011_hwinit(struct uart_port *port)
|
|
{
|
|
struct uart_amba_port *uap =
|
|
@@ -1746,7 +1763,7 @@ static int pl011_hwinit(struct uart_port
|
|
if (retval)
|
|
return retval;
|
|
|
|
- uap->port.uartclk = clk_get_rate(uap->clk);
|
|
+ uap->port.uartclk = pl011_clk_round(clk_get_rate(uap->clk));
|
|
|
|
/* Clear pending error and receive interrupts */
|
|
pl011_write(UART011_OEIS | UART011_BEIS | UART011_PEIS |
|
|
@@ -2452,7 +2469,7 @@ static int pl011_console_setup(struct co
|
|
plat->init();
|
|
}
|
|
|
|
- uap->port.uartclk = clk_get_rate(uap->clk);
|
|
+ uap->port.uartclk = pl011_clk_round(clk_get_rate(uap->clk));
|
|
|
|
if (uap->vendor->fixed_options) {
|
|
baud = uap->fixed_baud;
|
|
@@ -2669,6 +2686,7 @@ static struct uart_driver amba_reg = {
|
|
.cons = AMBA_CONSOLE,
|
|
};
|
|
|
|
+#if 0
|
|
static int pl011_probe_dt_alias(int index, struct device *dev)
|
|
{
|
|
struct device_node *np;
|
|
@@ -2700,6 +2718,7 @@ static int pl011_probe_dt_alias(int inde
|
|
|
|
return ret;
|
|
}
|
|
+#endif
|
|
|
|
/* unregisters the driver also if no more ports are left */
|
|
static void pl011_unregister_port(struct uart_amba_port *uap)
|