mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 06:57:57 +00:00
8299d1f057
Rebased RPi foundation patches on linux 5.10.59, removed applied and reverted patches, wireless patches and defconfig patches. bcm2708: boot tested on RPi B+ v1.2 bcm2709: boot tested on RPi 4B v1.1 4G bcm2711: boot tested on RPi 4B v1.1 4G Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
36 lines
1.1 KiB
Diff
36 lines
1.1 KiB
Diff
From 72d78ec8b6898976ea46b1c0cb9780707985cd80 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.com>
|
|
Date: Thu, 19 Aug 2021 14:28:56 +0100
|
|
Subject: [PATCH] Makefiles: dt: Always set '-@' on ARCH_BCM2835
|
|
|
|
On the BCM2835 architecture, always add the '-@' option to enable the
|
|
generation of symbols, rather than relying on DTC_FLAGS being empty
|
|
or correct.
|
|
|
|
See: https://github.com/raspberrypi/linux/issues/3846
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.com>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 2 +-
|
|
arch/arm64/boot/dts/broadcom/Makefile | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -1432,5 +1432,5 @@ subdir-y := overlays
|
|
|
|
# Enable fixups to support overlays on BCM2835 platforms
|
|
ifeq ($(CONFIG_ARCH_BCM2835),y)
|
|
- DTC_FLAGS ?= -@
|
|
+ DTC_FLAGS += -@
|
|
endif
|
|
--- a/arch/arm64/boot/dts/broadcom/Makefile
|
|
+++ b/arch/arm64/boot/dts/broadcom/Makefile
|
|
@@ -16,5 +16,5 @@ subdir-y += stingray
|
|
|
|
# Enable fixups to support overlays on BCM2835 platforms
|
|
ifeq ($(CONFIG_ARCH_BCM2835),y)
|
|
- DTC_FLAGS ?= -@
|
|
+ DTC_FLAGS += -@
|
|
endif
|