mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-25 13:49:26 +00:00
703515f889
Includes the following changes: 9edff13abd mac80211: disable potentially harmful PS software retry for A-MPDU sessions 75216a76b0 mac80211: backport upstream fix for CSA in IBSS mode 368cc8ef47 mac80211: update brcmfmac backporting brcmf_err cleanups 66a63d25c4 mac80211: fix build on linux 3.18 9eacb9d7fc rt2x00: mt7620: lots of improvements fd94fa61a7 mac80211: brcmfmac: update Raspberry Pi patches for linux 4.9 649e766a64 mac80211: update to wireless-testing 2017-01-31 47540afa5d ath9k: add a warning to the tx99 config option b367eef21d mac80211: rt2x00: add support for external LNA on MT7620 9200e168f2 mac80211: move (& update) upstream accepted brcmfmac patches Signed-off-by: Felix Fietkau <nbd@nbd.name>
32 lines
891 B
Diff
32 lines
891 B
Diff
--- a/drivers/net/wireless/ath/Makefile
|
|
+++ b/drivers/net/wireless/ath/Makefile
|
|
@@ -13,10 +13,10 @@ ath-objs := main.o \
|
|
regd.o \
|
|
hw.o \
|
|
key.o \
|
|
+ debug.o \
|
|
dfs_pattern_detector.o \
|
|
dfs_pri_detector.o
|
|
|
|
-ath-$(CPTCFG_ATH_DEBUG) += debug.o
|
|
ath-$(CPTCFG_ATH_TRACEPOINTS) += trace.o
|
|
|
|
CFLAGS_trace.o := -I$(src)
|
|
--- a/drivers/net/wireless/ath/ath.h
|
|
+++ b/drivers/net/wireless/ath/ath.h
|
|
@@ -318,14 +318,7 @@ void _ath_dbg(struct ath_common *common,
|
|
#endif /* CPTCFG_ATH_DEBUG */
|
|
|
|
/** Returns string describing opmode, or NULL if unknown mode. */
|
|
-#ifdef CPTCFG_ATH_DEBUG
|
|
const char *ath_opmode_to_string(enum nl80211_iftype opmode);
|
|
-#else
|
|
-static inline const char *ath_opmode_to_string(enum nl80211_iftype opmode)
|
|
-{
|
|
- return "UNKNOWN";
|
|
-}
|
|
-#endif
|
|
|
|
extern const char *ath_bus_type_strings[];
|
|
static inline const char *ath_bus_type_to_string(enum ath_bus_type bustype)
|