mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-02 20:16:59 +00:00
d7d8665572
SVN-Revision: 11006
15 lines
495 B
Diff
15 lines
495 B
Diff
Index: linux-2.6.25.1/Makefile
|
|
===================================================================
|
|
--- linux-2.6.25.1.orig/Makefile
|
|
+++ linux-2.6.25.1/Makefile
|
|
@@ -533,6 +533,9 @@ endif
|
|
NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
|
|
CHECKFLAGS += $(NOSTDINC_FLAGS)
|
|
|
|
+# improve gcc optimization
|
|
+CFLAGS += $(call cc-option,-funit-at-a-time,)
|
|
+
|
|
# warn about C99 declaration after statement
|
|
KBUILD_CFLAGS += $(call cc-option,-Wdeclaration-after-statement,)
|
|
|