mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 00:41:17 +00:00
99545b4bb1
This target adds support for the Allwinner D1 RISC-V based SoCs. - RISC-V single-core T-Head C906 (RV64GCV) - Tensilica HiFi4 DSP - DDR2/DDR3 support - 10/100/1000M ethernet - usual peripherals like USB2, SPI, I2C, PWM, etc. Four boards are supported: - Dongshan Nezha STU - 512Mb RAM - ethernet - LicheePi RV Dock - 512Mb RAM - wireless-only (RTL8723DS) - MangoPi MQ-Pro - 512Mb RAM - there are pads available for an SPI flash - wireless-only (RTL8723DS) - Nezha D1 - 512Mb/1Gb/2Gb RAM - 256Mb NAND flash - ethernet, wireless Installation: Standard SD-card installation via dd-ing the generated image to an SD-card of at least 256Mb. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
345 lines
8.3 KiB
Diff
345 lines
8.3 KiB
Diff
From 3bf76e93011425ed64a69c462b9959ed2a8ccf46 Mon Sep 17 00:00:00 2001
|
|
From: Samuel Holland <samuel@sholland.org>
|
|
Date: Wed, 29 Jun 2022 00:13:50 -0500
|
|
Subject: [PATCH 030/117] riscv: dts: allwinner: Add Sipeed Lichee RV
|
|
devicetrees
|
|
|
|
Sipeed manufactures a "Lichee RV" system-on-module, which provides a
|
|
minimal working system on its own, as well as a few carrier boards. The
|
|
"Dock" board provides audio, USB, and WiFi. The "86 Panel" additionally
|
|
provides 100M Ethernet and a built-in display panel.
|
|
|
|
The 86 Panel repurposes the USB ID and VBUS detection GPIOs for its RGB
|
|
panel interface, since the USB OTG port is inaccessible inside the case.
|
|
|
|
Co-developed-by: Jisheng Zhang <jszhang@kernel.org>
|
|
Signed-off-by: Jisheng Zhang <jszhang@kernel.org>
|
|
Signed-off-by: Samuel Holland <samuel@sholland.org>
|
|
---
|
|
arch/riscv/boot/dts/allwinner/Makefile | 4 +
|
|
.../sun20i-d1-lichee-rv-86-panel-480p.dts | 29 ++++++
|
|
.../sun20i-d1-lichee-rv-86-panel-720p.dts | 10 ++
|
|
.../sun20i-d1-lichee-rv-86-panel.dtsi | 92 +++++++++++++++++++
|
|
.../allwinner/sun20i-d1-lichee-rv-dock.dts | 74 +++++++++++++++
|
|
.../dts/allwinner/sun20i-d1-lichee-rv.dts | 84 +++++++++++++++++
|
|
6 files changed, 293 insertions(+)
|
|
create mode 100644 arch/riscv/boot/dts/allwinner/sun20i-d1-lichee-rv-86-panel-480p.dts
|
|
create mode 100644 arch/riscv/boot/dts/allwinner/sun20i-d1-lichee-rv-86-panel-720p.dts
|
|
create mode 100644 arch/riscv/boot/dts/allwinner/sun20i-d1-lichee-rv-86-panel.dtsi
|
|
create mode 100644 arch/riscv/boot/dts/allwinner/sun20i-d1-lichee-rv-dock.dts
|
|
create mode 100644 arch/riscv/boot/dts/allwinner/sun20i-d1-lichee-rv.dts
|
|
|
|
--- a/arch/riscv/boot/dts/allwinner/Makefile
|
|
+++ b/arch/riscv/boot/dts/allwinner/Makefile
|
|
@@ -1,2 +1,6 @@
|
|
# SPDX-License-Identifier: GPL-2.0
|
|
+dtb-$(CONFIG_ARCH_SUNXI) += sun20i-d1-lichee-rv-86-panel-480p.dtb
|
|
+dtb-$(CONFIG_ARCH_SUNXI) += sun20i-d1-lichee-rv-86-panel-720p.dtb
|
|
+dtb-$(CONFIG_ARCH_SUNXI) += sun20i-d1-lichee-rv-dock.dtb
|
|
+dtb-$(CONFIG_ARCH_SUNXI) += sun20i-d1-lichee-rv.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun20i-d1-nezha.dtb
|
|
--- /dev/null
|
|
+++ b/arch/riscv/boot/dts/allwinner/sun20i-d1-lichee-rv-86-panel-480p.dts
|
|
@@ -0,0 +1,29 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ or MIT)
|
|
+// Copyright (C) 2022 Samuel Holland <samuel@sholland.org>
|
|
+
|
|
+#include "sun20i-d1-lichee-rv-86-panel.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "Sipeed Lichee RV 86 Panel (480p)";
|
|
+ compatible = "sipeed,lichee-rv-86-panel-480p", "sipeed,lichee-rv",
|
|
+ "allwinner,sun20i-d1";
|
|
+};
|
|
+
|
|
+&i2c2 {
|
|
+ pinctrl-0 = <&i2c2_pb0_pins>;
|
|
+ pinctrl-names = "default";
|
|
+ status = "okay";
|
|
+
|
|
+ touchscreen@48 {
|
|
+ compatible = "focaltech,ft6236";
|
|
+ reg = <0x48>;
|
|
+ interrupt-parent = <&pio>;
|
|
+ interrupts = <6 14 IRQ_TYPE_LEVEL_LOW>; /* PG14 */
|
|
+ iovcc-supply = <®_vcc_3v3>;
|
|
+ reset-gpios = <&pio 6 15 GPIO_ACTIVE_LOW>; /* PG15 */
|
|
+ touchscreen-size-x = <480>;
|
|
+ touchscreen-size-y = <480>;
|
|
+ vcc-supply = <®_vcc_3v3>;
|
|
+ wakeup-source;
|
|
+ };
|
|
+};
|
|
--- /dev/null
|
|
+++ b/arch/riscv/boot/dts/allwinner/sun20i-d1-lichee-rv-86-panel-720p.dts
|
|
@@ -0,0 +1,10 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ or MIT)
|
|
+// Copyright (C) 2022 Samuel Holland <samuel@sholland.org>
|
|
+
|
|
+#include "sun20i-d1-lichee-rv-86-panel.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "Sipeed Lichee RV 86 Panel (720p)";
|
|
+ compatible = "sipeed,lichee-rv-86-panel-720p", "sipeed,lichee-rv",
|
|
+ "allwinner,sun20i-d1";
|
|
+};
|
|
--- /dev/null
|
|
+++ b/arch/riscv/boot/dts/allwinner/sun20i-d1-lichee-rv-86-panel.dtsi
|
|
@@ -0,0 +1,92 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ or MIT)
|
|
+// Copyright (C) 2022 Samuel Holland <samuel@sholland.org>
|
|
+
|
|
+#include "sun20i-d1-lichee-rv.dts"
|
|
+
|
|
+/ {
|
|
+ aliases {
|
|
+ ethernet0 = &emac;
|
|
+ ethernet1 = &xr829;
|
|
+ };
|
|
+
|
|
+ /* PC1 is repurposed as BT_WAKE_AP */
|
|
+ /delete-node/ leds;
|
|
+
|
|
+ wifi_pwrseq: wifi-pwrseq {
|
|
+ compatible = "mmc-pwrseq-simple";
|
|
+ clocks = <&ccu CLK_FANOUT1>;
|
|
+ clock-names = "ext_clock";
|
|
+ reset-gpios = <&pio 6 12 GPIO_ACTIVE_LOW>; /* PG12 */
|
|
+ assigned-clocks = <&ccu CLK_FANOUT1>;
|
|
+ assigned-clock-rates = <32768>;
|
|
+ pinctrl-0 = <&clk_pg11_pin>;
|
|
+ pinctrl-names = "default";
|
|
+ };
|
|
+};
|
|
+
|
|
+&ehci1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&emac {
|
|
+ pinctrl-0 = <&rmii_pe_pins>;
|
|
+ pinctrl-names = "default";
|
|
+ phy-handle = <&ext_rmii_phy>;
|
|
+ phy-mode = "rmii";
|
|
+ phy-supply = <®_vcc_3v3>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mdio {
|
|
+ ext_rmii_phy: ethernet-phy@1 {
|
|
+ compatible = "ethernet-phy-ieee802.3-c22";
|
|
+ reg = <1>;
|
|
+ reset-gpios = <&pio 4 16 GPIO_ACTIVE_LOW>; /* PE16 */
|
|
+ };
|
|
+};
|
|
+
|
|
+&mmc1 {
|
|
+ bus-width = <4>;
|
|
+ mmc-pwrseq = <&wifi_pwrseq>;
|
|
+ non-removable;
|
|
+ vmmc-supply = <®_vcc_3v3>;
|
|
+ vqmmc-supply = <®_vcc_3v3>;
|
|
+ pinctrl-0 = <&mmc1_pins>;
|
|
+ pinctrl-names = "default";
|
|
+ status = "okay";
|
|
+
|
|
+ xr829: wifi@1 {
|
|
+ reg = <1>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ohci1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&pio {
|
|
+ clk_pg11_pin: clk-pg11-pin {
|
|
+ pins = "PG11";
|
|
+ function = "clk";
|
|
+ };
|
|
+};
|
|
+
|
|
+&uart1 {
|
|
+ uart-has-rtscts;
|
|
+ pinctrl-0 = <&uart1_pg6_pins>, <&uart1_pg8_rts_cts_pins>;
|
|
+ pinctrl-names = "default";
|
|
+ status = "okay";
|
|
+
|
|
+ /* XR829 bluetooth is connected here */
|
|
+};
|
|
+
|
|
+&usb_otg {
|
|
+ status = "disabled";
|
|
+};
|
|
+
|
|
+&usbphy {
|
|
+ /* PD20 and PD21 are repurposed for the LCD panel */
|
|
+ /delete-property/ usb0_id_det-gpios;
|
|
+ /delete-property/ usb0_vbus_det-gpios;
|
|
+ usb1_vbus-supply = <®_vcc>;
|
|
+};
|
|
--- /dev/null
|
|
+++ b/arch/riscv/boot/dts/allwinner/sun20i-d1-lichee-rv-dock.dts
|
|
@@ -0,0 +1,74 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ or MIT)
|
|
+// Copyright (C) 2022 Jisheng Zhang <jszhang@kernel.org>
|
|
+// Copyright (C) 2022 Samuel Holland <samuel@sholland.org>
|
|
+
|
|
+#include <dt-bindings/input/input.h>
|
|
+
|
|
+#include "sun20i-d1-lichee-rv.dts"
|
|
+
|
|
+/ {
|
|
+ model = "Sipeed Lichee RV Dock";
|
|
+ compatible = "sipeed,lichee-rv-dock", "sipeed,lichee-rv",
|
|
+ "allwinner,sun20i-d1";
|
|
+
|
|
+ aliases {
|
|
+ ethernet1 = &rtl8723ds;
|
|
+ };
|
|
+
|
|
+ wifi_pwrseq: wifi-pwrseq {
|
|
+ compatible = "mmc-pwrseq-simple";
|
|
+ reset-gpios = <&pio 6 12 GPIO_ACTIVE_LOW>; /* PG12 */
|
|
+ };
|
|
+};
|
|
+
|
|
+&ehci1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&lradc {
|
|
+ status = "okay";
|
|
+
|
|
+ button-220 {
|
|
+ label = "OK";
|
|
+ linux,code = <KEY_OK>;
|
|
+ channel = <0>;
|
|
+ voltage = <220000>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&mmc1 {
|
|
+ bus-width = <4>;
|
|
+ mmc-pwrseq = <&wifi_pwrseq>;
|
|
+ non-removable;
|
|
+ vmmc-supply = <®_vcc_3v3>;
|
|
+ vqmmc-supply = <®_vcc_3v3>;
|
|
+ pinctrl-0 = <&mmc1_pins>;
|
|
+ pinctrl-names = "default";
|
|
+ status = "okay";
|
|
+
|
|
+ rtl8723ds: wifi@1 {
|
|
+ reg = <1>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&ohci1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&uart1 {
|
|
+ uart-has-rtscts;
|
|
+ pinctrl-0 = <&uart1_pg6_pins>, <&uart1_pg8_rts_cts_pins>;
|
|
+ pinctrl-names = "default";
|
|
+ status = "okay";
|
|
+
|
|
+ bluetooth {
|
|
+ compatible = "realtek,rtl8723ds-bt";
|
|
+ device-wake-gpios = <&pio 6 15 GPIO_ACTIVE_HIGH>; /* PG16 */
|
|
+ enable-gpios = <&pio 6 18 GPIO_ACTIVE_HIGH>; /* PG18 */
|
|
+ host-wake-gpios = <&pio 6 17 GPIO_ACTIVE_HIGH>; /* PG17 */
|
|
+ };
|
|
+};
|
|
+
|
|
+&usbphy {
|
|
+ usb1_vbus-supply = <®_vcc>;
|
|
+};
|
|
--- /dev/null
|
|
+++ b/arch/riscv/boot/dts/allwinner/sun20i-d1-lichee-rv.dts
|
|
@@ -0,0 +1,84 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ or MIT)
|
|
+// Copyright (C) 2022 Jisheng Zhang <jszhang@kernel.org>
|
|
+// Copyright (C) 2022 Samuel Holland <samuel@sholland.org>
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include <dt-bindings/gpio/gpio.h>
|
|
+#include <dt-bindings/leds/common.h>
|
|
+
|
|
+#include "sun20i-d1.dtsi"
|
|
+#include "sun20i-d1-common-regulators.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "Sipeed Lichee RV";
|
|
+ compatible = "sipeed,lichee-rv", "allwinner,sun20i-d1";
|
|
+
|
|
+ aliases {
|
|
+ mmc0 = &mmc0;
|
|
+ serial0 = &uart0;
|
|
+ };
|
|
+
|
|
+ chosen {
|
|
+ stdout-path = "serial0:115200n8";
|
|
+ };
|
|
+
|
|
+ leds {
|
|
+ compatible = "gpio-leds";
|
|
+
|
|
+ led-0 {
|
|
+ color = <LED_COLOR_ID_GREEN>;
|
|
+ function = LED_FUNCTION_STATUS;
|
|
+ gpios = <&pio 2 1 GPIO_ACTIVE_HIGH>; /* PC1 */
|
|
+ };
|
|
+ };
|
|
+
|
|
+ reg_vdd_cpu: vdd-cpu {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "vdd-cpu";
|
|
+ regulator-min-microvolt = <900000>;
|
|
+ regulator-max-microvolt = <900000>;
|
|
+ vin-supply = <®_vcc>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&cpu0 {
|
|
+ cpu-supply = <®_vdd_cpu>;
|
|
+};
|
|
+
|
|
+&ehci0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mmc0 {
|
|
+ broken-cd;
|
|
+ bus-width = <4>;
|
|
+ disable-wp;
|
|
+ vmmc-supply = <®_vcc_3v3>;
|
|
+ vqmmc-supply = <®_vcc_3v3>;
|
|
+ pinctrl-0 = <&mmc0_pins>;
|
|
+ pinctrl-names = "default";
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&ohci0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&uart0 {
|
|
+ pinctrl-0 = <&uart0_pb8_pins>;
|
|
+ pinctrl-names = "default";
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usb_otg {
|
|
+ dr_mode = "otg";
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usbphy {
|
|
+ usb0_id_det-gpios = <&pio 3 21 GPIO_ACTIVE_HIGH>; /* PD21 */
|
|
+ usb0_vbus_det-gpios = <&pio 3 20 GPIO_ACTIVE_HIGH>; /* PD20 */
|
|
+ usb0_vbus-supply = <®_vcc>;
|
|
+ status = "okay";
|
|
+};
|