mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-24 15:56:49 +00:00
8b52a8906b
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.4.y - led1 can't be controlled on rpi-3 for linux 4.4, remove it. - Fix modules.mk typos. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
31 lines
922 B
Diff
31 lines
922 B
Diff
From 192835cf562bf63050f3f4b3dab768f3481eb93d Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Sat, 26 Nov 2016 14:01:52 +0000
|
|
Subject: [PATCH] ARM: dts: Restore dtbs_install functionality
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
arch/arm/boot/dts/Makefile | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
|
|
index cbfc8ba..14a491c 100644
|
|
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -806,10 +806,11 @@ dtstree := $(srctree)/$(src)
|
|
dtb-$(CONFIG_OF_ALL_DTBS) := $(patsubst $(dtstree)/%.dts,%.dtb, $(wildcard $(dtstree)/*.dts))
|
|
|
|
always := $(dtb-y)
|
|
-subdir-y := $(dts-dirs) overlays
|
|
+subdir-y := overlays
|
|
clean-files := *.dtb
|
|
|
|
# Enable fixups to support overlays on BCM2708 platforms
|
|
ifeq ($(RPI_DT_OVERLAYS),y)
|
|
DTC_FLAGS ?= -@ -H epapr
|
|
+ dts-dirs += overlays
|
|
endif
|
|
--
|
|
2.1.4
|
|
|