mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-28 09:39:00 +00:00
d71928c1e3
Changelog: https://lwn.net/ml/netdev/YhO5Pn+6+dgAgSd9@salvia/ Patches: removed: - 001-parser-allow-quoted-string-in-flowtable_expr_member: it is now part of upstream release [1] added: - 001-examples-compile-with-make-check.patch: backported from [2], it fixes: nft-json-file.c:3:10: fatal error: nftables/libnftables.h: No such file or directory 3 | #include <nftables/libnftables.h> | ^~~~~~~~~~~~~~~~~~~~~~~~ compilation terminated. [1] https://git.netfilter.org/nftables/commit/?h=v1.0.2&id=07af4429241c9832a613cb8620331ac54257d9df [2] https://git.netfilter.org/nftables/commit/?id=18a08fb7f0443f8bde83393bd6f69e23a04246b3 Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
30 lines
994 B
Diff
30 lines
994 B
Diff
From 18a08fb7f0443f8bde83393bd6f69e23a04246b3 Mon Sep 17 00:00:00 2001
|
|
From: Pablo Neira Ayuso <pablo@netfilter.org>
|
|
Date: Tue, 22 Feb 2022 00:56:36 +0100
|
|
Subject: examples: compile with `make check' and add AM_CPPFLAGS
|
|
|
|
Compile examples via `make check' like libnftnl does. Use AM_CPPFLAGS to
|
|
specify local headers via -I.
|
|
|
|
Unfortunately, `make distcheck' did not catch this compile time error in
|
|
my system, since it was using the nftables/libnftables.h file of the
|
|
previous nftables release.
|
|
|
|
Fixes: 5b364657a35f ("build: missing SUBIRS update")
|
|
Fixes: caf2a6ad2d22 ("examples: add libnftables example program")
|
|
Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
|
|
---
|
|
examples/Makefile.am | 4 +++-
|
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
--- a/examples/Makefile.am
|
|
+++ b/examples/Makefile.am
|
|
@@ -1,4 +1,6 @@
|
|
-noinst_PROGRAMS = nft-buffer \
|
|
+check_PROGRAMS = nft-buffer \
|
|
nft-json-file
|
|
|
|
+AM_CPPFLAGS = -I$(top_srcdir)/include
|
|
+
|
|
LDADD = $(top_builddir)/src/libnftables.la
|