mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 06:33:41 +00:00
8b3d879861
Refreshed all patches. Compile-tested on: ath79, lantiq, ipq40xx, x86_64 Runtime-tested on: ipq40xx, x86_64 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
35 lines
1.0 KiB
Diff
35 lines
1.0 KiB
Diff
--- a/drivers/clocksource/Kconfig
|
|
+++ b/drivers/clocksource/Kconfig
|
|
@@ -127,6 +127,15 @@ config RDA_TIMER
|
|
help
|
|
Enables the support for the RDA Micro timer driver.
|
|
|
|
+config RTL9300_TIMER
|
|
+ bool "Clocksource/timer for the Realtek RTL9300 family of SoCs"
|
|
+ depends on MIPS
|
|
+ select COMMON_CLK
|
|
+ select TIMER_OF
|
|
+ select CLKSRC_MMIO
|
|
+ help
|
|
+ Enables support for the Realtek RTL9300 timer driver.
|
|
+
|
|
config SUN4I_TIMER
|
|
bool "Sun4i timer driver" if COMPILE_TEST
|
|
depends on HAS_IOMEM
|
|
@@ -696,5 +705,4 @@ config INGENIC_TIMER
|
|
select IRQ_DOMAIN
|
|
help
|
|
Support for the timer/counter unit of the Ingenic JZ SoCs.
|
|
-
|
|
endmenu
|
|
--- a/drivers/clocksource/Makefile
|
|
+++ b/drivers/clocksource/Makefile
|
|
@@ -61,6 +61,7 @@ obj-$(CONFIG_MILBEAUT_TIMER) += timer-mi
|
|
obj-$(CONFIG_SPRD_TIMER) += timer-sprd.o
|
|
obj-$(CONFIG_NPCM7XX_TIMER) += timer-npcm7xx.o
|
|
obj-$(CONFIG_RDA_TIMER) += timer-rda.o
|
|
+obj-$(CONFIG_RTL9300_TIMER) += timer-rtl9300.o
|
|
|
|
obj-$(CONFIG_ARC_TIMERS) += arc_timer.o
|
|
obj-$(CONFIG_ARM_ARCH_TIMER) += arm_arch_timer.o
|