mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
75 lines
2.0 KiB
Diff
75 lines
2.0 KiB
Diff
From abea9147d22704cdfb68b7161a71dc9fb8fcb0b0 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Noralf=20Tr=C3=B8nnes?= <noralf@tronnes.org>
|
|
Date: Fri, 26 Jun 2015 14:25:01 +0200
|
|
Subject: [PATCH] firmware: bcm2835: Support ARCH_BCM270x
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Support booting without Device Tree.
|
|
Turn on USB power.
|
|
Load driver early because of lacking support for deferred probing
|
|
in many drivers.
|
|
|
|
Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
|
|
|
|
firmware: bcm2835: Don't turn on USB power
|
|
|
|
The raspberrypi-power driver is now used to turn on USB power.
|
|
|
|
This partly reverts commit:
|
|
firmware: bcm2835: Support ARCH_BCM270x
|
|
|
|
Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
|
|
---
|
|
drivers/firmware/raspberrypi.c | 17 ++++++++++++++++-
|
|
1 file changed, 16 insertions(+), 1 deletion(-)
|
|
|
|
--- a/drivers/firmware/raspberrypi.c
|
|
+++ b/drivers/firmware/raspberrypi.c
|
|
@@ -32,6 +32,8 @@ struct rpi_firmware {
|
|
struct kref consumers;
|
|
};
|
|
|
|
+static struct platform_device *g_pdev;
|
|
+
|
|
static DEFINE_MUTEX(transaction_lock);
|
|
|
|
static void response_callback(struct mbox_client *cl, void *msg)
|
|
@@ -280,6 +282,7 @@ static int rpi_firmware_probe(struct pla
|
|
kref_init(&fw->consumers);
|
|
|
|
platform_set_drvdata(pdev, fw);
|
|
+ g_pdev = pdev;
|
|
|
|
rpi_firmware_print_firmware_revision(fw);
|
|
rpi_register_hwmon_driver(dev, fw);
|
|
@@ -308,6 +311,7 @@ static int rpi_firmware_remove(struct pl
|
|
rpi_clk = NULL;
|
|
|
|
rpi_firmware_put(fw);
|
|
+ g_pdev = NULL;
|
|
|
|
return 0;
|
|
}
|
|
@@ -382,7 +386,18 @@ static struct platform_driver rpi_firmwa
|
|
.shutdown = rpi_firmware_shutdown,
|
|
.remove = rpi_firmware_remove,
|
|
};
|
|
-module_platform_driver(rpi_firmware_driver);
|
|
+
|
|
+static int __init rpi_firmware_init(void)
|
|
+{
|
|
+ return platform_driver_register(&rpi_firmware_driver);
|
|
+}
|
|
+subsys_initcall(rpi_firmware_init);
|
|
+
|
|
+static void __init rpi_firmware_exit(void)
|
|
+{
|
|
+ platform_driver_unregister(&rpi_firmware_driver);
|
|
+}
|
|
+module_exit(rpi_firmware_exit);
|
|
|
|
MODULE_AUTHOR("Eric Anholt <eric@anholt.net>");
|
|
MODULE_DESCRIPTION("Raspberry Pi firmware driver");
|