mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
7181eb9f81
Remove upstreamed patches: - 000-v5.18-01-dt-bindings-reset-add-dt-binding-header-for-Mediatek.patch - 000-v5.18-02-staging-mt7621-dts-align-resets-with-binding-documen.patch - 001-v5.18-01-dt-bindings-clock-mediatek-mt7621-sysc-add-reset-cel.patch - 001-v5.18-02-clk-ralink-make-system-controller-node-a-reset-provi.patch - 002-v6.0-MIPS-ralink-mt7621-avoid-to-init-common-ralink-reset.patch - 100-v5.16-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch - 101-v5.17-PCI-mt7621-Rename-mt7621_pci_-to-mt7621_pcie_.patch - 102-v5.17-PCI-mt7621-Declare-mt7621_pci_ops-static.patch - 103-v5.17-PCI-mt7621-Move-MIPS-setup-to-pcibios_root_bridge_pr.patch - 104-v5.17-PCI-mt7621-Drop-of_match_ptr-to-avoid-unused-variabl.patch - 105-v5.17-PCI-mt7621-Remove-unused-function-pcie_rmw.patch - 106-v5.17-PCI-Let-pcibios_root_bridge_prepare-access-bridge-wi.patch - 107-v6.2-PCI-mt7621-Add-sentinel-to-quirks-table.patch - 108-v6.3-PCI-mt7621-Delay-phy-ports-initialization.patch Manually refresh: - 006-v6.5-mips-ralink-introduce-commonly-used-remap-node-funct.patch - 320-MIPS-add-support-for-buggy-MT7621S-core-detection.patch - 405-mtd-spi-nor-Add-support-for-BoHong-bh25q128as.patch - 410-mtd-rawnand-add-driver-support-for-MT7621-nand-flash.patch - 805-pinctrl-AW9523.patch - 825-i2c-MIPS-adds-ralink-I2C-driver.patch - 830-mmc-MIPS-ralink-add-sdhci-for-mt7620a-SoC.patch Automatically refresh: - 200-add-ralink-eth.patch - 314-MIPS-add-bootargs-override-property.patch - 315-owrt-hack-fix-mt7688-cache-issue.patch - 700-net-ethernet-mediatek-support-net-labels.patch - 720-Revert-net-phy-simplify-phy_link_change-arguments.patch - 721-NET-no-auto-carrier-off-support.patch - 800-dmaengine-mediatek-add-HSDMA-support-for-mt7621.patch - 802-GPIO-MIPS-ralink-add-gpio-driver-for-ralink-SoC.patch - 810-uvc-add-iPassion-iP2970-support.patch - 821-SPI-ralink-add-Ralink-SoC-spi-driver.patch - 835-asoc-add-mt7620-support.patch - 840-serial-add-ugly-custom-baud-rate-hack.patch - 845-pwm-add-mediatek-support.patch - 850-awake-rt305x-dwc2-controller.patch Tested-by: Andre Heider <a.heider@gmail.com> # netgear,wac124 Tested-by: Andrey Jr. Melnikov <temnota.am@gmail.com> # Xiaomi Mi Router 3G Tested-by: Timo Dorfner <timo.capa@gmail.com> # mt7621/mir3g mt7621/rm2100 Reviewed-by: Shiji Yang <yangshiji66@qq.com> Co-Developed-by: Mieczyslaw Nalewaj <namiltd@yahoo.com> Signed-off-by: Nick Hainke <vincent@systemli.org>
73 lines
2.9 KiB
Diff
73 lines
2.9 KiB
Diff
From: AngeloGioacchino Del Regno
|
|
<angelogioacchino.delregno@somainline.org>
|
|
To: linus.walleij@linaro.org
|
|
Cc: linux-kernel@vger.kernel.org, konrad.dybcio@somainline.org,
|
|
marijn.suijten@somainline.org, martin.botka@somainline.org,
|
|
phone-devel@vger.kernel.org, linux-gpio@vger.kernel.org,
|
|
devicetree@vger.kernel.org, robh+dt@kernel.org,
|
|
AngeloGioacchino Del Regno
|
|
<angelogioacchino.delregno@somainline.org>
|
|
Subject: [PATCH v5 1/2] pinctrl: Add driver for Awinic AW9523/B I2C GPIO
|
|
Expander
|
|
Date: Mon, 25 Jan 2021 19:22:18 +0100
|
|
|
|
The Awinic AW9523(B) is a multi-function I2C gpio expander in a
|
|
TQFN-24L package, featuring PWM (max 37mA per pin, or total max
|
|
power 3.2Watts) for LED driving capability.
|
|
|
|
It has two ports with 8 pins per port (for a total of 16 pins),
|
|
configurable as either PWM with 1/256 stepping or GPIO input/output,
|
|
1.8V logic input; each GPIO can be configured as input or output
|
|
independently from each other.
|
|
|
|
This IC also has an internal interrupt controller, which is capable
|
|
of generating an interrupt for each GPIO, depending on the
|
|
configuration, and will raise an interrupt on the INTN pin to
|
|
advertise this to an external interrupt controller.
|
|
|
|
Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@somainline.org>
|
|
---
|
|
drivers/pinctrl/Kconfig | 17 +
|
|
drivers/pinctrl/Makefile | 1 +
|
|
drivers/pinctrl/pinctrl-aw9523.c | 1122 ++++++++++++++++++++++++++++++
|
|
3 files changed, 1140 insertions(+)
|
|
create mode 100644 drivers/pinctrl/pinctrl-aw9523.c
|
|
|
|
--- a/drivers/pinctrl/Kconfig
|
|
+++ b/drivers/pinctrl/Kconfig
|
|
@@ -113,6 +113,24 @@ config PINCTRL_AT91PIO4
|
|
Say Y here to enable the at91 pinctrl/gpio driver for Atmel PIO4
|
|
controller available on sama5d2 SoC.
|
|
|
|
+config PINCTRL_AW9523
|
|
+ bool "Awinic AW9523/AW9523B I2C GPIO expander pinctrl driver"
|
|
+ depends on OF && I2C
|
|
+ select PINMUX
|
|
+ select PINCONF
|
|
+ select GENERIC_PINCONF
|
|
+ select GPIOLIB
|
|
+ select GPIOLIB_IRQCHIP
|
|
+ select REGMAP
|
|
+ select REGMAP_I2C
|
|
+ help
|
|
+ The Awinic AW9523/AW9523B is a multi-function I2C GPIO
|
|
+ expander with PWM functionality. This driver bundles a
|
|
+ pinctrl driver to select the function muxing and a GPIO
|
|
+ driver to handle GPIO, when the GPIO function is selected.
|
|
+
|
|
+ Say yes to enable pinctrl and GPIO support for the AW9523(B).
|
|
+
|
|
config PINCTRL_AXP209
|
|
tristate "X-Powers AXP209 PMIC pinctrl and GPIO Support"
|
|
depends on MFD_AXP20X
|
|
--- a/drivers/pinctrl/Makefile
|
|
+++ b/drivers/pinctrl/Makefile
|
|
@@ -15,6 +15,7 @@ obj-$(CONFIG_PINCTRL_ARTPEC6) += pinctrl
|
|
obj-$(CONFIG_PINCTRL_AS3722) += pinctrl-as3722.o
|
|
obj-$(CONFIG_PINCTRL_AT91) += pinctrl-at91.o
|
|
obj-$(CONFIG_PINCTRL_AT91PIO4) += pinctrl-at91-pio4.o
|
|
+obj-$(CONFIG_PINCTRL_AW9523) += pinctrl-aw9523.o
|
|
obj-$(CONFIG_PINCTRL_AXP209) += pinctrl-axp209.o
|
|
obj-$(CONFIG_PINCTRL_BM1880) += pinctrl-bm1880.o
|
|
obj-$(CONFIG_PINCTRL_CY8C95X0) += pinctrl-cy8c95x0.o
|