mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-28 17:48:58 +00:00
7d7aa2fd92
This change makes the names of Broadcom targets consistent by using the common notation based on SoC/CPU ID (which is used internally anyway), bcmXXXX instead of brcmXXXX. This is even used for target TITLE in make menuconfig already, only the short target name used brcm so far. Despite, since subtargets range from bcm2708 to bcm2711, it seems appropriate to use bcm27xx instead of bcm2708 (again, as already done for BOARDNAME). This also renames the packages brcm2708-userland and brcm2708-gpu-fw. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Álvaro Fernández Rojas <noltari@gmail.com>
34 lines
1.3 KiB
Diff
34 lines
1.3 KiB
Diff
From 0e7db01b8ce2c2fb5596e7a9b7104e9947e5c269 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Fri, 8 Mar 2019 21:12:39 +0000
|
|
Subject: [PATCH] 2711: Add basic 64-bit support
|
|
|
|
This commit adds initial support for 64-bit 2711 builds. However,
|
|
it will only work as much as it does if the Pi4 RAM is limited to
|
|
1GB - more than that and several things break (SD card, coherent
|
|
allocations, etc.)
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
arch/arm64/boot/dts/broadcom/Makefile | 1 +
|
|
.../boot/dts/broadcom/bcm2711-rpi-4-b.dts | 3 +
|
|
3 files changed, 1295 insertions(+)
|
|
create mode 100644 arch/arm64/boot/dts/broadcom/bcm2711-rpi-4-b.dts
|
|
|
|
--- a/arch/arm64/boot/dts/broadcom/Makefile
|
|
+++ b/arch/arm64/boot/dts/broadcom/Makefile
|
|
@@ -3,6 +3,7 @@ dtb-$(CONFIG_ARCH_BCM2835) += bcm2837-rp
|
|
bcm2837-rpi-3-b-plus.dtb
|
|
dtb-$(CONFIG_ARCH_BCM2709) += bcm2710-rpi-3-b.dtb
|
|
dtb-$(CONFIG_ARCH_BCM2835) += bcm2710-rpi-3-b.dtb
|
|
+dtb-$(CONFIG_ARCH_BCM2835) += bcm2711-rpi-4-b.dtb
|
|
dtb-$(CONFIG_ARCH_BCM2835) += bcm2710-rpi-3-b-plus.dtb
|
|
dtb-$(CONFIG_ARCH_BCM2709) += bcm2710-rpi-cm3.dtb
|
|
dtb-$(CONFIG_ARCH_BCM2835) += bcm2710-rpi-cm3.dtb
|
|
--- /dev/null
|
|
+++ b/arch/arm64/boot/dts/broadcom/bcm2711-rpi-4-b.dts
|
|
@@ -0,0 +1,3 @@
|
|
+#define RPI364
|
|
+
|
|
+#include "../../../../arm/boot/dts/bcm2711-rpi-4-b.dts"
|