mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 00:41:17 +00:00
39ac29a68a
- Release announcement: https://lore.kernel.org/u-boot/20220711134339.GV1146598@bill-the-cat/ - Changes between 2022.04 and 2022.07: https://source.denx.de/u-boot/u-boot/-/compare/v2022.04...v2022.07?from_project_id=531 Remove one upstreamed patch and add patch to fix issue with sunxi tool as it uses function from newer version libressl (3.5.0). Signed-off-by: Andre Heider <a.heider@gmail.com> Tested-by: Josef Schlehofer <pepe.schlehofer@gmail.com> [Turris Omnia] (cherry picked from commit 24bf6813bad98a8eba5430ed5e4da89d54797274) Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com> [Improve commit message]
21 lines
622 B
Diff
21 lines
622 B
Diff
The build fails on a sunxi tool:
|
|
|
|
/usr/bin/ld: tools/sunxi_toc0.o: in function `toc0_set_header':
|
|
sunxi_toc0.c:(.text+0x363): undefined reference to `RSA_get0_d'
|
|
|
|
The missing function was added in libressl v3.5.0. We don't
|
|
really care, so just cut it out for now.
|
|
|
|
--- a/tools/Makefile
|
|
+++ b/tools/Makefile
|
|
@@ -96,8 +96,7 @@ AES_OBJS-$(CONFIG_TOOLS_LIBCRYPTO) := $(
|
|
|
|
# Cryptographic helpers and image types that depend on openssl/libcrypto
|
|
LIBCRYPTO_OBJS-$(CONFIG_TOOLS_LIBCRYPTO) := \
|
|
- lib/fdt-libcrypto.o \
|
|
- sunxi_toc0.o
|
|
+ lib/fdt-libcrypto.o
|
|
|
|
ROCKCHIP_OBS = lib/rc4.o rkcommon.o rkimage.o rksd.o rkspi.o
|
|
|