mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 17:01:14 +00:00
7541d30c9c
f52bb5b fix previous commit
18eac67 Fix entries in /etc/hosts disabling static leases.
f8c77ed Fix removal of DHCP_CLIENT_MAC options from DHCPv6 relay replies.
4bf62f6 Tidy cache_blockdata_free()
9c0d445 Fix e7bfd556c079c8b5e7425aed44abc35925b24043 to actually work.
2896e24 Check for not(DS or DNSKEY) in is_outdated_cname_pointer()
a90f09d Fix crash freeing negative SRV cache entries.
5b99eae Cache SRV records.
2daca52 Fix typo in ra-param man page section.
2c59473 File logic bug in cache-marshalling code. Introduced a couple of commits back.
cc921df Remove nested struct/union in cache records and all_addr.
ab194ed Futher address union tidying.
65a01b7
Tidy address-union handling: move class into explicit argument.
bde4647 Tidy all_addr union, merge log and rcode fields.
e7bfd55 Alter DHCP address selection after DECLINE in consec-addr mode. Avoid offering the same address after a recieving a DECLINE message to stop an infinite protocol loop. This has long been done in default address allocation mode: this adds similar behaviour when allocaing addresses consecutively.
The most relevant fix for openwrt is 18eac67 (& my own local f52bb5b
which fixes a missing bracket silly) To quote the patch:
It is possible for a config entry to have one address family specified by a
dhcp-host directive and the other added from /etc/hosts. This is especially
common on OpenWrt because it uses odhcpd for DHCPv6 and IPv6 leases are
imported into dnsmasq via a hosts file.
To handle this case there need to be separate *_HOSTS flags for IPv4 and IPv6.
Otherwise when the hosts file is reloaded it will clear the CONFIG_ADDR(6) flag
which was set by the dhcp-host directive.
Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
64 lines
2.9 KiB
Diff
64 lines
2.9 KiB
Diff
From 3a5a84cdd1488bad118eeac72d09a60299bca744 Mon Sep 17 00:00:00 2001
|
|
From: Simon Kelley <simon@thekelleys.org.uk>
|
|
Date: Wed, 31 Oct 2018 21:30:13 +0000
|
|
Subject: [PATCH 08/30] Fix Makefile lines generating UBUS linker config.
|
|
|
|
If arg2 of pkg-wrapper is "--copy", then arg1 is NOT the name of
|
|
the package manager (--copy doesn't invoke it) it's a secondary
|
|
config string that inhibts the copy if found. This patch allows that
|
|
to be the empty string, for unconditional copy, and modifies the
|
|
ubus linker config to use it. It worked by coincidence before, because
|
|
there was no config string called "pkg-config".
|
|
|
|
Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
|
|
---
|
|
Makefile | 2 +-
|
|
bld/pkg-wrapper | 14 ++++++++------
|
|
2 files changed, 9 insertions(+), 7 deletions(-)
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -53,7 +53,7 @@ top?=$(CURDIR)
|
|
|
|
dbus_cflags = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_DBUS $(PKG_CONFIG) --cflags dbus-1`
|
|
dbus_libs = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_DBUS $(PKG_CONFIG) --libs dbus-1`
|
|
-ubus_libs = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_UBUS $(PKG_CONFIG) --copy -lubox -lubus`
|
|
+ubus_libs = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_UBUS "" --copy -lubox -lubus`
|
|
idn_cflags = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_IDN $(PKG_CONFIG) --cflags libidn`
|
|
idn_libs = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_IDN $(PKG_CONFIG) --libs libidn`
|
|
idn2_cflags = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_LIBIDN2 $(PKG_CONFIG) --cflags libidn2`
|
|
--- a/bld/pkg-wrapper
|
|
+++ b/bld/pkg-wrapper
|
|
@@ -11,23 +11,25 @@ in=`cat`
|
|
|
|
if grep "^\#[[:space:]]*define[[:space:]]*$search" config.h >/dev/null 2>&1 || \
|
|
echo $in | grep $search >/dev/null 2>&1; then
|
|
-# Nasty, nasty, in --copy, arg 2 is another config to search for, use with NO_GMP
|
|
+# Nasty, nasty, in --copy, arg 2 (if non-empty) is another config to search for, used with NO_GMP
|
|
if [ $op = "--copy" ]; then
|
|
- if grep "^\#[[:space:]]*define[[:space:]]*$pkg" config.h >/dev/null 2>&1 || \
|
|
- echo $in | grep $pkg >/dev/null 2>&1; then
|
|
+ if [ -z "$pkg" ]; then
|
|
+ pkg="$*"
|
|
+ elif grep "^\#[[:space:]]*define[[:space:]]*$pkg" config.h >/dev/null 2>&1 || \
|
|
+ echo $in | grep $pkg >/dev/null 2>&1; then
|
|
pkg=""
|
|
else
|
|
pkg="$*"
|
|
fi
|
|
elif grep "^\#[[:space:]]*define[[:space:]]*${search}_STATIC" config.h >/dev/null 2>&1 || \
|
|
- echo $in | grep ${search}_STATIC >/dev/null 2>&1; then
|
|
+ echo $in | grep ${search}_STATIC >/dev/null 2>&1; then
|
|
pkg=`$pkg --static $op $*`
|
|
else
|
|
pkg=`$pkg $op $*`
|
|
fi
|
|
-
|
|
+
|
|
if grep "^\#[[:space:]]*define[[:space:]]*${search}_STATIC" config.h >/dev/null 2>&1 || \
|
|
- echo $in | grep ${search}_STATIC >/dev/null 2>&1; then
|
|
+ echo $in | grep ${search}_STATIC >/dev/null 2>&1; then
|
|
if [ $op = "--libs" ] || [ $op = "--copy" ]; then
|
|
echo "-Wl,-Bstatic $pkg -Wl,-Bdynamic"
|
|
else
|