mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 21:58:04 +00:00
eec18118d0
Convert the Enterasys WS-AP3710i access point to use the simpleImage wrapper. This is necessary, as the bootlaoder does not align the DTB correctly (and does not support altering the FDT loadaddress). Booting images with kernels 5.15 and later can break depending on the alignment on the DTB within the FIT image. Signed-off-by: David Bauer <mail@david-bauer.net>
49 lines
2.0 KiB
Diff
49 lines
2.0 KiB
Diff
--- a/arch/powerpc/platforms/85xx/Kconfig
|
|
+++ b/arch/powerpc/platforms/85xx/Kconfig
|
|
@@ -73,6 +73,17 @@ config WS_AP3710I
|
|
This board is a Concurrent Dual-Band wireless access point with a
|
|
Freescale P1020 SoC.
|
|
|
|
+config WS_AP3715I
|
|
+ bool "Enterasys WS-AP3715i"
|
|
+ select DEFAULT_UIMAGE
|
|
+ select ARCH_REQUIRE_GPIOLIB
|
|
+ select GPIO_MPC8XXX
|
|
+ help
|
|
+ This option enables support for the Enterasys WS-AP3715i board.
|
|
+
|
|
+ This board is a Concurrent Dual-Band wireless access point with a
|
|
+ Freescale P1010 SoC.
|
|
+
|
|
config WS_AP3825I
|
|
bool "Extreme Networks WS-AP3825i"
|
|
select DEFAULT_UIMAGE
|
|
--- a/arch/powerpc/platforms/85xx/Makefile
|
|
+++ b/arch/powerpc/platforms/85xx/Makefile
|
|
@@ -26,6 +26,7 @@ obj-$(CONFIG_PANDA) += panda.o
|
|
obj-$(CONFIG_PPC_P2020) += p2020.o $(obj8259-y)
|
|
obj-$(CONFIG_TWR_P102x) += twr_p102x.o
|
|
obj-$(CONFIG_WS_AP3710I) += ws-ap3710i.o
|
|
+obj-$(CONFIG_WS_AP3715I) += ws-ap3715i.o
|
|
obj-$(CONFIG_WS_AP3825I) += ws-ap3825i.o
|
|
obj-$(CONFIG_FIREBOX_T10) += firebox_t10.o
|
|
obj-$(CONFIG_CORENET_GENERIC) += corenet_generic.o
|
|
--- a/arch/powerpc/boot/Makefile
|
|
+++ b/arch/powerpc/boot/Makefile
|
|
@@ -184,6 +184,7 @@ src-plat-$(CONFIG_MVME7100) += motload-h
|
|
src-plat-$(CONFIG_HIVEAP_330) += simpleboot.c fixed-head.S
|
|
src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S
|
|
src-plat-$(CONFIG_WS_AP3710I) += simpleboot.c fixed-head.S
|
|
+src-plat-$(CONFIG_WS_AP3715I) += simpleboot.c fixed-head.S
|
|
src-plat-$(CONFIG_WS_AP3825I) += simpleboot.c fixed-head.S
|
|
|
|
src-plat-$(CONFIG_PPC_MICROWATT) += fixed-head.S microwatt.c
|
|
@@ -358,6 +359,7 @@ image-$(CONFIG_KSI8560) += cuImage.ksi
|
|
image-$(CONFIG_HIVEAP_330) += simpleImage.hiveap-330
|
|
image-$(CONFIG_TL_WDR4900_V1) += simpleImage.tl-wdr4900-v1
|
|
image-$(CONFIG_WS_AP3710I) += simpleImage.ws-ap3710i
|
|
+image-$(CONFIG_WS_AP3715I) += simpleImage.ws-ap3715i
|
|
image-$(CONFIG_WS_AP3825I) += simpleImage.ws-ap3825i
|
|
# Board ports in arch/powerpc/platform/86xx/Kconfig
|
|
image-$(CONFIG_MVME7100) += dtbImage.mvme7100
|