mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 06:57:57 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
143 lines
4.3 KiB
Diff
143 lines
4.3 KiB
Diff
From f9ec5723c3dbfcede9c7b0dcdf85e401ce16316c Mon Sep 17 00:00:00 2001
|
|
From: Christian Marangi <ansuelsmth@gmail.com>
|
|
Date: Sat, 23 Jul 2022 16:29:29 +0200
|
|
Subject: [PATCH 1/5] net: ethernet: stmicro: stmmac: move queue reset to
|
|
dedicated functions
|
|
|
|
Move queue reset to dedicated functions. This aside from a simple
|
|
cleanup is also required to allocate a dma conf without resetting the tx
|
|
queue while the device is temporarily detached as now the reset is not
|
|
part of the dma init function and can be done later in the code flow.
|
|
|
|
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
|
Signed-off-by: Jakub Kicinski <kuba@kernel.org>
|
|
---
|
|
.../net/ethernet/stmicro/stmmac/stmmac_main.c | 59 ++++++++++---------
|
|
1 file changed, 31 insertions(+), 28 deletions(-)
|
|
|
|
--- a/drivers/net/ethernet/stmicro/stmmac/stmmac_main.c
|
|
+++ b/drivers/net/ethernet/stmicro/stmmac/stmmac_main.c
|
|
@@ -130,6 +130,9 @@ static irqreturn_t stmmac_mac_interrupt(
|
|
static irqreturn_t stmmac_safety_interrupt(int irq, void *dev_id);
|
|
static irqreturn_t stmmac_msi_intr_tx(int irq, void *data);
|
|
static irqreturn_t stmmac_msi_intr_rx(int irq, void *data);
|
|
+static void stmmac_reset_rx_queue(struct stmmac_priv *priv, u32 queue);
|
|
+static void stmmac_reset_tx_queue(struct stmmac_priv *priv, u32 queue);
|
|
+static void stmmac_reset_queues_param(struct stmmac_priv *priv);
|
|
static void stmmac_tx_timer_arm(struct stmmac_priv *priv, u32 queue);
|
|
static void stmmac_flush_tx_descriptors(struct stmmac_priv *priv, int queue);
|
|
|
|
@@ -1705,9 +1708,6 @@ static int __init_dma_rx_desc_rings(stru
|
|
return -ENOMEM;
|
|
}
|
|
|
|
- rx_q->cur_rx = 0;
|
|
- rx_q->dirty_rx = 0;
|
|
-
|
|
/* Setup the chained descriptor addresses */
|
|
if (priv->mode == STMMAC_CHAIN_MODE) {
|
|
if (priv->extend_desc)
|
|
@@ -1813,12 +1813,6 @@ static int __init_dma_tx_desc_rings(stru
|
|
tx_q->tx_skbuff[i] = NULL;
|
|
}
|
|
|
|
- tx_q->dirty_tx = 0;
|
|
- tx_q->cur_tx = 0;
|
|
- tx_q->mss = 0;
|
|
-
|
|
- netdev_tx_reset_queue(netdev_get_tx_queue(priv->dev, queue));
|
|
-
|
|
return 0;
|
|
}
|
|
|
|
@@ -2687,10 +2681,7 @@ static void stmmac_tx_err(struct stmmac_
|
|
stmmac_stop_tx_dma(priv, chan);
|
|
dma_free_tx_skbufs(priv, chan);
|
|
stmmac_clear_tx_descriptors(priv, chan);
|
|
- tx_q->dirty_tx = 0;
|
|
- tx_q->cur_tx = 0;
|
|
- tx_q->mss = 0;
|
|
- netdev_tx_reset_queue(netdev_get_tx_queue(priv->dev, chan));
|
|
+ stmmac_reset_tx_queue(priv, chan);
|
|
stmmac_init_tx_chan(priv, priv->ioaddr, priv->plat->dma_cfg,
|
|
tx_q->dma_tx_phy, chan);
|
|
stmmac_start_tx_dma(priv, chan);
|
|
@@ -3774,6 +3765,8 @@ static int stmmac_open(struct net_device
|
|
}
|
|
}
|
|
|
|
+ stmmac_reset_queues_param(priv);
|
|
+
|
|
ret = stmmac_hw_setup(dev, true);
|
|
if (ret < 0) {
|
|
netdev_err(priv->dev, "%s: Hw setup failed\n", __func__);
|
|
@@ -6417,6 +6410,7 @@ void stmmac_enable_rx_queue(struct stmma
|
|
return;
|
|
}
|
|
|
|
+ stmmac_reset_rx_queue(priv, queue);
|
|
stmmac_clear_rx_descriptors(priv, queue);
|
|
|
|
stmmac_init_rx_chan(priv, priv->ioaddr, priv->plat->dma_cfg,
|
|
@@ -6478,6 +6472,7 @@ void stmmac_enable_tx_queue(struct stmma
|
|
return;
|
|
}
|
|
|
|
+ stmmac_reset_tx_queue(priv, queue);
|
|
stmmac_clear_tx_descriptors(priv, queue);
|
|
|
|
stmmac_init_tx_chan(priv, priv->ioaddr, priv->plat->dma_cfg,
|
|
@@ -7400,6 +7395,25 @@ int stmmac_suspend(struct device *dev)
|
|
}
|
|
EXPORT_SYMBOL_GPL(stmmac_suspend);
|
|
|
|
+static void stmmac_reset_rx_queue(struct stmmac_priv *priv, u32 queue)
|
|
+{
|
|
+ struct stmmac_rx_queue *rx_q = &priv->rx_queue[queue];
|
|
+
|
|
+ rx_q->cur_rx = 0;
|
|
+ rx_q->dirty_rx = 0;
|
|
+}
|
|
+
|
|
+static void stmmac_reset_tx_queue(struct stmmac_priv *priv, u32 queue)
|
|
+{
|
|
+ struct stmmac_tx_queue *tx_q = &priv->tx_queue[queue];
|
|
+
|
|
+ tx_q->cur_tx = 0;
|
|
+ tx_q->dirty_tx = 0;
|
|
+ tx_q->mss = 0;
|
|
+
|
|
+ netdev_tx_reset_queue(netdev_get_tx_queue(priv->dev, queue));
|
|
+}
|
|
+
|
|
/**
|
|
* stmmac_reset_queues_param - reset queue parameters
|
|
* @priv: device pointer
|
|
@@ -7410,22 +7424,11 @@ static void stmmac_reset_queues_param(st
|
|
u32 tx_cnt = priv->plat->tx_queues_to_use;
|
|
u32 queue;
|
|
|
|
- for (queue = 0; queue < rx_cnt; queue++) {
|
|
- struct stmmac_rx_queue *rx_q = &priv->rx_queue[queue];
|
|
+ for (queue = 0; queue < rx_cnt; queue++)
|
|
+ stmmac_reset_rx_queue(priv, queue);
|
|
|
|
- rx_q->cur_rx = 0;
|
|
- rx_q->dirty_rx = 0;
|
|
- }
|
|
-
|
|
- for (queue = 0; queue < tx_cnt; queue++) {
|
|
- struct stmmac_tx_queue *tx_q = &priv->tx_queue[queue];
|
|
-
|
|
- tx_q->cur_tx = 0;
|
|
- tx_q->dirty_tx = 0;
|
|
- tx_q->mss = 0;
|
|
-
|
|
- netdev_tx_reset_queue(netdev_get_tx_queue(priv->dev, queue));
|
|
- }
|
|
+ for (queue = 0; queue < tx_cnt; queue++)
|
|
+ stmmac_reset_tx_queue(priv, queue);
|
|
}
|
|
|
|
/**
|