mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-29 01:59:02 +00:00
1020ac6f47
Update to the latest upstream release to include recent improvements and bugfixes. Also refresh local patches. Link: https://github.com/libbpf/bpftool/releases/tag/v7.3.0 Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
11 lines
311 B
Diff
11 lines
311 B
Diff
--- a/libbpf/src/Makefile
|
|
+++ b/libbpf/src/Makefile
|
|
@@ -34,6 +34,7 @@ ALL_CFLAGS := $(INCLUDES)
|
|
|
|
SHARED_CFLAGS += -fPIC -fvisibility=hidden -DSHARED
|
|
|
|
+CFLAGS = $(EXTRA_CFLAGS)
|
|
CFLAGS ?= -g -O2 -Werror -Wall -std=gnu89
|
|
ALL_CFLAGS += $(CFLAGS) \
|
|
-D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 \
|