mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
8b52a8906b
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.4.y - led1 can't be controlled on rpi-3 for linux 4.4, remove it. - Fix modules.mk typos. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
35 lines
1.3 KiB
Diff
35 lines
1.3 KiB
Diff
From d4be0d5751c1bfe067a07a4ec95d7575ec03ab83 Mon Sep 17 00:00:00 2001
|
|
From: Boris Brezillon <boris.brezillon@free-electrons.com>
|
|
Date: Mon, 12 Dec 2016 09:00:53 +0100
|
|
Subject: [PATCH] clk: bcm: Fix 'maybe-uninitialized' warning in
|
|
bcm2835_clock_choose_div_and_prate()
|
|
|
|
best_rate is reported as potentially uninitialized by gcc.
|
|
|
|
Signed-off-by: Boris Brezillon <boris.brezillon@free-electrons.com>
|
|
Fixes: 155e8b3b0ee3 ("clk: bcm: Support rate change propagation on bcm2835 clocks")
|
|
Reported-by: Stephen Rothwell <sfr@canb.auug.org.au>
|
|
Reviewed-by: Eric Anholt <eric@anholt.net>
|
|
Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
|
|
(cherry picked from commit 2aab7a2055a1705c9e30920d95a596226999eb21)
|
|
---
|
|
drivers/clk/bcm/clk-bcm2835.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/drivers/clk/bcm/clk-bcm2835.c b/drivers/clk/bcm/clk-bcm2835.c
|
|
index d023e4a..89dad97 100644
|
|
--- a/drivers/clk/bcm/clk-bcm2835.c
|
|
+++ b/drivers/clk/bcm/clk-bcm2835.c
|
|
@@ -1067,7 +1067,7 @@ static unsigned long bcm2835_clock_choose_div_and_prate(struct clk_hw *hw,
|
|
struct bcm2835_clock *clock = bcm2835_clock_from_hw(hw);
|
|
struct bcm2835_cprman *cprman = clock->cprman;
|
|
const struct bcm2835_clock_data *data = clock->data;
|
|
- unsigned long best_rate;
|
|
+ unsigned long best_rate = 0;
|
|
u32 curdiv, mindiv, maxdiv;
|
|
struct clk_hw *parent;
|
|
|
|
--
|
|
2.1.4
|
|
|