mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
8b52a8906b
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.4.y - led1 can't be controlled on rpi-3 for linux 4.4, remove it. - Fix modules.mk typos. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
32 lines
1.1 KiB
Diff
32 lines
1.1 KiB
Diff
From b7791eea502e0d98ae204750aff2abafc431fb11 Mon Sep 17 00:00:00 2001
|
|
From: popcornmix <popcornmix@gmail.com>
|
|
Date: Tue, 6 Dec 2016 17:05:39 +0000
|
|
Subject: [PATCH] bcm2835-rng: Avoid initialising if already enabled
|
|
|
|
Avoids the 0x40000 cycles of warmup again if firmware has already used it
|
|
---
|
|
drivers/char/hw_random/bcm2835-rng.c | 7 ++++---
|
|
1 file changed, 4 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/drivers/char/hw_random/bcm2835-rng.c b/drivers/char/hw_random/bcm2835-rng.c
|
|
index 7192ec2..2ff49c1 100644
|
|
--- a/drivers/char/hw_random/bcm2835-rng.c
|
|
+++ b/drivers/char/hw_random/bcm2835-rng.c
|
|
@@ -62,9 +62,10 @@ static int bcm2835_rng_probe(struct platform_device *pdev)
|
|
bcm2835_rng_ops.priv = (unsigned long)rng_base;
|
|
|
|
/* set warm-up count & enable */
|
|
- __raw_writel(RNG_WARMUP_COUNT, rng_base + RNG_STATUS);
|
|
- __raw_writel(RNG_RBGEN, rng_base + RNG_CTRL);
|
|
-
|
|
+ if (!(__raw_readl(rng_base + RNG_CTRL) & RNG_RBGEN)) {
|
|
+ __raw_writel(RNG_WARMUP_COUNT, rng_base + RNG_STATUS);
|
|
+ __raw_writel(RNG_RBGEN, rng_base + RNG_CTRL);
|
|
+ }
|
|
/* register driver */
|
|
err = hwrng_register(&bcm2835_rng_ops);
|
|
if (err) {
|
|
--
|
|
2.1.4
|
|
|