mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 23:42:43 +00:00
e95b1b23f1
Ran update_kernel.sh in a fresh clone without any existing toolchains. Manually rebased: bcm27xx 950-0267-xhci-add-quirk-for-host-controllers-that-don-t-updat.patch bcm53xx 180-usb-xhci-add-support-for-performing-fake-doorbell.patch layerscape 302-dts-0008-arm64-dts-ls1046a-accumulated-change-to-ls1046a-boar.patch 820-usb-0016-MLK-16735-usb-host-add-XHCI_CDNS_HOST-flag.patch 820-usb-0018-MLK-18794-1-usb-host-xhci-add-.bus_suspend-override.patch Build system: x86_64 Build-tested: bcm27xx/bcm2711, ipq806x/R7800 Run-tested: ipq806x/R7800 No dmesg regressions/everything functional. Signed-off-by: John Audia <graysky@archlinux.us> [remove quilt comment, fix/adjust 820-usb-* layerscape patches] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
37 lines
1.2 KiB
Diff
37 lines
1.2 KiB
Diff
From 7542fb08d2726606057c4283b3a454abb195a0f5 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Mon, 23 Sep 2019 09:26:41 +0100
|
|
Subject: [PATCH] kbuild: Allow .dtbo overlays to be built piecemeal
|
|
|
|
Before 4.20, it was possible to build an arbitrary overlay by copying
|
|
it to arm/boot/dts/overlays/mytest-overlay.dts and running:
|
|
|
|
make ARCH=arm overlays/mytest.dtbo
|
|
|
|
In 4.20 the .dtb build rules were centralised, requiring the dowstream
|
|
.dtbo build rules to be changed. They were, enough to support "make ...
|
|
dtbs", but not sufficiently to allow this ad-hoc, one-off building of
|
|
individual files.
|
|
|
|
Add the missing makefile rule to support this way of building.
|
|
|
|
See: https://github.com/raspberrypi/linux/issues/3250
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
Makefile | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1261,6 +1261,9 @@ ifneq ($(dtstree),)
|
|
%.dtb: include/config/kernel.release scripts_dtc
|
|
$(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
|
|
|
|
+%.dtbo: prepare3 scripts_dtc
|
|
+ $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
|
|
+
|
|
PHONY += dtbs dtbs_install dtbs_check
|
|
dtbs: include/config/kernel.release scripts_dtc
|
|
$(Q)$(MAKE) $(build)=$(dtstree)
|