mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-13 16:31:09 +00:00
0d0cfe9f2d
This updates libtool to its current release, from 2015. Current patches were renumbered and given a description text. The fix in 160-passthrough-ssp.patch is no longer needed. A patch to speed up build was cherry-picked, and another openwrt specific patch was needed to not use quotes in $(SHELL), to acommodate our "SHELL=/usr/bin/env bash" usage. The already present call to ./bootstrap ensures that generated files are refreshed, so the patches are applied only to their sources. Also, that bootstrap call was adjusted to run at the appropriate time when QUILT=1. References below are relevant commits to upstream libtool regarding some of the changes to patches. This commit is being reapplied after previous revertion, and after some editing. The fix for the issue that prompted reverting is the parent of this commit. Ref: 435cb8d71 ("libtoolize: simplify runtime by substituting pkgauxdir") Ref: 3cf11cfe2 ("libtoolize: rewritten over funclib.sh instead of general.m4sh") Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com> Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net> [refactored to simplify patch changes, expanded patches, added upstream references] Signed-off-by: Michael Pratt <mcpratt@pm.me>
73 lines
3.1 KiB
Diff
73 lines
3.1 KiB
Diff
From 879578d3f4dc9bc42aa433b1fb6b584564f83617 Mon Sep 17 00:00:00 2001
|
|
From: Eneas U de Queiroz <cotequeiroz@gmail.com>
|
|
Date: Wed, 21 Jul 2021 13:38:24 -0300
|
|
Subject: openwrt: don't quote $(SHELL) in Makefile.am
|
|
|
|
This allows to use SHELL="env bash" to get a controlled enviroment.
|
|
|
|
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
|
|
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -46,7 +46,7 @@ EXTRA_LTLIBRARIES =
|
|
# Using 'cd' in backquotes may print the directory name, use this instead:
|
|
lt__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
|
|
|
|
-git_version_gen = '$(SHELL)' '$(aux_dir)/git-version-gen' '--fallback' '$(VERSION)' '.tarball-version'
|
|
+git_version_gen = $(SHELL) '$(aux_dir)/git-version-gen' '--fallback' '$(VERSION)' '.tarball-version'
|
|
rebuild = rebuild=:; revision=`$(lt__cd) $(srcdir) && $(git_version_gen) | $(SED) 's|-.*$$||'`
|
|
|
|
|
|
@@ -301,7 +301,7 @@ libtool: $(ltmain_sh) $(config_status) $
|
|
if test 0 = '$(AM_DEFAULT_VERBOSITY)' && test 1 != '$(V)'; \
|
|
then echo " GEN " $@; \
|
|
else echo '$(SHELL) $(top_builddir)/config.status "$@"'; fi; \
|
|
- cd '$(top_builddir)' && '$(SHELL)' ./config.status '$@'; \
|
|
+ cd '$(top_builddir)' && $(SHELL) ./config.status '$@'; \
|
|
fi
|
|
|
|
|
|
@@ -788,13 +788,13 @@ testsuite_deps_uninstalled = $(testsuite
|
|
# Hook the test suite into the check rule
|
|
check-local: $(testsuite_deps_uninstalled)
|
|
$(AM_V_at)$(CD_TESTDIR); \
|
|
- CONFIG_SHELL='$(SHELL)' '$(SHELL)' "$$abs_srcdir/$(TESTSUITE)" \
|
|
+ CONFIG_SHELL=$(SHELL) $(SHELL) "$$abs_srcdir/$(TESTSUITE)" \
|
|
$(TESTS_ENVIRONMENT) $(BUILDCHECK_ENVIRONMENT) $(TESTSUITEFLAGS)
|
|
|
|
# Run the test suite on the *installed* tree.
|
|
installcheck-local: $(testsuite_deps)
|
|
$(AM_V_at)$(CD_TESTDIR); \
|
|
- CONFIG_SHELL='$(SHELL)' '$(SHELL)' "$$abs_srcdir/$(TESTSUITE)" \
|
|
+ CONFIG_SHELL=$(SHELL) $(SHELL) "$$abs_srcdir/$(TESTSUITE)" \
|
|
$(TESTS_ENVIRONMENT) $(INSTALLCHECK_ENVIRONMENT) $(TESTSUITEFLAGS) \
|
|
AUTOTEST_PATH='$(exec_prefix)/bin'
|
|
|
|
@@ -806,7 +806,7 @@ check-noninteractive-old:
|
|
.PHONY: check-noninteractive-new
|
|
check-noninteractive-new: $(testsuite_deps_uninstalled)
|
|
$(AM_V_at)$(CD_TESTDIR); \
|
|
- CONFIG_SHELL='$(SHELL)' '$(SHELL)' "$$abs_srcdir/$(TESTSUITE)" \
|
|
+ CONFIG_SHELL=$(SHELL) $(SHELL) "$$abs_srcdir/$(TESTSUITE)" \
|
|
$(TESTS_ENVIRONMENT) $(BUILDCHECK_ENVIRONMENT) \
|
|
-k '!interactive' INNER_TESTSUITEFLAGS=',!interactive' \
|
|
$(TESTSUITEFLAGS)
|
|
@@ -815,7 +815,7 @@ check-noninteractive-new: $(testsuite_de
|
|
.PHONY: check-interactive
|
|
check-interactive: $(testsuite_deps_uninstalled)
|
|
$(AM_V_at)$(CD_TESTDIR); \
|
|
- CONFIG_SHELL='$(SHELL)' '$(SHELL)' "$$abs_srcdir/$(TESTSUITE)" \
|
|
+ CONFIG_SHELL=$(SHELL) $(SHELL) "$$abs_srcdir/$(TESTSUITE)" \
|
|
$(TESTS_ENVIRONMENT) $(BUILDCHECK_ENVIRONMENT) \
|
|
-k interactive -k recursive INNER_TESTSUITEFLAGS=',interactive' \
|
|
$(TESTSUITEFLAGS)
|
|
@@ -827,7 +827,7 @@ check-noninteractive: check-noninteracti
|
|
clean-local:
|
|
-$(CD_TESTDIR); \
|
|
test -f "$$abs_srcdir/$(TESTSUITE)" && \
|
|
- '$(SHELL)' "$$abs_srcdir/$(TESTSUITE)" --clean
|
|
+ $(SHELL) "$$abs_srcdir/$(TESTSUITE)" --clean
|
|
|
|
## An empty target to depend on when a rule needs to always run
|
|
## whenever it is visited.
|