mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 22:47:56 +00:00
28cec43807
Compiles faster, is PIC by default, and does not have pkgconfig files with wrong paths. Add various fixes to it as it seems cross compilation was never tested. Signed-off-by: Rosen Penev <rosenp@gmail.com>
24 lines
811 B
Diff
24 lines
811 B
Diff
From 4194bb5b35e9b5f3296bf17b7cabcc5cb1632ba3 Mon Sep 17 00:00:00 2001
|
|
From: Rosen Penev <rosenp@gmail.com>
|
|
Date: Fri, 29 Apr 2022 16:55:15 -0700
|
|
Subject: [PATCH 3/7] meson: fix cpu_set_t test
|
|
|
|
_GNU_SOURCE is needed here.
|
|
|
|
Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
|
---
|
|
meson.build | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -379,7 +379,7 @@ endforeach
|
|
have = cc.has_header('sched.h')
|
|
conf.set10('HAVE_DECL_CPU_ALLOC', have)
|
|
# We get -1 if the size cannot be determined
|
|
-have_cpu_set_t = cc.sizeof('cpu_set_t', prefix : '#include <sched.h>') > 0
|
|
+have_cpu_set_t = cc.sizeof('cpu_set_t', prefix : '#define _GNU_SOURCE\n#include <sched.h>') > 0
|
|
conf.set('HAVE_CPU_SET_T', have_cpu_set_t ? 1 : false)
|
|
|
|
have = cc.has_header_symbol('stdlib.h', 'environ')
|