mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
63a0a4d85b
This adds support for the RTL9300 and RTL9310 I2C controller. The controller implements the SMBus protocol for SMBus transfers over an I2C bus. The driver supports selecting one of the 2 possible SCL pins and any of the 8 possible SDA pins. Bus speeds of 100kHz (standard speed) and 400kHz (high speed I2C) are supported. Signed-off-by: Birger Koblitz <git@birger-koblitz.de>
30 lines
938 B
Diff
30 lines
938 B
Diff
--- a/drivers/i2c/busses/Kconfig
|
|
+++ b/drivers/i2c/busses/Kconfig
|
|
@@ -954,6 +954,16 @@ config I2C_RK3X
|
|
This driver can also be built as a module. If so, the module will
|
|
be called i2c-rk3x.
|
|
|
|
+config I2C_RTL9300
|
|
+ tristate "Realtek RTL9300 I2C adapter"
|
|
+ depends on OF
|
|
+ help
|
|
+ Say Y here to include support for the I2C adapter in Realtek RTL9300
|
|
+ and RTL9310 SoCs.
|
|
+
|
|
+ This driver can also be built as a module. If so, the module will
|
|
+ be called i2c-rtl9300.
|
|
+
|
|
config HAVE_S3C2410_I2C
|
|
bool
|
|
help
|
|
--- a/drivers/i2c/busses/Makefile
|
|
+++ b/drivers/i2c/busses/Makefile
|
|
@@ -95,6 +95,7 @@ obj-$(CONFIG_I2C_QCOM_GENI) += i2c-qcom-
|
|
obj-$(CONFIG_I2C_QUP) += i2c-qup.o
|
|
obj-$(CONFIG_I2C_RIIC) += i2c-riic.o
|
|
obj-$(CONFIG_I2C_RK3X) += i2c-rk3x.o
|
|
+obj-$(CONFIG_I2C_RTL9300) += i2c-rtl9300.o
|
|
obj-$(CONFIG_I2C_S3C2410) += i2c-s3c2410.o
|
|
obj-$(CONFIG_I2C_SH7760) += i2c-sh7760.o
|
|
obj-$(CONFIG_I2C_SH_MOBILE) += i2c-sh_mobile.o
|