mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
39 lines
1.5 KiB
Diff
39 lines
1.5 KiB
Diff
From 19098934f910b4d47cb30251dd39ffa57bef9523 Mon Sep 17 00:00:00 2001
|
|
From: John Thomson <git@johnthomson.fastmail.com.au>
|
|
Date: Tue, 6 Dec 2022 06:46:45 +1000
|
|
Subject: [PATCH] PCI: mt7621: Add sentinel to quirks table
|
|
|
|
Current driver is missing a sentinel in the struct soc_device_attribute
|
|
array, which causes an oops when assessed by the
|
|
soc_device_match(mt7621_pcie_quirks_match) call.
|
|
|
|
This was only exposed once the CONFIG_SOC_MT7621 mt7621 soc_dev_attr
|
|
was fixed to register the SOC as a device, in:
|
|
|
|
commit 7c18b64bba3b ("mips: ralink: mt7621: do not use kzalloc too early")
|
|
|
|
Fix it by adding the required sentinel.
|
|
|
|
Link: https://lore.kernel.org/lkml/26ebbed1-0fe9-4af9-8466-65f841d0b382@app.fastmail.com
|
|
Link: https://lore.kernel.org/r/20221205204645.301301-1-git@johnthomson.fastmail.com.au
|
|
Fixes: b483b4e4d3f6 ("staging: mt7621-pci: add quirks for 'E2' revision using 'soc_device_attribute'")
|
|
Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
|
|
Signed-off-by: Lorenzo Pieralisi <lpieralisi@kernel.org>
|
|
Acked-by: Sergio Paracuellos <sergio.paracuellos@gmail.com>
|
|
---
|
|
drivers/pci/controller/pcie-mt7621.c | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
--- a/drivers/pci/controller/pcie-mt7621.c
|
|
+++ b/drivers/pci/controller/pcie-mt7621.c
|
|
@@ -471,7 +471,8 @@ static int mt7621_pcie_register_host(str
|
|
}
|
|
|
|
static const struct soc_device_attribute mt7621_pcie_quirks_match[] = {
|
|
- { .soc_id = "mt7621", .revision = "E2" }
|
|
+ { .soc_id = "mt7621", .revision = "E2" },
|
|
+ { /* sentinel */ }
|
|
};
|
|
|
|
static int mt7621_pcie_probe(struct platform_device *pdev)
|