mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-30 10:39:04 +00:00
3001d3c5d4
On master, the bootwrapper link-address for all simpleImage targets was relocated to 0x15000000 due to growing kernel size. This was not done on OpenWrt 23.05, as the decompressed kernel still fits. However, with the wrapper for the WS-AP3710i, the bootloader attempts execute in-place with the uImage load-address of 0x1000000. As the image is compiled without the uImage header in mind, this naturally fails. In order to fix this, link the WS-AP3715i simpleImage at 0x15000000 as done in master. This will force the bootloader to relocate the code to the proper address and skip XIP. Signed-off-by: David Bauer <mail@david-bauer.net>
31 lines
986 B
Diff
31 lines
986 B
Diff
--- a/arch/powerpc/platforms/85xx/Kconfig
|
|
+++ b/arch/powerpc/platforms/85xx/Kconfig
|
|
@@ -123,6 +123,17 @@ config FIREBOX_T10
|
|
This board is a VPN Gateway-Router with a
|
|
Freescale P1010 SoC.
|
|
|
|
+config MSM460
|
|
+ bool "HPE MSM460"
|
|
+ select DEFAULT_UIMAGE
|
|
+ select ARCH_REQUIRE_GPIOLIB
|
|
+ select GPIO_MPC8XXX
|
|
+ help
|
|
+ This option enables support for the HPE MSM460 board.
|
|
+
|
|
+ This board is a Concurrent Dual-Band wireless access point with a
|
|
+ Freescale P1020 SoC.
|
|
+
|
|
config MPC8540_ADS
|
|
bool "Freescale MPC8540 ADS"
|
|
select DEFAULT_UIMAGE
|
|
--- a/arch/powerpc/platforms/85xx/Makefile
|
|
+++ b/arch/powerpc/platforms/85xx/Makefile
|
|
@@ -21,6 +21,7 @@ obj-$(CONFIG_MPC8536_DS) += mpc8536_ds.
|
|
obj-$(CONFIG_MPC85xx_DS) += mpc85xx_ds.o
|
|
obj-$(CONFIG_MPC85xx_MDS) += mpc85xx_mds.o
|
|
obj-$(CONFIG_MPC85xx_RDB) += mpc85xx_rdb.o
|
|
+obj-$(CONFIG_MSM460) += msm460.o
|
|
obj-$(CONFIG_P1010_RDB) += p1010rdb.o
|
|
obj-$(CONFIG_P1022_DS) += p1022_ds.o
|
|
obj-$(CONFIG_P1022_RDK) += p1022_rdk.o
|