mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-27 17:18:59 +00:00
ae06a650d6
Use upstream latest git HEAD as it allows to remove the patches 700-radius-Prevent-buffer-overflow-in-rc_mksid, 701-pppd-Fix-bounds-check-in-EAP-code and 702-pppd-Ignore-received-EAP-messages-when-not-doing-EAP and take in other fixes. 41a7323 pppd: Fixed spelling 'unkown' => 'unknown' (#141) 6b014be pppd: Print version information to stdout instead of stderr (#133) cba2736 pppd: Add RFC1990 (Multilink) to the See Also section of the man page f2f9554 pppd: Add mppe.h to the list of headers to install if MPPE is defined ae54fcf pppd: Obfuscate password argument string 8d45443 pppd: Ignore received EAP messages when not doing EAP 8d7970b pppd: Fix bounds check in EAP code 858976b radius: Prevent buffer overflow in rc_mksid() Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
89 lines
2.7 KiB
Diff
89 lines
2.7 KiB
Diff
build: Do not strip binaries on install
|
|
|
|
Strippign executables should be handled by the distro packaging, not by ppp
|
|
itself. This patch removes the "-s" (strip) switch from all "install" commands
|
|
in order to install unstripped binaries into the destination prefix.
|
|
|
|
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
|
|
|
|
--- a/chat/Makefile.linux
|
|
+++ b/chat/Makefile.linux
|
|
@@ -25,7 +25,7 @@ chat.o: chat.c
|
|
|
|
install: chat
|
|
mkdir -p $(BINDIR) $(MANDIR)
|
|
- $(INSTALL) -s -c chat $(BINDIR)
|
|
+ $(INSTALL) -c chat $(BINDIR)
|
|
$(INSTALL) -c -m 644 chat.8 $(MANDIR)
|
|
|
|
clean:
|
|
--- a/pppd/Makefile.linux
|
|
+++ b/pppd/Makefile.linux
|
|
@@ -108,7 +108,7 @@ ifdef USE_SRP
|
|
CFLAGS += -DUSE_SRP -DOPENSSL -I/usr/local/ssl/include
|
|
LIBS += -lsrp -L/usr/local/ssl/lib -lcrypto
|
|
TARGETS += srp-entry
|
|
-EXTRAINSTALL = $(INSTALL) -s -c -m 555 srp-entry $(BINDIR)/srp-entry
|
|
+EXTRAINSTALL = $(INSTALL) -c -m 555 srp-entry $(BINDIR)/srp-entry
|
|
MANPAGES += srp-entry.8
|
|
EXTRACLEAN += srp-entry.o
|
|
NEEDDES=y
|
|
@@ -220,7 +220,7 @@ all: $(TARGETS)
|
|
install: pppd
|
|
mkdir -p $(BINDIR) $(MANDIR)
|
|
$(EXTRAINSTALL)
|
|
- $(INSTALL) -s -c -m 555 pppd $(BINDIR)/pppd
|
|
+ $(INSTALL) -c -m 555 pppd $(BINDIR)/pppd
|
|
if chgrp pppusers $(BINDIR)/pppd 2>/dev/null; then \
|
|
chmod o-rx,u+s $(BINDIR)/pppd; fi
|
|
$(INSTALL) -c -m 444 pppd.8 $(MANDIR)
|
|
--- a/pppd/plugins/radius/Makefile.linux
|
|
+++ b/pppd/plugins/radius/Makefile.linux
|
|
@@ -36,9 +36,9 @@ all: $(PLUGIN)
|
|
|
|
install: all
|
|
$(INSTALL) -d -m 755 $(LIBDIR)
|
|
- $(INSTALL) -s -c -m 755 radius.so $(LIBDIR)
|
|
- $(INSTALL) -s -c -m 755 radattr.so $(LIBDIR)
|
|
- $(INSTALL) -s -c -m 755 radrealms.so $(LIBDIR)
|
|
+ $(INSTALL) -c -m 755 radius.so $(LIBDIR)
|
|
+ $(INSTALL) -c -m 755 radattr.so $(LIBDIR)
|
|
+ $(INSTALL) -c -m 755 radrealms.so $(LIBDIR)
|
|
$(INSTALL) -c -m 444 pppd-radius.8 $(MANDIR)
|
|
$(INSTALL) -c -m 444 pppd-radattr.8 $(MANDIR)
|
|
|
|
--- a/pppd/plugins/rp-pppoe/Makefile.linux
|
|
+++ b/pppd/plugins/rp-pppoe/Makefile.linux
|
|
@@ -43,9 +43,9 @@ rp-pppoe.so: plugin.o discovery.o if.o c
|
|
|
|
install: all
|
|
$(INSTALL) -d -m 755 $(LIBDIR)
|
|
- $(INSTALL) -s -c -m 4550 rp-pppoe.so $(LIBDIR)
|
|
+ $(INSTALL) -c -m 4550 rp-pppoe.so $(LIBDIR)
|
|
$(INSTALL) -d -m 755 $(BINDIR)
|
|
- $(INSTALL) -s -c -m 555 pppoe-discovery $(BINDIR)
|
|
+ $(INSTALL) -c -m 555 pppoe-discovery $(BINDIR)
|
|
|
|
clean:
|
|
rm -f *.o *.so pppoe-discovery
|
|
--- a/pppdump/Makefile.linux
|
|
+++ b/pppdump/Makefile.linux
|
|
@@ -17,5 +17,5 @@ clean:
|
|
|
|
install:
|
|
mkdir -p $(BINDIR) $(MANDIR)
|
|
- $(INSTALL) -s -c pppdump $(BINDIR)
|
|
+ $(INSTALL) -c pppdump $(BINDIR)
|
|
$(INSTALL) -c -m 444 pppdump.8 $(MANDIR)
|
|
--- a/pppstats/Makefile.linux
|
|
+++ b/pppstats/Makefile.linux
|
|
@@ -22,7 +22,7 @@ all: pppstats
|
|
|
|
install: pppstats
|
|
-mkdir -p $(MANDIR)
|
|
- $(INSTALL) -s -c pppstats $(BINDIR)
|
|
+ $(INSTALL) -c pppstats $(BINDIR)
|
|
$(INSTALL) -c -m 444 pppstats.8 $(MANDIR)
|
|
|
|
pppstats: $(PPPSTATSRCS)
|