mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-19 19:27:27 +00:00
7bf62e2451
All patches automatically rebased.
Build system: x86_64
Build-tested: ramips/mt7621*
*Had to revert 7f1edbd
in order to build due to FS#4149
Signed-off-by: John Audia <graysky@archlinux.us>
27 lines
844 B
Diff
27 lines
844 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -580,6 +580,13 @@ config XILINX_GMII2RGMII
|
|
the Reduced Gigabit Media Independent Interface(RGMII) between
|
|
Ethernet physical media devices and the Gigabit Ethernet controller.
|
|
|
|
+config AR40XX_PHY
|
|
+ tristate "Driver for Qualcomm Atheros IPQ40XX switches"
|
|
+ depends on HAS_IOMEM && OF && OF_MDIO
|
|
+ select SWCONFIG
|
|
+ help
|
|
+ This is the driver for Qualcomm Atheros IPQ40XX ESS switches.
|
|
+
|
|
endif # PHYLIB
|
|
|
|
config MICREL_KS8995MA
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -68,6 +68,7 @@ ifdef CONFIG_HWMON
|
|
aquantia-objs += aquantia_hwmon.o
|
|
endif
|
|
obj-$(CONFIG_AQUANTIA_PHY) += aquantia.o
|
|
+obj-$(CONFIG_AR40XX_PHY) += ar40xx.o
|
|
obj-$(CONFIG_AX88796B_PHY) += ax88796b.o
|
|
obj-$(CONFIG_AT803X_PHY) += at803x.o
|
|
obj-$(CONFIG_BCM63XX_PHY) += bcm63xx.o
|