mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-11 15:33:03 +00:00
f32085fc0b
Airoha is a new ARM platform based on Cortex-A53 which has recently been merged into linux-next. Due to BootROM limitations on this platform, the Cortex-A53 can't run in Aarch64 mode and code must be compiled for 32-Bit ARM. This support is based mostly on those linux-next commits backported for kernel 5.15. Patches: 1 - platform support = linux-next 2 - clock driver = linux-next 3 - gpio driver = linux-next 4 - linux,usable-memory-range dts support = linux-next 5 - mtd spinand driver 6 - spi driver 7 - pci driver (kconfig only, uses mediatek PCI) = linux-next Still missing: - Ethernet driver - Sysupgrade support A.t.m there exists one subtarget EN7523 with only one evaluation board. The initramfs can be run with the following commands from u-boot: - u-boot> setenv bootfile \ openwrt-airoha-airoha_en7523-evb-initramfs-kernel.bin u-boot> tftpboot u-boot> bootm 0x81800000 - Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
34 lines
1.1 KiB
Diff
34 lines
1.1 KiB
Diff
diff --git a/drivers/gpio/Kconfig b/drivers/gpio/Kconfig
|
|
index cbfb6f13..b3106df6 100644
|
|
--- a/drivers/gpio/Kconfig
|
|
+++ b/drivers/gpio/Kconfig
|
|
@@ -247,6 +247,16 @@ config GPIO_EM
|
|
help
|
|
Say yes here to support GPIO on Renesas Emma Mobile SoCs.
|
|
|
|
+config GPIO_EN7523
|
|
+ tristate "Airoha GPIO support"
|
|
+ depends on ARCH_AIROHA
|
|
+ default ARCH_AIROHA
|
|
+ select GPIO_GENERIC
|
|
+ select GPIOLIB_IRQCHIP
|
|
+ help
|
|
+ Say Y or M here to support the GPIO controller block on the
|
|
+ Airoha EN7523 SoC. It supports two banks of 32 GPIOs.
|
|
+
|
|
config GPIO_EP93XX
|
|
def_bool y
|
|
depends on ARCH_EP93XX
|
|
diff --git a/drivers/gpio/Makefile b/drivers/gpio/Makefile
|
|
index 61202717..4c73ce82 100644
|
|
--- a/drivers/gpio/Makefile
|
|
+++ b/drivers/gpio/Makefile
|
|
@@ -57,6 +57,7 @@ obj-$(CONFIG_GPIO_DLN2) += gpio-dln2.o
|
|
obj-$(CONFIG_GPIO_DWAPB) += gpio-dwapb.o
|
|
obj-$(CONFIG_GPIO_EIC_SPRD) += gpio-eic-sprd.o
|
|
obj-$(CONFIG_GPIO_EM) += gpio-em.o
|
|
+obj-$(CONFIG_GPIO_EN7523) += gpio-en7523.o
|
|
obj-$(CONFIG_GPIO_EP93XX) += gpio-ep93xx.o
|
|
obj-$(CONFIG_GPIO_EXAR) += gpio-exar.o
|
|
obj-$(CONFIG_GPIO_F7188X) += gpio-f7188x.o
|