mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-18 13:26:34 +00:00
iproute2: update to 6.12.0
Release Notes: https://lore.kernel.org/netdev/20241119092743.6a1bdcb7@hermes.local/T/ Allows us to drop 2 upstreamed patches: package/network/utils/iproute2/patches/010-bridge-mst-fix-a-musl-build-issue.patch package/network/utils/iproute2/patches/011-bridge-mst-fix-a-further-musl-build-issue.patch Signed-off-by: Robert Marko <robert.marko@sartura.hr> Link: https://github.com/openwrt/openwrt/pull/17206 Signed-off-by: Robert Marko <robimarko@gmail.com>
This commit is contained in:
parent
f8b93e2d12
commit
ff5f77ecdd
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=iproute2
|
||||
PKG_VERSION:=6.11.0
|
||||
PKG_VERSION:=6.12.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
|
||||
PKG_HASH:=1f795398a04aeaacd06a8f6ace2cfd913c33fa5953ca99daae83bb5c534611c3
|
||||
PKG_HASH:=bbd141ef7b5d0127cc2152843ba61f274dc32814fa3e0f13e7d07a080bef53d9
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_BUILD_DEPENDS:=iptables
|
||||
PKG_LICENSE:=GPL-2.0
|
||||
|
@ -1,68 +0,0 @@
|
||||
From 6a77abab92516e65f07f8657fc4e384c4541ce0e Mon Sep 17 00:00:00 2001
|
||||
From: Dario Binacchi <dario.binacchi@amarulasolutions.com>
|
||||
Date: Sun, 22 Sep 2024 16:50:10 +0200
|
||||
Subject: bridge: mst: fix a musl build issue
|
||||
|
||||
This patch fixes a compilation error raised by the bump to version 6.11.0
|
||||
in Buildroot using musl as the C library for the cross-compilation
|
||||
toolchain.
|
||||
|
||||
After setting the CFLGAS
|
||||
|
||||
ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
|
||||
IPROUTE2_CFLAGS += -D__UAPI_DEF_IN6_ADDR=0 -D__UAPI_DEF_SOCKADDR_IN6=0 \
|
||||
-D__UAPI_DEF_IPV6_MREQ=0
|
||||
endif
|
||||
|
||||
to fix the following errors:
|
||||
|
||||
In file included from ../../../host/mips64-buildroot-linux-musl/sysroot/usr/include/arpa/inet.h:9,
|
||||
from ../include/libnetlink.h:14,
|
||||
from mst.c:10:
|
||||
../../../host/mips64-buildroot-linux-musl/sysroot/usr/include/netinet/in.h:23:8: error: redefinition of 'struct in6_addr'
|
||||
23 | struct in6_addr {
|
||||
| ^~~~~~~~
|
||||
In file included from ../include/uapi/linux/if_bridge.h:19,
|
||||
from mst.c:7:
|
||||
../include/uapi/linux/in6.h:33:8: note: originally defined here
|
||||
33 | struct in6_addr {
|
||||
| ^~~~~~~~
|
||||
../../../host/mips64-buildroot-linux-musl/sysroot/usr/include/netinet/in.h:34:8: error: redefinition of 'struct sockaddr_in6'
|
||||
34 | struct sockaddr_in6 {
|
||||
| ^~~~~~~~~~~~
|
||||
../include/uapi/linux/in6.h:50:8: note: originally defined here
|
||||
50 | struct sockaddr_in6 {
|
||||
| ^~~~~~~~~~~~
|
||||
../../../host/mips64-buildroot-linux-musl/sysroot/usr/include/netinet/in.h:42:8: error: redefinition of 'struct ipv6_mreq'
|
||||
42 | struct ipv6_mreq {
|
||||
| ^~~~~~~~~
|
||||
../include/uapi/linux/in6.h:60:8: note: originally defined here
|
||||
60 | struct ipv6_mreq {
|
||||
|
||||
I got this further errors
|
||||
|
||||
../include/uapi/linux/in6.h:72:25: error: field 'flr_dst' has incomplete type
|
||||
72 | struct in6_addr flr_dst;
|
||||
| ^~~~~~~
|
||||
../include/uapi/linux/if_bridge.h:711:41: error: field 'ip6' has incomplete type
|
||||
711 | struct in6_addr ip6;
|
||||
| ^~~
|
||||
|
||||
fixed by including the netinet/in.h header.
|
||||
|
||||
Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
|
||||
Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
|
||||
---
|
||||
bridge/mst.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
--- a/bridge/mst.c
|
||||
+++ b/bridge/mst.c
|
||||
@@ -4,6 +4,7 @@
|
||||
*/
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <netinet/in.h>
|
||||
#include <linux/if_bridge.h>
|
||||
#include <net/if.h>
|
||||
|
@ -1,51 +0,0 @@
|
||||
From 043ef90e2fa94397eb5c85330889ca4146a6d58a Mon Sep 17 00:00:00 2001
|
||||
From: Dario Binacchi <dario.binacchi@amarulasolutions.com>
|
||||
Date: Sun, 22 Sep 2024 16:50:11 +0200
|
||||
Subject: bridge: mst: fix a further musl build issue
|
||||
|
||||
This patch fixes the following build errors:
|
||||
|
||||
In file included from mst.c:11:
|
||||
../include/json_print.h:80:30: warning: 'struct timeval' declared inside parameter list will not be visible outside of this definition or declaration
|
||||
80 | _PRINT_FUNC(tv, const struct timeval *)
|
||||
| ^~~~~~~
|
||||
../include/json_print.h:50:37: note: in definition of macro '_PRINT_FUNC'
|
||||
50 | type value); \
|
||||
| ^~~~
|
||||
../include/json_print.h:80:30: warning: 'struct timeval' declared inside parameter list will not be visible outside of this definition or declaration
|
||||
80 | _PRINT_FUNC(tv, const struct timeval *)
|
||||
| ^~~~~~~
|
||||
../include/json_print.h:55:45: note: in definition of macro '_PRINT_FUNC'
|
||||
55 | type value) \
|
||||
| ^~~~
|
||||
../include/json_print.h: In function 'print_tv':
|
||||
../include/json_print.h:58:48: error: passing argument 5 of 'print_color_tv' from incompatible pointer type [-Wincompatible-pointer-types]
|
||||
58 | value); \
|
||||
| ^~~~~
|
||||
| |
|
||||
| const struct timeval *
|
||||
../include/json_print.h:80:1: note: in expansion of macro '_PRINT_FUNC'
|
||||
80 | _PRINT_FUNC(tv, const struct timeval *)
|
||||
| ^~~~~~~~~~~
|
||||
../include/json_print.h:50:42: note: expected 'const struct timeval *' but argument is of type 'const struct timeval *'
|
||||
50 | type value); \
|
||||
| ^
|
||||
../include/json_print.h:80:1: note: in expansion of macro '_PRINT_FUNC'
|
||||
80 | _PRINT_FUNC(tv, const struct timeval *)
|
||||
|
||||
Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
|
||||
Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
|
||||
---
|
||||
bridge/mst.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
--- a/bridge/mst.c
|
||||
+++ b/bridge/mst.c
|
||||
@@ -4,6 +4,7 @@
|
||||
*/
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <sys/time.h>
|
||||
#include <netinet/in.h>
|
||||
#include <linux/if_bridge.h>
|
||||
#include <net/if.h>
|
Loading…
Reference in New Issue
Block a user