mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
ipq40xx: add MikroTik hAP ac2 support
This adds support for the MikroTik RouterBOARD RBD52G-5HacD2HnD-TC (hAP ac²), a indoor dual band, dual-radio 802.11ac wireless AP with integrated omnidirectional antennae, USB port and five 10/100/1000 Mbps Ethernet ports. See https://mikrotik.com/product/hap_ac2 for more info. Specifications: - SoC: Qualcomm Atheros IPQ4018 - RAM: 128 MB - Storage: 16 MB NOR - Wireless: · Built-in IPQ4018 (SoC) 802.11b/g/n 2x2:2, 2.5 dBi antennae · Built-in IPQ4018 (SoC) 802.11a/n/ac 2x2:2, 2.5 dBi antennae - Ethernet: Built-in IPQ4018 (SoC, QCA8075) , 5x 1000/100/10 port, passive PoE in - 1x USB Type A port Installation: Boot the initramfs image via TFTP and then flash the sysupgrade image using "sysupgrade -n" Signed-off-by: Robert Marko <robimarko@gmail.com>
This commit is contained in:
parent
1db4681617
commit
faea7becaf
@ -43,6 +43,7 @@ ALLWIFIBOARDS:= \
|
|||||||
linksys_ea8300 \
|
linksys_ea8300 \
|
||||||
linksys_mr8300-v0 \
|
linksys_mr8300-v0 \
|
||||||
luma_wrtq-329acn \
|
luma_wrtq-329acn \
|
||||||
|
mikrotik_hap-ac2 \
|
||||||
mobipromo_cm520-79f \
|
mobipromo_cm520-79f \
|
||||||
nec_wg2600hp3 \
|
nec_wg2600hp3 \
|
||||||
plasmacloud_pa1200 \
|
plasmacloud_pa1200 \
|
||||||
@ -126,6 +127,7 @@ $(eval $(call generate-ipq-wifi-package,glinet_gl-s1300,GL.iNet GL-S1300))
|
|||||||
$(eval $(call generate-ipq-wifi-package,linksys_ea8300,Linksys EA8300))
|
$(eval $(call generate-ipq-wifi-package,linksys_ea8300,Linksys EA8300))
|
||||||
$(eval $(call generate-ipq-wifi-package,linksys_mr8300-v0,Linksys MR8300))
|
$(eval $(call generate-ipq-wifi-package,linksys_mr8300-v0,Linksys MR8300))
|
||||||
$(eval $(call generate-ipq-wifi-package,luma_wrtq-329acn,Luma WRTQ-329ACN))
|
$(eval $(call generate-ipq-wifi-package,luma_wrtq-329acn,Luma WRTQ-329ACN))
|
||||||
|
$(eval $(call generate-ipq-wifi-package,mikrotik_hap-ac2,Mikrotik hAP ac2))
|
||||||
$(eval $(call generate-ipq-wifi-package,mobipromo_cm520-79f,MobiPromo CM520-79F))
|
$(eval $(call generate-ipq-wifi-package,mobipromo_cm520-79f,MobiPromo CM520-79F))
|
||||||
$(eval $(call generate-ipq-wifi-package,nec_wg2600hp3,NEC Platforms WG2600HP3))
|
$(eval $(call generate-ipq-wifi-package,nec_wg2600hp3,NEC Platforms WG2600HP3))
|
||||||
$(eval $(call generate-ipq-wifi-package,plasmacloud_pa1200,Plasma Cloud PA1200))
|
$(eval $(call generate-ipq-wifi-package,plasmacloud_pa1200,Plasma Cloud PA1200))
|
||||||
|
BIN
package/firmware/ipq-wifi/board-mikrotik_hap-ac2.qca4019
Normal file
BIN
package/firmware/ipq-wifi/board-mikrotik_hap-ac2.qca4019
Normal file
Binary file not shown.
@ -47,6 +47,7 @@ ipq40xx_setup_interfaces()
|
|||||||
ucidef_set_interfaces_lan_wan "eth1" "eth0"
|
ucidef_set_interfaces_lan_wan "eth1" "eth0"
|
||||||
;;
|
;;
|
||||||
asus,rt-ac58u|\
|
asus,rt-ac58u|\
|
||||||
|
mikrotik,hap-ac2|\
|
||||||
zyxel,nbg6617)
|
zyxel,nbg6617)
|
||||||
ucidef_set_interfaces_lan_wan "eth0" "eth1"
|
ucidef_set_interfaces_lan_wan "eth0" "eth1"
|
||||||
ucidef_add_switch "switch0" \
|
ucidef_add_switch "switch0" \
|
||||||
@ -169,6 +170,11 @@ ipq40xx_setup_macs()
|
|||||||
wan_mac=$(mtd_get_mac_ascii devinfo hw_mac_addr)
|
wan_mac=$(mtd_get_mac_ascii devinfo hw_mac_addr)
|
||||||
lan_mac=$(macaddr_add "$wan_mac" 1)
|
lan_mac=$(macaddr_add "$wan_mac" 1)
|
||||||
;;
|
;;
|
||||||
|
mikrotik,hap-ac2)
|
||||||
|
wan_mac=$(cat /sys/firmware/mikrotik/hard_config/mac_base)
|
||||||
|
lan_mac=$(macaddr_add $wan_mac 1)
|
||||||
|
label_mac="$wan_mac"
|
||||||
|
;;
|
||||||
esac
|
esac
|
||||||
|
|
||||||
[ -n "$lan_mac" ] && ucidef_set_interface_macaddr "lan" $lan_mac
|
[ -n "$lan_mac" ] && ucidef_set_interface_macaddr "lan" $lan_mac
|
||||||
|
@ -140,6 +140,11 @@ case "$FIRMWARE" in
|
|||||||
caldata_valid "202f" || caldata_extract "ART" 0x1000 0x2f20
|
caldata_valid "202f" || caldata_extract "ART" 0x1000 0x2f20
|
||||||
ath10k_patch_mac $(macaddr_add $(get_mac_binary "/sys/bus/i2c/devices/0-0050/eeprom" 0x66) +2)
|
ath10k_patch_mac $(macaddr_add $(get_mac_binary "/sys/bus/i2c/devices/0-0050/eeprom" 0x66) +2)
|
||||||
;;
|
;;
|
||||||
|
mikrotik,hap-ac2)
|
||||||
|
wlan_data="/sys/firmware/mikrotik/hard_config/wlan_data"
|
||||||
|
( [ -f "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data" 0x0 0x2f20 ) || \
|
||||||
|
( [ -d "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data/data_0" 0x0 0x2f20 )
|
||||||
|
;;
|
||||||
netgear,ex6100v2 |\
|
netgear,ex6100v2 |\
|
||||||
netgear,ex6150v2)
|
netgear,ex6150v2)
|
||||||
caldata_extract "ART" 0x1000 0x2f20
|
caldata_extract "ART" 0x1000 0x2f20
|
||||||
@ -244,6 +249,11 @@ case "$FIRMWARE" in
|
|||||||
caldata_valid "202f" || caldata_extract "ART" 0x5000 0x2f20
|
caldata_valid "202f" || caldata_extract "ART" 0x5000 0x2f20
|
||||||
ath10k_patch_mac $(macaddr_add $(get_mac_binary "/sys/bus/i2c/devices/0-0050/eeprom" 0x66) +3)
|
ath10k_patch_mac $(macaddr_add $(get_mac_binary "/sys/bus/i2c/devices/0-0050/eeprom" 0x66) +3)
|
||||||
;;
|
;;
|
||||||
|
mikrotik,hap-ac2)
|
||||||
|
wlan_data="/sys/firmware/mikrotik/hard_config/wlan_data"
|
||||||
|
( [ -f "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data" 0x8000 0x2f20 ) || \
|
||||||
|
( [ -d "$wlan_data" ] && caldata_sysfsload_from_file "$wlan_data/data_2" 0x0 0x2f20 )
|
||||||
|
;;
|
||||||
netgear,ex6100v2 |\
|
netgear,ex6100v2 |\
|
||||||
netgear,ex6150v2)
|
netgear,ex6150v2)
|
||||||
caldata_extract "ART" 0x5000 0x2f20
|
caldata_extract "ART" 0x5000 0x2f20
|
||||||
|
@ -111,6 +111,10 @@ platform_do_upgrade() {
|
|||||||
CI_KERNPART="part.safe"
|
CI_KERNPART="part.safe"
|
||||||
nand_do_upgrade "$1"
|
nand_do_upgrade "$1"
|
||||||
;;
|
;;
|
||||||
|
mikrotik,hap-ac2)
|
||||||
|
[ "$(rootfs_type)" = "tmpfs" ] && mtd erase firmware
|
||||||
|
default_do_upgrade "$1"
|
||||||
|
;;
|
||||||
openmesh,a42 |\
|
openmesh,a42 |\
|
||||||
openmesh,a62 |\
|
openmesh,a62 |\
|
||||||
plasmacloud,pa1200 |\
|
plasmacloud,pa1200 |\
|
||||||
|
@ -0,0 +1,272 @@
|
|||||||
|
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
|
||||||
|
/* Copyright (c) 2020, Robert Marko <robimarko@gmail.com> */
|
||||||
|
|
||||||
|
#include "qcom-ipq4019.dtsi"
|
||||||
|
#include <dt-bindings/gpio/gpio.h>
|
||||||
|
#include <dt-bindings/input/input.h>
|
||||||
|
#include <dt-bindings/soc/qcom,tcsr.h>
|
||||||
|
|
||||||
|
/ {
|
||||||
|
model = "MikroTik hAP ac2";
|
||||||
|
compatible = "mikrotik,hap-ac2";
|
||||||
|
|
||||||
|
memory {
|
||||||
|
device_type = "memory";
|
||||||
|
reg = <0x80000000 0x08000000>;
|
||||||
|
};
|
||||||
|
|
||||||
|
chosen {
|
||||||
|
stdout-path = "serial0:115200n8";
|
||||||
|
};
|
||||||
|
|
||||||
|
aliases {
|
||||||
|
led-boot = &led_user;
|
||||||
|
led-failsafe = &led_user;
|
||||||
|
led-running = &led_user;
|
||||||
|
led-upgrade = &led_user;
|
||||||
|
};
|
||||||
|
|
||||||
|
soc {
|
||||||
|
rng@22000 {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
counter@4a1000 {
|
||||||
|
compatible = "qcom,qca-gcnt";
|
||||||
|
reg = <0x4a1000 0x4>;
|
||||||
|
};
|
||||||
|
|
||||||
|
tcsr@1949000 {
|
||||||
|
compatible = "qcom,tcsr";
|
||||||
|
reg = <0x1949000 0x100>;
|
||||||
|
qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
|
||||||
|
};
|
||||||
|
|
||||||
|
tcsr@194b000 {
|
||||||
|
/* select hostmode */
|
||||||
|
compatible = "qcom,tcsr";
|
||||||
|
reg = <0x194b000 0x100>;
|
||||||
|
qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
ess_tcsr@1953000 {
|
||||||
|
compatible = "qcom,tcsr";
|
||||||
|
reg = <0x1953000 0x1000>;
|
||||||
|
qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
|
||||||
|
};
|
||||||
|
|
||||||
|
tcsr@1957000 {
|
||||||
|
compatible = "qcom,tcsr";
|
||||||
|
reg = <0x1957000 0x100>;
|
||||||
|
qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
|
||||||
|
};
|
||||||
|
|
||||||
|
usb3@8af8800 {
|
||||||
|
status = "okay";
|
||||||
|
|
||||||
|
dwc3@8a00000 {
|
||||||
|
phys = <&usb3_hs_phy>;
|
||||||
|
phy-names = "usb2-phy";
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
crypto@8e3a000 {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
watchdog@b017000 {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
ess-switch@c000000 {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
edma@c080000 {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
keys {
|
||||||
|
compatible = "gpio-keys";
|
||||||
|
|
||||||
|
reset {
|
||||||
|
label = "reset";
|
||||||
|
gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
|
||||||
|
linux,code = <KEY_RESTART>;
|
||||||
|
};
|
||||||
|
|
||||||
|
mode {
|
||||||
|
label = "mode";
|
||||||
|
gpios = <&tlmm 5 GPIO_ACTIVE_LOW>;
|
||||||
|
linux,code = <KEY_RFKILL>;
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
leds {
|
||||||
|
compatible = "gpio-leds";
|
||||||
|
|
||||||
|
power {
|
||||||
|
label = "green:power";
|
||||||
|
gpios = <&tlmm 0 GPIO_ACTIVE_HIGH>;
|
||||||
|
default-state = "keep";
|
||||||
|
panic-indicator;
|
||||||
|
};
|
||||||
|
|
||||||
|
led_user: user {
|
||||||
|
label = "green:user";
|
||||||
|
gpios = <&tlmm 3 GPIO_ACTIVE_HIGH>;
|
||||||
|
};
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
&tlmm {
|
||||||
|
serial_pins: serial_pinmux {
|
||||||
|
mux {
|
||||||
|
pins = "gpio60", "gpio61";
|
||||||
|
function = "blsp_uart0";
|
||||||
|
bias-disable;
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
spi_0_pins: spi_0_pinmux {
|
||||||
|
pin {
|
||||||
|
function = "blsp_spi0";
|
||||||
|
pins = "gpio55", "gpio56", "gpio57";
|
||||||
|
drive-strength = <2>;
|
||||||
|
bias-disable;
|
||||||
|
};
|
||||||
|
pin_cs {
|
||||||
|
function = "gpio";
|
||||||
|
pins = "gpio54";
|
||||||
|
drive-strength = <2>;
|
||||||
|
bias-disable;
|
||||||
|
output-high;
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
enable-usb-power {
|
||||||
|
gpio-hog;
|
||||||
|
gpios = <2 GPIO_ACTIVE_HIGH>;
|
||||||
|
output-high;
|
||||||
|
line-name = "enable USB power";
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
&blsp_dma {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
&blsp1_spi1 {
|
||||||
|
status = "okay";
|
||||||
|
|
||||||
|
pinctrl-0 = <&spi_0_pins>;
|
||||||
|
pinctrl-names = "default";
|
||||||
|
cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>;
|
||||||
|
|
||||||
|
flash@0 {
|
||||||
|
reg = <0>;
|
||||||
|
compatible = "jedec,spi-nor";
|
||||||
|
spi-max-frequency = <40000000>;
|
||||||
|
|
||||||
|
partitions {
|
||||||
|
compatible = "fixed-partitions";
|
||||||
|
#address-cells = <1>;
|
||||||
|
#size-cells = <1>;
|
||||||
|
|
||||||
|
partition@0 {
|
||||||
|
label = "Qualcomm";
|
||||||
|
reg = <0x0 0x80000>;
|
||||||
|
read-only;
|
||||||
|
};
|
||||||
|
|
||||||
|
partition@80000 {
|
||||||
|
compatible = "mikrotik,routerboot-partitions";
|
||||||
|
#address-cells = <1>;
|
||||||
|
#size-cells = <1>;
|
||||||
|
label = "RouterBoot";
|
||||||
|
reg = <0x80000 0x80000>;
|
||||||
|
read-only;
|
||||||
|
|
||||||
|
hard_config {
|
||||||
|
read-only;
|
||||||
|
};
|
||||||
|
|
||||||
|
dtb_config {
|
||||||
|
read-only;
|
||||||
|
};
|
||||||
|
|
||||||
|
soft_config {
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
partition@100000 {
|
||||||
|
compatible = "mikrotik,minor";
|
||||||
|
label = "firmware";
|
||||||
|
reg = <0x100000 0xf00000>;
|
||||||
|
};
|
||||||
|
};
|
||||||
|
};
|
||||||
|
};
|
||||||
|
|
||||||
|
&blsp1_uart1 {
|
||||||
|
status = "okay";
|
||||||
|
|
||||||
|
pinctrl-0 = <&serial_pins>;
|
||||||
|
pinctrl-names = "default";
|
||||||
|
};
|
||||||
|
|
||||||
|
&cryptobam {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
&usb3_hs_phy {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
&mdio {
|
||||||
|
status = "okay";
|
||||||
|
};
|
||||||
|
|
||||||
|
ðphy0 {
|
||||||
|
qcom,single-led-1000;
|
||||||
|
qcom,single-led-100;
|
||||||
|
qcom,single-led-10;
|
||||||
|
};
|
||||||
|
|
||||||
|
ðphy1 {
|
||||||
|
qcom,single-led-1000;
|
||||||
|
qcom,single-led-100;
|
||||||
|
qcom,single-led-10;
|
||||||
|
};
|
||||||
|
|
||||||
|
ðphy2 {
|
||||||
|
qcom,single-led-1000;
|
||||||
|
qcom,single-led-100;
|
||||||
|
qcom,single-led-10;
|
||||||
|
};
|
||||||
|
|
||||||
|
ðphy3 {
|
||||||
|
qcom,single-led-1000;
|
||||||
|
qcom,single-led-100;
|
||||||
|
qcom,single-led-10;
|
||||||
|
};
|
||||||
|
|
||||||
|
ðphy4 {
|
||||||
|
qcom,single-led-1000;
|
||||||
|
qcom,single-led-100;
|
||||||
|
qcom,single-led-10;
|
||||||
|
};
|
||||||
|
|
||||||
|
&wifi0 {
|
||||||
|
status = "okay";
|
||||||
|
|
||||||
|
qcom,ath10k-calibration-variant = "MikroTik-hAP-ac2";
|
||||||
|
};
|
||||||
|
|
||||||
|
&wifi1 {
|
||||||
|
status = "okay";
|
||||||
|
|
||||||
|
qcom,ath10k-calibration-variant = "MikroTik-hAP-ac2";
|
||||||
|
};
|
@ -0,0 +1,20 @@
|
|||||||
|
define Device/mikrotik_nor
|
||||||
|
DEVICE_VENDOR := MikroTik
|
||||||
|
BLOCKSIZE := 64k
|
||||||
|
IMAGE_SIZE := 16128k
|
||||||
|
KERNEL_NAME := vmlinux
|
||||||
|
KERNEL := kernel-bin | append-dtb-elf
|
||||||
|
IMAGES = sysupgrade.bin
|
||||||
|
IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 | \
|
||||||
|
pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | \
|
||||||
|
append-metadata | check-size
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Device/mikrotik_hap-ac2
|
||||||
|
$(call Device/mikrotik_nor)
|
||||||
|
DEVICE_MODEL := hAP ac2
|
||||||
|
SOC := qcom-ipq4018
|
||||||
|
DEVICE_PACKAGES := ipq-wifi-mikrotik_hap-ac2 -kmod-ath10k-ct \
|
||||||
|
kmod-ath10k-ct-smallbuffers
|
||||||
|
endef
|
||||||
|
TARGET_DEVICES += mikrotik_hap-ac2
|
@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
|||||||
|
|
||||||
--- a/arch/arm/boot/dts/Makefile
|
--- a/arch/arm/boot/dts/Makefile
|
||||||
+++ b/arch/arm/boot/dts/Makefile
|
+++ b/arch/arm/boot/dts/Makefile
|
||||||
@@ -837,11 +837,58 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
@@ -837,11 +837,59 @@ dtb-$(CONFIG_ARCH_QCOM) += \
|
||||||
qcom-apq8074-dragonboard.dtb \
|
qcom-apq8074-dragonboard.dtb \
|
||||||
qcom-apq8084-ifc6540.dtb \
|
qcom-apq8084-ifc6540.dtb \
|
||||||
qcom-apq8084-mtp.dtb \
|
qcom-apq8084-mtp.dtb \
|
||||||
@ -31,6 +31,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
|||||||
+ qcom-ipq4018-gl-ap1300.dtb \
|
+ qcom-ipq4018-gl-ap1300.dtb \
|
||||||
+ qcom-ipq4018-jalapeno.dtb \
|
+ qcom-ipq4018-jalapeno.dtb \
|
||||||
+ qcom-ipq4018-meshpoint-one.dtb \
|
+ qcom-ipq4018-meshpoint-one.dtb \
|
||||||
|
+ qcom-ipq4018-hap-ac2.dtb \
|
||||||
+ qcom-ipq4018-nbg6617.dtb \
|
+ qcom-ipq4018-nbg6617.dtb \
|
||||||
+ qcom-ipq4019-oap100.dtb \
|
+ qcom-ipq4019-oap100.dtb \
|
||||||
+ qcom-ipq4018-pa1200.dtb \
|
+ qcom-ipq4018-pa1200.dtb \
|
||||||
|
Loading…
Reference in New Issue
Block a user