mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
trace-cmd: update to 2.9.1
Fixed license information. Adjusted Makefile to new install paths. Backported upstream patch to fix compilation with musl. Replaces local and incomplete patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
This commit is contained in:
parent
7aa8c00e4b
commit
f97b3ad726
@ -1,16 +1,18 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=trace-cmd
|
PKG_NAME:=trace-cmd
|
||||||
PKG_VERSION:=v2.6.1
|
PKG_VERSION:=v2.9.1
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git/snapshot/
|
PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git/snapshot/
|
||||||
PKG_HASH:=4eb79001778a77c0ada10265e7f4b5515a3e21a46f0a15c2e8cc614efdf3f5df
|
PKG_HASH:=9404fc3cf540ea795304608068c9db6cdb38b90584c7f3c43249785913d54b38
|
||||||
|
|
||||||
|
PKG_LICENSE:=GPL-2.0-only
|
||||||
|
PKG_LICENSE_FILES:=COPYING
|
||||||
|
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_USE_MIPS16:=0
|
PKG_USE_MIPS16:=0
|
||||||
PKG_LICENSE:=GPL-2.0
|
|
||||||
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
@ -34,27 +36,27 @@ MAKE_FLAGS += \
|
|||||||
NO_AUDIT=1 \
|
NO_AUDIT=1 \
|
||||||
prefix=/usr
|
prefix=/usr
|
||||||
|
|
||||||
PLUGINS_DIR := $(PKG_INSTALL_DIR)/usr/lib/trace-cmd/plugins
|
PLUGINS_DIR := $(PKG_INSTALL_DIR)/usr/lib/traceevent/plugins
|
||||||
PLUGINS_MAIN := function hrtimer mac80211 sched_switch
|
PLUGINS_MAIN := function hrtimer mac80211 sched_switch
|
||||||
|
|
||||||
TARGET_CFLAGS += --std=gnu99 -D_GNU_SOURCE
|
TARGET_CFLAGS += --std=gnu99 -D_GNU_SOURCE
|
||||||
|
|
||||||
define Package/trace-cmd/install
|
define Package/trace-cmd/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/trace-cmd/plugins
|
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/traceevent/plugins
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/trace-cmd $(1)/usr/bin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/trace-cmd $(1)/usr/bin/
|
||||||
$(CP) \
|
$(CP) \
|
||||||
$(patsubst %,$(PLUGINS_DIR)/plugin_%.so,$(PLUGINS_MAIN)) \
|
$(patsubst %,$(PLUGINS_DIR)/plugin_%.so,$(PLUGINS_MAIN)) \
|
||||||
$(1)/usr/lib/trace-cmd/plugins
|
$(1)/usr/lib/traceevent/plugins
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/trace-cmd-extra/install
|
define Package/trace-cmd-extra/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/trace-cmd/plugins
|
$(INSTALL_DIR) $(1)/usr/lib/traceevent/plugins
|
||||||
$(CP) \
|
$(CP) \
|
||||||
$$(patsubst %,$(PLUGINS_DIR)/plugin_%.so, \
|
$$(patsubst %,$(PLUGINS_DIR)/plugin_%.so, \
|
||||||
$$(filter-out $(PLUGINS_MAIN), \
|
$$(filter-out $(PLUGINS_MAIN), \
|
||||||
$$(patsubst $(PLUGINS_DIR)/plugin_%.so,%, \
|
$$(patsubst $(PLUGINS_DIR)/plugin_%.so,%, \
|
||||||
$$(wildcard $(PLUGINS_DIR)/plugin_*.so)))) \
|
$$(wildcard $(PLUGINS_DIR)/plugin_*.so)))) \
|
||||||
$(1)/usr/lib/trace-cmd/plugins
|
$(1)/usr/lib/traceevent/plugins
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,trace-cmd))
|
$(eval $(call BuildPackage,trace-cmd))
|
||||||
|
104
package/devel/trace-cmd/patches/100-musl.patch
Normal file
104
package/devel/trace-cmd/patches/100-musl.patch
Normal file
@ -0,0 +1,104 @@
|
|||||||
|
From 1a000636c1828eecdcec5360a51623ef4ffbff04 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Beniamin Sandu <beniaminsandu@gmail.com>
|
||||||
|
Date: Mon, 30 Nov 2020 14:27:55 +0200
|
||||||
|
Subject: trace-cmd: make it build against musl C library
|
||||||
|
|
||||||
|
* add some missing headers and macros
|
||||||
|
* set pthread affinity using pthread_setaffinity_np after creating the thread
|
||||||
|
instead of pthread_attr_setaffinity_np (which seems to not be implemented
|
||||||
|
in musl)
|
||||||
|
|
||||||
|
Tested using https://musl.cc/x86_64-linux-musl-native.tgz
|
||||||
|
|
||||||
|
Link: https://lore.kernel.org/linux-trace-devel/20201130122755.31000-1-beniaminsandu@gmail.com
|
||||||
|
|
||||||
|
Reviewed-by: Tzvetomir Stoyanov (VMware) <tz.stoyanov@gmail.com>
|
||||||
|
Signed-off-by: Beniamin Sandu <beniaminsandu@gmail.com>
|
||||||
|
[ Fixed a whitespace issue ]
|
||||||
|
Signed-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
|
||||||
|
---
|
||||||
|
include/trace-cmd/trace-cmd.h | 1 +
|
||||||
|
lib/trace-cmd/include/trace-cmd-local.h | 1 +
|
||||||
|
lib/tracefs/tracefs-events.c | 1 +
|
||||||
|
tracecmd/include/trace-local.h | 1 +
|
||||||
|
tracecmd/trace-tsync.c | 16 +++++++++++-----
|
||||||
|
5 files changed, 20 insertions(+), 5 deletions(-)
|
||||||
|
|
||||||
|
--- a/include/trace-cmd/trace-cmd.h
|
||||||
|
+++ b/include/trace-cmd/trace-cmd.h
|
||||||
|
@@ -6,6 +6,7 @@
|
||||||
|
#ifndef _TRACE_CMD_H
|
||||||
|
#define _TRACE_CMD_H
|
||||||
|
|
||||||
|
+#include <pthread.h>
|
||||||
|
#include "traceevent/event-parse.h"
|
||||||
|
|
||||||
|
#define TRACECMD_MAGIC { 23, 8, 68 }
|
||||||
|
--- a/lib/trace-cmd/include/trace-cmd-local.h
|
||||||
|
+++ b/lib/trace-cmd/include/trace-cmd-local.h
|
||||||
|
@@ -26,5 +26,6 @@ void warning(const char *fmt, ...);
|
||||||
|
#endif
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#include <byteswap.h>
|
||||||
|
|
||||||
|
#endif /* _TRACE_CMD_LOCAL_H */
|
||||||
|
--- a/lib/tracefs/tracefs-events.c
|
||||||
|
+++ b/lib/tracefs/tracefs-events.c
|
||||||
|
@@ -13,6 +13,7 @@
|
||||||
|
#include <errno.h>
|
||||||
|
#include <sys/stat.h>
|
||||||
|
#include <fcntl.h>
|
||||||
|
+#include <limits.h>
|
||||||
|
|
||||||
|
#include "kbuffer.h"
|
||||||
|
#include "tracefs.h"
|
||||||
|
--- a/tracecmd/include/trace-local.h
|
||||||
|
+++ b/tracecmd/include/trace-local.h
|
||||||
|
@@ -8,6 +8,7 @@
|
||||||
|
|
||||||
|
#include <sys/types.h>
|
||||||
|
#include <dirent.h> /* for DIR */
|
||||||
|
+#include <limits.h>
|
||||||
|
|
||||||
|
#include "trace-cmd.h"
|
||||||
|
#include "event-utils.h"
|
||||||
|
--- a/tracecmd/trace-tsync.c
|
||||||
|
+++ b/tracecmd/trace-tsync.c
|
||||||
|
@@ -104,13 +104,16 @@ int tracecmd_host_tsync(struct buffer_in
|
||||||
|
|
||||||
|
pthread_attr_init(&attrib);
|
||||||
|
pthread_attr_setdetachstate(&attrib, PTHREAD_CREATE_JOINABLE);
|
||||||
|
- if (!get_first_cpu(&pin_mask, &mask_size))
|
||||||
|
- pthread_attr_setaffinity_np(&attrib, mask_size, pin_mask);
|
||||||
|
|
||||||
|
ret = pthread_create(&instance->tsync_thread, &attrib,
|
||||||
|
tsync_host_thread, &instance->tsync);
|
||||||
|
- if (!ret)
|
||||||
|
+
|
||||||
|
+ if (!ret) {
|
||||||
|
+ if (!get_first_cpu(&pin_mask, &mask_size))
|
||||||
|
+ pthread_setaffinity_np(instance->tsync_thread, mask_size, pin_mask);
|
||||||
|
instance->tsync_thread_running = true;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
if (pin_mask)
|
||||||
|
CPU_FREE(pin_mask);
|
||||||
|
pthread_attr_destroy(&attrib);
|
||||||
|
@@ -243,11 +246,14 @@ unsigned int tracecmd_guest_tsync(char *
|
||||||
|
pthread_attr_init(&attrib);
|
||||||
|
tsync->sync_proto = proto;
|
||||||
|
pthread_attr_setdetachstate(&attrib, PTHREAD_CREATE_JOINABLE);
|
||||||
|
- if (!get_first_cpu(&pin_mask, &mask_size))
|
||||||
|
- pthread_attr_setaffinity_np(&attrib, mask_size, pin_mask);
|
||||||
|
|
||||||
|
ret = pthread_create(thr_id, &attrib, tsync_agent_thread, tsync);
|
||||||
|
|
||||||
|
+ if (!ret) {
|
||||||
|
+ if (!get_first_cpu(&pin_mask, &mask_size))
|
||||||
|
+ pthread_setaffinity_np(*thr_id, mask_size, pin_mask);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
if (pin_mask)
|
||||||
|
CPU_FREE(pin_mask);
|
||||||
|
pthread_attr_destroy(&attrib);
|
@ -1,16 +1,16 @@
|
|||||||
--- a/plugin_mac80211.c
|
--- a/lib/traceevent/plugins/plugin_mac80211.c
|
||||||
+++ b/plugin_mac80211.c
|
+++ b/lib/traceevent/plugins/plugin_mac80211.c
|
||||||
@@ -179,12 +179,15 @@ static int drv_config(struct trace_seq *
|
@@ -165,12 +165,15 @@ static int drv_config(struct trace_seq *
|
||||||
{ 2, "IDLE" },
|
{ 2, "IDLE" },
|
||||||
{ 3, "QOS"},
|
{ 3, "QOS"},
|
||||||
);
|
);
|
||||||
- pevent_print_num_field(s, " chan:%d/", event, "center_freq", record, 1);
|
- tep_print_num_field(s, " chan:%d/", event, "center_freq", record, 1);
|
||||||
- print_enum(s, event, "channel_type", data,
|
- print_enum(s, event, "channel_type", data,
|
||||||
- { 0, "noht" },
|
- { 0, "noht" },
|
||||||
- { 1, "ht20" },
|
- { 1, "ht20" },
|
||||||
- { 2, "ht40-" },
|
- { 2, "ht40-" },
|
||||||
- { 3, "ht40+" });
|
- { 3, "ht40+" });
|
||||||
+ pevent_print_num_field(s, " chan:%d@", event, "control_freq", record, 1);
|
+ tep_print_num_field(s, " chan:%d@", event, "control_freq", record, 1);
|
||||||
+ print_enum(s, event, "chan_width", data,
|
+ print_enum(s, event, "chan_width", data,
|
||||||
+ { 0, "20_noht" },
|
+ { 0, "20_noht" },
|
||||||
+ { 1, "20" },
|
+ { 1, "20" },
|
||||||
|
@ -1,24 +0,0 @@
|
|||||||
From 293ff6d5bc9d3b8bfbc3c57d20d3d2d00986c168 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Alexander Couzens <lynxis@fe80.eu>
|
|
||||||
Date: Sun, 26 Nov 2017 05:22:51 +0100
|
|
||||||
Subject: [PATCH] trace-cmd listen: Include limits.h to define PATH_MAX
|
|
||||||
|
|
||||||
PATH_MAX is defined by limits.h. On some system it's also
|
|
||||||
defined by dirent.h but not on musl.
|
|
||||||
|
|
||||||
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
|
|
||||||
Signed-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
|
|
||||||
---
|
|
||||||
trace-listen.c | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
--- a/trace-listen.c
|
|
||||||
+++ b/trace-listen.c
|
|
||||||
@@ -23,6 +23,7 @@
|
|
||||||
#include <stdlib.h>
|
|
||||||
#include <string.h>
|
|
||||||
#include <getopt.h>
|
|
||||||
+#include <limits.h>
|
|
||||||
#include <sys/types.h>
|
|
||||||
#include <sys/socket.h>
|
|
||||||
#include <sys/wait.h>
|
|
Loading…
Reference in New Issue
Block a user