mirror of
https://github.com/openwrt/openwrt.git
synced 2025-04-09 04:15:47 +00:00
toolchain: bump GCC 11 to 11.3.0
Remove an upstreamed patch and rebase all remaining patches. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
This commit is contained in:
parent
7f998088f0
commit
f4cdef2191
@ -10,4 +10,4 @@ config GCC_VERSION
|
||||
string
|
||||
default "8.4.0" if GCC_VERSION_8
|
||||
default "10.3.0" if GCC_VERSION_10
|
||||
default "11.2.0"
|
||||
default "11.3.0"
|
||||
|
@ -36,8 +36,8 @@ ifeq ($(PKG_VERSION),10.3.0)
|
||||
PKG_HASH:=64f404c1a650f27fc33da242e1f2df54952e3963a49e06e73f6940f3223ac344
|
||||
endif
|
||||
|
||||
ifeq ($(PKG_VERSION),11.2.0)
|
||||
PKG_HASH:=d08edc536b54c372a1010ff6619dd274c0f1603aa49212ba20f7aa2cda36fa8b
|
||||
ifeq ($(PKG_VERSION),11.3.0)
|
||||
PKG_HASH:=b47cf2818691f5b1e21df2bb38c795fac2cfbd640ede2d0a5e1c89e338a3ac39
|
||||
endif
|
||||
|
||||
PATCH_DIR=../patches/$(GCC_VERSION)
|
||||
|
@ -1,114 +0,0 @@
|
||||
From a6219e8e0719b14f474b0dcaa7bde2f4e57474f9 Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Jelinek <jakub@redhat.com>
|
||||
Date: Wed, 17 Nov 2021 13:45:53 +0100
|
||||
Subject: [PATCH] ranger: Fix up fold_using_range::range_of_address [PR103255]
|
||||
|
||||
If on &base->member the offset isn't constant or isn't zero and
|
||||
-fdelete-null-pointer-checks and not -fwrapv-pointer and base has a range
|
||||
that doesn't include NULL, we return the range of the base.
|
||||
Usually it isn't a big deal, because for most pointers we just use
|
||||
varying, range_zero and range_nonzero ranges and nothing beyond that,
|
||||
but if a pointer is initialized from a constant, we actually track the
|
||||
exact range and in that case this causes miscompilation.
|
||||
As discussed on IRC, I think doing something like:
|
||||
offset_int off2;
|
||||
if (off_cst && off.is_constant (&off2))
|
||||
{
|
||||
tree cst = wide_int_to_tree (sizetype, off2 / BITS_PER_UNIT);
|
||||
// adjust range r with POINTER_PLUS_EXPR cst
|
||||
if (!range_includes_zero_p (&r))
|
||||
return true;
|
||||
}
|
||||
// Fallback
|
||||
r = range_nonzero (TREE_TYPE (gimple_assign_rhs1 (stmt)));
|
||||
return true;
|
||||
could work, given that most of the pointer ranges are just the simple ones
|
||||
perhaps it is too much for little benefit.
|
||||
|
||||
2021-11-17 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
PR tree-optimization/103255
|
||||
* gimple-range.cc (fold_using_range::range_of_address): Return
|
||||
range_nonzero rather than unadjusted base's range. Formatting fixes.
|
||||
|
||||
* gcc.c-torture/execute/pr103255.c: New test.
|
||||
|
||||
(cherry picked from commit c39cb6bf835ca12e590eaa6f90222e51be207c50)
|
||||
---
|
||||
gcc/gimple-range.cc | 16 +++++---
|
||||
.../gcc.c-torture/execute/pr103255.c | 41 +++++++++++++++++++
|
||||
2 files changed, 52 insertions(+), 5 deletions(-)
|
||||
create mode 100644 gcc/testsuite/gcc.c-torture/execute/pr103255.c
|
||||
|
||||
--- a/gcc/gimple-range.cc
|
||||
+++ b/gcc/gimple-range.cc
|
||||
@@ -491,14 +491,20 @@ gimple_ranger::range_of_address (irange
|
||||
}
|
||||
/* If &X->a is equal to X, the range of X is the result. */
|
||||
if (off_cst && known_eq (off, 0))
|
||||
- return true;
|
||||
+ return true;
|
||||
else if (flag_delete_null_pointer_checks
|
||||
&& !TYPE_OVERFLOW_WRAPS (TREE_TYPE (expr)))
|
||||
{
|
||||
- /* For -fdelete-null-pointer-checks -fno-wrapv-pointer we don't
|
||||
- allow going from non-NULL pointer to NULL. */
|
||||
- if(!range_includes_zero_p (&r))
|
||||
- return true;
|
||||
+ /* For -fdelete-null-pointer-checks -fno-wrapv-pointer we don't
|
||||
+ allow going from non-NULL pointer to NULL. */
|
||||
+ if (!range_includes_zero_p (&r))
|
||||
+ {
|
||||
+ /* We could here instead adjust r by off >> LOG2_BITS_PER_UNIT
|
||||
+ using POINTER_PLUS_EXPR if off_cst and just fall back to
|
||||
+ this. */
|
||||
+ r = range_nonzero (TREE_TYPE (gimple_assign_rhs1 (stmt)));
|
||||
+ return true;
|
||||
+ }
|
||||
}
|
||||
/* If MEM_REF has a "positive" offset, consider it non-NULL
|
||||
always, for -fdelete-null-pointer-checks also "negative"
|
||||
--- /dev/null
|
||||
+++ b/gcc/testsuite/gcc.c-torture/execute/pr103255.c
|
||||
@@ -0,0 +1,41 @@
|
||||
+/* PR tree-optimization/103255 */
|
||||
+
|
||||
+struct H
|
||||
+{
|
||||
+ unsigned a;
|
||||
+ unsigned b;
|
||||
+ unsigned c;
|
||||
+};
|
||||
+
|
||||
+#if __SIZEOF_POINTER__ >= 4
|
||||
+#define ADDR 0x400000
|
||||
+#else
|
||||
+#define ADDR 0x4000
|
||||
+#endif
|
||||
+#define OFF 0x20
|
||||
+
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+ struct H *h = 0;
|
||||
+ unsigned long o;
|
||||
+ volatile int t = 1;
|
||||
+
|
||||
+ for (o = OFF; o <= OFF; o += 0x1000)
|
||||
+ {
|
||||
+ struct H *u;
|
||||
+ u = (struct H *) (ADDR + o);
|
||||
+ if (t)
|
||||
+ {
|
||||
+ h = u;
|
||||
+ break;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ if (h == 0)
|
||||
+ return 0;
|
||||
+ unsigned *tt = &h->b;
|
||||
+ if ((__SIZE_TYPE__) tt != (ADDR + OFF + __builtin_offsetof (struct H, b)))
|
||||
+ __builtin_abort ();
|
||||
+ return 0;
|
||||
+}
|
@ -12,7 +12,7 @@ Date: Tue Feb 26 16:16:33 2013 +0000
|
||||
|
||||
--- a/gcc/Makefile.in
|
||||
+++ b/gcc/Makefile.in
|
||||
@@ -3355,18 +3355,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
|
||||
@@ -3348,18 +3348,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
|
||||
doc/gccint.info: $(TEXI_GCCINT_FILES)
|
||||
doc/cppinternals.info: $(TEXI_CPPINT_FILES)
|
||||
|
@ -22,7 +22,7 @@ Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
|
||||
|
||||
--- a/gcc/configure
|
||||
+++ b/gcc/configure
|
||||
@@ -30954,6 +30954,9 @@ fi
|
||||
@@ -31533,6 +31533,9 @@ fi
|
||||
# Check if the target LIBC handles PT_GNU_STACK.
|
||||
gcc_cv_libc_gnustack=unknown
|
||||
case "$target" in
|
||||
@ -34,7 +34,7 @@ Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
|
||||
if test $glibc_version_major -gt 2 \
|
||||
--- a/gcc/configure.ac
|
||||
+++ b/gcc/configure.ac
|
||||
@@ -6788,6 +6788,9 @@ fi
|
||||
@@ -7023,6 +7023,9 @@ fi
|
||||
# Check if the target LIBC handles PT_GNU_STACK.
|
||||
gcc_cv_libc_gnustack=unknown
|
||||
case "$target" in
|
@ -40,7 +40,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
|
||||
case OPT_fconstant_string_class_:
|
||||
constant_string_class_name = arg;
|
||||
break;
|
||||
@@ -1196,6 +1205,47 @@ c_common_init (void)
|
||||
@@ -1198,6 +1207,47 @@ c_common_init (void)
|
||||
return false;
|
||||
}
|
||||
|
||||
@ -114,7 +114,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
|
||||
; On SVR4 targets, it also controls whether or not to emit a
|
||||
--- a/gcc/doc/invoke.texi
|
||||
+++ b/gcc/doc/invoke.texi
|
||||
@@ -9055,6 +9055,17 @@ This option is only supported for C and
|
||||
@@ -9058,6 +9058,17 @@ This option is only supported for C and
|
||||
@option{-Wall} and by @option{-Wpedantic}, which can be disabled with
|
||||
@option{-Wno-pointer-sign}.
|
||||
|
@ -7,7 +7,7 @@ Date: Sat Apr 21 03:02:39 2012 +0000
|
||||
|
||||
--- a/gcc/gcc.c
|
||||
+++ b/gcc/gcc.c
|
||||
@@ -10100,8 +10100,10 @@ getenv_spec_function (int argc, const ch
|
||||
@@ -10106,8 +10106,10 @@ getenv_spec_function (int argc, const ch
|
||||
}
|
||||
|
||||
if (!value)
|
Loading…
x
Reference in New Issue
Block a user