mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
kernel: bump 5.10 to 5.10.35
Refresh kernel patches. Built under MacOS Run tested: x86_64 (apu2) Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
This commit is contained in:
parent
976e65933b
commit
f35dbef6d2
@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
|
||||
endif
|
||||
|
||||
LINUX_VERSION-5.4 = .117
|
||||
LINUX_VERSION-5.10 = .34
|
||||
LINUX_VERSION-5.10 = .35
|
||||
|
||||
LINUX_KERNEL_HASH-5.4.117 = 4e989b5775830092e5c76b5cca65ebff862ad0c87d0b58c3a20d415c3d4ec770
|
||||
LINUX_KERNEL_HASH-5.10.34 = 6eeeb7e005bd1d4eb8b10382a35f8cd54ee6692c244ab1362590fa539f3d6582
|
||||
LINUX_KERNEL_HASH-5.10.35 = ac37a19d45b77a87e58e3aae8b127a6e7eb85ed7467fc8e58474b387bfd498fd
|
||||
|
||||
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
||||
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
|
||||
|
@ -22,7 +22,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
|
||||
|
||||
--- a/arch/arm/Kconfig
|
||||
+++ b/arch/arm/Kconfig
|
||||
@@ -1827,6 +1827,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
|
||||
@@ -1780,6 +1780,17 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEN
|
||||
The command-line arguments provided by the boot loader will be
|
||||
appended to the the device tree bootargs property.
|
||||
|
||||
@ -42,7 +42,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
|
||||
config CMDLINE
|
||||
--- a/arch/arm/boot/compressed/atags_to_fdt.c
|
||||
+++ b/arch/arm/boot/compressed/atags_to_fdt.c
|
||||
@@ -4,6 +4,8 @@
|
||||
@@ -5,6 +5,8 @@
|
||||
|
||||
#if defined(CONFIG_ARM_ATAG_DTB_COMPAT_CMDLINE_EXTEND)
|
||||
#define do_extend_cmdline 1
|
||||
@ -51,7 +51,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
|
||||
#else
|
||||
#define do_extend_cmdline 0
|
||||
#endif
|
||||
@@ -67,6 +69,80 @@ static uint32_t get_cell_size(const void
|
||||
@@ -69,6 +71,80 @@ static uint32_t get_cell_size(const void
|
||||
return cell_size;
|
||||
}
|
||||
|
||||
@ -132,7 +132,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
|
||||
static void merge_fdt_bootargs(void *fdt, const char *fdt_cmdline)
|
||||
{
|
||||
char cmdline[COMMAND_LINE_SIZE];
|
||||
@@ -86,12 +162,21 @@ static void merge_fdt_bootargs(void *fdt
|
||||
@@ -88,12 +164,21 @@ static void merge_fdt_bootargs(void *fdt
|
||||
|
||||
/* and append the ATAG_CMDLINE */
|
||||
if (fdt_cmdline) {
|
||||
@ -154,7 +154,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
|
||||
}
|
||||
*ptr = '\0';
|
||||
|
||||
@@ -166,7 +251,9 @@ int atags_to_fdt(void *atag_list, void *
|
||||
@@ -168,7 +253,9 @@ int atags_to_fdt(void *atag_list, void *
|
||||
else
|
||||
setprop_string(fdt, "/chosen", "bootargs",
|
||||
atag->u.cmdline.cmdline);
|
||||
@ -165,7 +165,7 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
|
||||
if (memcount >= sizeof(mem_reg_property)/4)
|
||||
continue;
|
||||
if (!atag->u.mem.size)
|
||||
@@ -210,6 +297,10 @@ int atags_to_fdt(void *atag_list, void *
|
||||
@@ -212,6 +299,10 @@ int atags_to_fdt(void *atag_list, void *
|
||||
setprop(fdt, "/memory", "reg", mem_reg_property,
|
||||
4 * memcount * memsize);
|
||||
}
|
||||
@ -178,9 +178,9 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
|
||||
}
|
||||
--- a/init/main.c
|
||||
+++ b/init/main.c
|
||||
@@ -104,6 +104,10 @@
|
||||
#define CREATE_TRACE_POINTS
|
||||
#include <trace/events/initcall.h>
|
||||
@@ -110,6 +110,10 @@
|
||||
|
||||
#include <kunit/test.h>
|
||||
|
||||
+#if defined(CONFIG_ARM_ATAG_DTB_COMPAT_CMDLINE_MANGLE)
|
||||
+#include <linux/of.h>
|
||||
@ -189,8 +189,8 @@ Signed-off-by: Adrian Panella <ianchi74@outlook.com>
|
||||
static int kernel_init(void *);
|
||||
|
||||
extern void init_IRQ(void);
|
||||
@@ -633,6 +637,18 @@ asmlinkage __visible void __init start_k
|
||||
pr_notice("Kernel command line: %s\n", boot_command_line);
|
||||
@@ -905,6 +909,18 @@ asmlinkage __visible void __init __no_sa
|
||||
pr_notice("Kernel command line: %s\n", saved_command_line);
|
||||
/* parameters may set static keys */
|
||||
jump_label_init();
|
||||
+
|
||||
|
@ -674,7 +674,7 @@
|
||||
pcie0: pci@1b500000 {
|
||||
compatible = "qcom,pcie-ipq8064";
|
||||
reg = <0x1b500000 0x1000
|
||||
@@ -751,6 +1344,59 @@
|
||||
@@ -739,6 +1332,59 @@
|
||||
status = "disabled";
|
||||
};
|
||||
|
||||
@ -734,7 +734,7 @@
|
||||
vsdcc_fixed: vsdcc-regulator {
|
||||
compatible = "regulator-fixed";
|
||||
regulator-name = "SDCC Power";
|
||||
@@ -826,4 +1472,17 @@
|
||||
@@ -814,4 +1460,17 @@
|
||||
};
|
||||
};
|
||||
};
|
||||
|
@ -19,7 +19,7 @@ Link: https://lore.kernel.org/linux-mtd/20210104041137.113075-3-manivannan.sadha
|
||||
|
||||
--- a/drivers/mtd/parsers/Kconfig
|
||||
+++ b/drivers/mtd/parsers/Kconfig
|
||||
@@ -186,6 +186,14 @@ config MTD_REDBOOT_PARTS_READONLY
|
||||
@@ -196,6 +196,14 @@ config MTD_REDBOOT_PARTS_READONLY
|
||||
|
||||
endif # MTD_REDBOOT_PARTS
|
||||
|
||||
@ -36,7 +36,7 @@ Link: https://lore.kernel.org/linux-mtd/20210104041137.113075-3-manivannan.sadha
|
||||
depends on MTD && OF
|
||||
--- a/drivers/mtd/parsers/Makefile
|
||||
+++ b/drivers/mtd/parsers/Makefile
|
||||
@@ -12,4 +12,5 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
||||
@@ -13,4 +13,5 @@ obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
||||
obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
|
||||
obj-$(CONFIG_MTD_SHARPSL_PARTS) += sharpslpart.o
|
||||
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
||||
|
@ -16,8 +16,6 @@ Reported-by: Dan Carpenter <dan.carpenter@oracle.com>
|
||||
drivers/thermal/qcom/tsens.h | 4 +-
|
||||
2 files changed, 124 insertions(+), 30 deletions(-)
|
||||
|
||||
diff --git a/drivers/thermal/qcom/tsens.c b/drivers/thermal/qcom/tsens.c
|
||||
index d8ce3a687b80..9a7e991d4bd2 100644
|
||||
--- a/drivers/thermal/qcom/tsens.c
|
||||
+++ b/drivers/thermal/qcom/tsens.c
|
||||
@@ -12,6 +12,7 @@
|
||||
@ -28,7 +26,7 @@ index d8ce3a687b80..9a7e991d4bd2 100644
|
||||
#include <linux/platform_device.h>
|
||||
#include <linux/pm.h>
|
||||
#include <linux/regmap.h>
|
||||
@@ -515,6 +516,15 @@ static irqreturn_t tsens_irq_thread(int irq, void *data)
|
||||
@@ -515,6 +516,15 @@ static irqreturn_t tsens_irq_thread(int
|
||||
dev_dbg(priv->dev, "[%u] %s: no violation: %d\n",
|
||||
hw_id, __func__, temp);
|
||||
}
|
||||
@ -44,7 +42,7 @@ index d8ce3a687b80..9a7e991d4bd2 100644
|
||||
}
|
||||
|
||||
return IRQ_HANDLED;
|
||||
@@ -530,6 +540,13 @@ static int tsens_set_trips(void *_sensor, int low, int high)
|
||||
@@ -530,6 +540,13 @@ static int tsens_set_trips(void *_sensor
|
||||
int high_val, low_val, cl_high, cl_low;
|
||||
u32 hw_id = s->hw_id;
|
||||
|
||||
@ -58,7 +56,7 @@ index d8ce3a687b80..9a7e991d4bd2 100644
|
||||
dev_dbg(dev, "[%u] %s: proposed thresholds: (%d:%d)\n",
|
||||
hw_id, __func__, low, high);
|
||||
|
||||
@@ -584,18 +601,21 @@ int get_temp_tsens_valid(const struct tsens_sensor *s, int *temp)
|
||||
@@ -584,18 +601,21 @@ int get_temp_tsens_valid(const struct ts
|
||||
u32 valid;
|
||||
int ret;
|
||||
|
||||
@ -89,7 +87,7 @@ index d8ce3a687b80..9a7e991d4bd2 100644
|
||||
}
|
||||
|
||||
/* Valid bit is set, OK to read the temperature */
|
||||
@@ -608,15 +628,29 @@ int get_temp_common(const struct tsens_sensor *s, int *temp)
|
||||
@@ -608,15 +628,29 @@ int get_temp_common(const struct tsens_s
|
||||
{
|
||||
struct tsens_priv *priv = s->priv;
|
||||
int hw_id = s->hw_id;
|
||||
@ -125,7 +123,7 @@ index d8ce3a687b80..9a7e991d4bd2 100644
|
||||
}
|
||||
|
||||
#ifdef CONFIG_DEBUG_FS
|
||||
@@ -738,19 +772,34 @@ int __init init_common(struct tsens_priv *priv)
|
||||
@@ -738,19 +772,34 @@ int __init init_common(struct tsens_priv
|
||||
priv->tm_offset = 0x1000;
|
||||
}
|
||||
|
||||
@ -168,7 +166,7 @@ index d8ce3a687b80..9a7e991d4bd2 100644
|
||||
if (tsens_version(priv) > VER_0_1) {
|
||||
for (i = VER_MAJOR; i <= VER_STEP; i++) {
|
||||
priv->rf[i] = devm_regmap_field_alloc(dev, priv->srot_map,
|
||||
@@ -769,6 +818,10 @@ int __init init_common(struct tsens_priv *priv)
|
||||
@@ -769,6 +818,10 @@ int __init init_common(struct tsens_priv
|
||||
ret = PTR_ERR(priv->rf[TSENS_EN]);
|
||||
goto err_put_device;
|
||||
}
|
||||
@ -179,7 +177,7 @@ index d8ce3a687b80..9a7e991d4bd2 100644
|
||||
ret = regmap_field_read(priv->rf[TSENS_EN], &enabled);
|
||||
if (ret)
|
||||
goto err_put_device;
|
||||
@@ -791,6 +844,19 @@ int __init init_common(struct tsens_priv *priv)
|
||||
@@ -791,6 +844,19 @@ int __init init_common(struct tsens_priv
|
||||
goto err_put_device;
|
||||
}
|
||||
|
||||
@ -199,7 +197,7 @@ index d8ce3a687b80..9a7e991d4bd2 100644
|
||||
/* This loop might need changes if enum regfield_ids is reordered */
|
||||
for (j = LAST_TEMP_0; j <= UP_THRESH_15; j += 16) {
|
||||
for (i = 0; i < priv->feat->max_sensors; i++) {
|
||||
@@ -806,7 +872,7 @@ int __init init_common(struct tsens_priv *priv)
|
||||
@@ -806,7 +872,7 @@ int __init init_common(struct tsens_priv
|
||||
}
|
||||
}
|
||||
|
||||
@ -208,7 +206,7 @@ index d8ce3a687b80..9a7e991d4bd2 100644
|
||||
/* Loop might need changes if enum regfield_ids is reordered */
|
||||
for (j = CRITICAL_STATUS_0; j <= CRIT_THRESH_15; j += 16) {
|
||||
for (i = 0; i < priv->feat->max_sensors; i++) {
|
||||
@@ -844,7 +910,11 @@ int __init init_common(struct tsens_priv *priv)
|
||||
@@ -844,7 +910,11 @@ int __init init_common(struct tsens_priv
|
||||
}
|
||||
|
||||
spin_lock_init(&priv->ul_lock);
|
||||
@ -221,7 +219,7 @@ index d8ce3a687b80..9a7e991d4bd2 100644
|
||||
tsens_debug_init(op);
|
||||
|
||||
err_put_device:
|
||||
@@ -943,10 +1013,19 @@ static int tsens_register_irq(struct tsens_priv *priv, char *irqname,
|
||||
@@ -943,10 +1013,19 @@ static int tsens_register_irq(struct tse
|
||||
if (irq == -ENXIO)
|
||||
ret = 0;
|
||||
} else {
|
||||
@ -245,7 +243,7 @@ index d8ce3a687b80..9a7e991d4bd2 100644
|
||||
if (ret)
|
||||
dev_err(&pdev->dev, "%s: failed to get irq\n",
|
||||
__func__);
|
||||
@@ -975,6 +1054,19 @@ static int tsens_register(struct tsens_priv *priv)
|
||||
@@ -975,6 +1054,19 @@ static int tsens_register(struct tsens_p
|
||||
priv->ops->enable(priv, i);
|
||||
}
|
||||
|
||||
@ -265,8 +263,6 @@ index d8ce3a687b80..9a7e991d4bd2 100644
|
||||
ret = tsens_register_irq(priv, "uplow", tsens_irq_thread);
|
||||
if (ret < 0)
|
||||
return ret;
|
||||
diff --git a/drivers/thermal/qcom/tsens.h b/drivers/thermal/qcom/tsens.h
|
||||
index f40b625f897e..8e6c1fd3ccf5 100644
|
||||
--- a/drivers/thermal/qcom/tsens.h
|
||||
+++ b/drivers/thermal/qcom/tsens.h
|
||||
@@ -13,6 +13,7 @@
|
||||
@ -287,6 +283,3 @@ index f40b625f897e..8e6c1fd3ccf5 100644
|
||||
VER_1_X,
|
||||
VER_2_X,
|
||||
};
|
||||
--
|
||||
2.30.2
|
||||
|
||||
|
@ -14,11 +14,9 @@ Reviewed-by: Thara Gopinath <thara.gopinath@linaro.org>
|
||||
drivers/thermal/qcom/tsens.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/thermal/qcom/tsens.c b/drivers/thermal/qcom/tsens.c
|
||||
index 9a7e991d4bd2..38b9936def1a 100644
|
||||
--- a/drivers/thermal/qcom/tsens.c
|
||||
+++ b/drivers/thermal/qcom/tsens.c
|
||||
@@ -86,7 +86,8 @@ void compute_intercept_slope(struct tsens_priv *priv, u32 *p1,
|
||||
@@ -86,7 +86,8 @@ void compute_intercept_slope(struct tsen
|
||||
"%s: sensor%d - data_point1:%#x data_point2:%#x\n",
|
||||
__func__, i, p1[i], p2[i]);
|
||||
|
||||
@ -28,6 +26,3 @@ index 9a7e991d4bd2..38b9936def1a 100644
|
||||
if (mode == TWO_PT_CALIB) {
|
||||
/*
|
||||
* slope (m) = adc_code2 - adc_code1 (y2 - y1)/
|
||||
--
|
||||
2.30.2
|
||||
|
||||
|
@ -12,8 +12,6 @@ Acked-by: Thara Gopinath <thara.gopinath@linaro.org>
|
||||
drivers/thermal/qcom/tsens-8960.c | 80 ++++++++++++++++++++++++++++++-
|
||||
1 file changed, 79 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/drivers/thermal/qcom/tsens-8960.c b/drivers/thermal/qcom/tsens-8960.c
|
||||
index 2a28a5af209e..3f4fc1ffe679 100644
|
||||
--- a/drivers/thermal/qcom/tsens-8960.c
|
||||
+++ b/drivers/thermal/qcom/tsens-8960.c
|
||||
@@ -51,11 +51,22 @@
|
||||
@ -40,7 +38,7 @@ index 2a28a5af209e..3f4fc1ffe679 100644
|
||||
static int suspend_8960(struct tsens_priv *priv)
|
||||
{
|
||||
int ret;
|
||||
@@ -269,6 +280,71 @@ static int get_temp_8960(const struct tsens_sensor *s, int *temp)
|
||||
@@ -269,6 +280,71 @@ static int get_temp_8960(const struct ts
|
||||
return -ETIMEDOUT;
|
||||
}
|
||||
|
||||
@ -112,13 +110,10 @@ index 2a28a5af209e..3f4fc1ffe679 100644
|
||||
static const struct tsens_ops ops_8960 = {
|
||||
.init = init_8960,
|
||||
.calibrate = calibrate_8960,
|
||||
@@ -282,4 +358,6 @@ static const struct tsens_ops ops_8960 = {
|
||||
@@ -282,4 +358,6 @@ static const struct tsens_ops ops_8960 =
|
||||
struct tsens_plat_data data_8960 = {
|
||||
.num_sensors = 11,
|
||||
.ops = &ops_8960,
|
||||
+ .feat = &tsens_8960_feat,
|
||||
+ .fields = tsens_8960_regfields,
|
||||
};
|
||||
--
|
||||
2.30.2
|
||||
|
||||
|
@ -11,11 +11,9 @@ Reviewed-by: Thara Gopinath <thara.gopinath@linaro.org>
|
||||
drivers/thermal/qcom/tsens-8960.c | 52 +------------------------------
|
||||
1 file changed, 1 insertion(+), 51 deletions(-)
|
||||
|
||||
diff --git a/drivers/thermal/qcom/tsens-8960.c b/drivers/thermal/qcom/tsens-8960.c
|
||||
index 3f4fc1ffe679..86585f439985 100644
|
||||
--- a/drivers/thermal/qcom/tsens-8960.c
|
||||
+++ b/drivers/thermal/qcom/tsens-8960.c
|
||||
@@ -173,56 +173,6 @@ static void disable_8960(struct tsens_priv *priv)
|
||||
@@ -173,56 +173,6 @@ static void disable_8960(struct tsens_pr
|
||||
regmap_write(priv->tm_map, CNTL_ADDR, reg_cntl);
|
||||
}
|
||||
|
||||
@ -72,7 +70,7 @@ index 3f4fc1ffe679..86585f439985 100644
|
||||
static int calibrate_8960(struct tsens_priv *priv)
|
||||
{
|
||||
int i;
|
||||
@@ -346,7 +296,7 @@ static const struct reg_field tsens_8960_regfields[MAX_REGFIELDS] = {
|
||||
@@ -346,7 +296,7 @@ static const struct reg_field tsens_8960
|
||||
};
|
||||
|
||||
static const struct tsens_ops ops_8960 = {
|
||||
@ -81,6 +79,3 @@ index 3f4fc1ffe679..86585f439985 100644
|
||||
.calibrate = calibrate_8960,
|
||||
.get_temp = get_temp_8960,
|
||||
.enable = enable_8960,
|
||||
--
|
||||
2.30.2
|
||||
|
||||
|
@ -14,8 +14,6 @@ Acked-by: Thara Gopinath <thara.gopinath@linaro.org>
|
||||
drivers/thermal/qcom/tsens-8960.c | 23 ++++++++++++++++++++---
|
||||
1 file changed, 20 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/drivers/thermal/qcom/tsens-8960.c b/drivers/thermal/qcom/tsens-8960.c
|
||||
index 86585f439985..95fcccafae14 100644
|
||||
--- a/drivers/thermal/qcom/tsens-8960.c
|
||||
+++ b/drivers/thermal/qcom/tsens-8960.c
|
||||
@@ -27,9 +27,9 @@
|
||||
@ -29,7 +27,7 @@ index 86585f439985..95fcccafae14 100644
|
||||
#define SENSOR0_SHIFT 3
|
||||
|
||||
/* INT_STATUS_ADDR bitmasks */
|
||||
@@ -126,17 +126,34 @@ static int resume_8960(struct tsens_priv *priv)
|
||||
@@ -126,17 +126,34 @@ static int resume_8960(struct tsens_priv
|
||||
static int enable_8960(struct tsens_priv *priv, int id)
|
||||
{
|
||||
int ret;
|
||||
@ -66,6 +64,3 @@ index 86585f439985..95fcccafae14 100644
|
||||
if (priv->num_sensors > 1)
|
||||
reg |= mask | SLP_CLK_ENA | EN;
|
||||
else
|
||||
--
|
||||
2.30.2
|
||||
|
||||
|
@ -15,8 +15,6 @@ Acked-by: Thara Gopinath <thara.gopinath@linaro.org>
|
||||
drivers/thermal/qcom/tsens-8960.c | 56 +++++++++----------------------
|
||||
1 file changed, 15 insertions(+), 41 deletions(-)
|
||||
|
||||
diff --git a/drivers/thermal/qcom/tsens-8960.c b/drivers/thermal/qcom/tsens-8960.c
|
||||
index 95fcccafae14..9cc8a7dd23ae 100644
|
||||
--- a/drivers/thermal/qcom/tsens-8960.c
|
||||
+++ b/drivers/thermal/qcom/tsens-8960.c
|
||||
@@ -67,6 +67,13 @@
|
||||
@ -33,7 +31,7 @@ index 95fcccafae14..9cc8a7dd23ae 100644
|
||||
static int suspend_8960(struct tsens_priv *priv)
|
||||
{
|
||||
int ret;
|
||||
@@ -194,9 +201,7 @@ static int calibrate_8960(struct tsens_priv *priv)
|
||||
@@ -194,9 +201,7 @@ static int calibrate_8960(struct tsens_p
|
||||
{
|
||||
int i;
|
||||
char *data;
|
||||
@ -44,7 +42,7 @@ index 95fcccafae14..9cc8a7dd23ae 100644
|
||||
|
||||
data = qfprom_read(priv->dev, "calib");
|
||||
if (IS_ERR(data))
|
||||
@@ -204,49 +209,18 @@ static int calibrate_8960(struct tsens_priv *priv)
|
||||
@@ -204,49 +209,18 @@ static int calibrate_8960(struct tsens_p
|
||||
if (IS_ERR(data))
|
||||
return PTR_ERR(data);
|
||||
|
||||
@ -100,7 +98,7 @@ index 95fcccafae14..9cc8a7dd23ae 100644
|
||||
static struct tsens_features tsens_8960_feat = {
|
||||
.ver_major = VER_0,
|
||||
.crit_int = 0,
|
||||
@@ -315,7 +289,7 @@ static const struct reg_field tsens_8960_regfields[MAX_REGFIELDS] = {
|
||||
@@ -315,7 +289,7 @@ static const struct reg_field tsens_8960
|
||||
static const struct tsens_ops ops_8960 = {
|
||||
.init = init_common,
|
||||
.calibrate = calibrate_8960,
|
||||
@ -109,6 +107,3 @@ index 95fcccafae14..9cc8a7dd23ae 100644
|
||||
.enable = enable_8960,
|
||||
.disable = disable_8960,
|
||||
.suspend = suspend_8960,
|
||||
--
|
||||
2.30.2
|
||||
|
||||
|
@ -11,8 +11,6 @@ Reviewed-by: Thara Gopinath <thara.gopinath@linaro.org>
|
||||
drivers/thermal/qcom/tsens-8960.c | 24 +-----------------------
|
||||
1 file changed, 1 insertion(+), 23 deletions(-)
|
||||
|
||||
diff --git a/drivers/thermal/qcom/tsens-8960.c b/drivers/thermal/qcom/tsens-8960.c
|
||||
index 9cc8a7dd23ae..58d09e927383 100644
|
||||
--- a/drivers/thermal/qcom/tsens-8960.c
|
||||
+++ b/drivers/thermal/qcom/tsens-8960.c
|
||||
@@ -10,8 +10,6 @@
|
||||
@ -65,6 +63,3 @@ index 9cc8a7dd23ae..58d09e927383 100644
|
||||
|
||||
#define S0_STATUS_OFF 0x3628
|
||||
#define S1_STATUS_OFF 0x362c
|
||||
--
|
||||
2.30.2
|
||||
|
||||
|
@ -12,11 +12,9 @@ Reviewed-by: Thara Gopinath <thara.gopinath@linaro.org>
|
||||
drivers/thermal/qcom/tsens.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/drivers/thermal/qcom/tsens.c b/drivers/thermal/qcom/tsens.c
|
||||
index 38b9936def1a..58073dc5d30b 100644
|
||||
--- a/drivers/thermal/qcom/tsens.c
|
||||
+++ b/drivers/thermal/qcom/tsens.c
|
||||
@@ -966,6 +966,9 @@ static SIMPLE_DEV_PM_OPS(tsens_pm_ops, tsens_suspend, tsens_resume);
|
||||
@@ -966,6 +966,9 @@ static SIMPLE_DEV_PM_OPS(tsens_pm_ops, t
|
||||
|
||||
static const struct of_device_id tsens_table[] = {
|
||||
{
|
||||
@ -26,6 +24,3 @@ index 38b9936def1a..58073dc5d30b 100644
|
||||
.compatible = "qcom,msm8916-tsens",
|
||||
.data = &data_8916,
|
||||
}, {
|
||||
--
|
||||
2.30.2
|
||||
|
||||
|
@ -12,8 +12,6 @@ Reviewed-by: Rob Herring <robh@kernel.org>
|
||||
.../bindings/thermal/qcom-tsens.yaml | 56 ++++++++++++++++---
|
||||
1 file changed, 48 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/Documentation/devicetree/bindings/thermal/qcom-tsens.yaml b/Documentation/devicetree/bindings/thermal/qcom-tsens.yaml
|
||||
index 95462e071ab4..1785b1c75a3c 100644
|
||||
--- a/Documentation/devicetree/bindings/thermal/qcom-tsens.yaml
|
||||
+++ b/Documentation/devicetree/bindings/thermal/qcom-tsens.yaml
|
||||
@@ -19,6 +19,11 @@ description: |
|
||||
@ -60,7 +58,7 @@ index 95462e071ab4..1785b1c75a3c 100644
|
||||
- qcom,msm8916-tsens
|
||||
- qcom,msm8974-tsens
|
||||
- qcom,msm8976-tsens
|
||||
@@ -114,17 +129,42 @@ allOf:
|
||||
@@ -114,19 +129,44 @@ allOf:
|
||||
interrupt-names:
|
||||
minItems: 2
|
||||
|
||||
@ -87,8 +85,8 @@ index 95462e071ab4..1785b1c75a3c 100644
|
||||
additionalProperties: false
|
||||
|
||||
examples:
|
||||
+ - |
|
||||
+ #include <dt-bindings/interrupt-controller/arm-gic.h>
|
||||
- |
|
||||
#include <dt-bindings/interrupt-controller/arm-gic.h>
|
||||
+ // Example msm9860 based SoC (ipq8064):
|
||||
+ gcc: clock-controller {
|
||||
+
|
||||
@ -107,9 +105,8 @@ index 95462e071ab4..1785b1c75a3c 100644
|
||||
+ };
|
||||
+ };
|
||||
+
|
||||
- |
|
||||
#include <dt-bindings/interrupt-controller/arm-gic.h>
|
||||
+ - |
|
||||
+ #include <dt-bindings/interrupt-controller/arm-gic.h>
|
||||
// Example 1 (legacy: for pre v1 IP):
|
||||
--
|
||||
2.30.2
|
||||
|
||||
tsens1: thermal-sensor@900000 {
|
||||
compatible = "qcom,msm8916-tsens", "qcom,tsens-v0_1";
|
||||
|
@ -12,8 +12,6 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
|
||||
drivers/thermal/qcom/tsens-8960.c | 8 ++++----
|
||||
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/drivers/thermal/qcom/tsens-8960.c b/drivers/thermal/qcom/tsens-8960.c
|
||||
index 58d09e927383..5cc5b3527f1f 100644
|
||||
--- a/drivers/thermal/qcom/tsens-8960.c
|
||||
+++ b/drivers/thermal/qcom/tsens-8960.c
|
||||
@@ -45,11 +45,11 @@
|
||||
@ -32,6 +30,3 @@ index 58d09e927383..5cc5b3527f1f 100644
|
||||
};
|
||||
|
||||
static int suspend_8960(struct tsens_priv *priv)
|
||||
--
|
||||
2.30.2
|
||||
|
||||
|
@ -86,11 +86,9 @@ Signed-off-by: Jonathan McDowell <noodles@earth.li>
|
||||
drivers/net/ethernet/stmicro/stmmac/dwmac-ipq806x.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/drivers/net/ethernet/stmicro/stmmac/dwmac-ipq806x.c b/drivers/net/ethernet/stmicro/stmmac/dwmac-ipq806x.c
|
||||
index bf3250e0e59c..749585fe6fc9 100644
|
||||
--- a/drivers/net/ethernet/stmicro/stmmac/dwmac-ipq806x.c
|
||||
+++ b/drivers/net/ethernet/stmicro/stmmac/dwmac-ipq806x.c
|
||||
@@ -352,6 +352,8 @@ static int ipq806x_gmac_probe(struct platform_device *pdev)
|
||||
@@ -352,6 +352,8 @@ static int ipq806x_gmac_probe(struct pla
|
||||
plat_dat->bsp_priv = gmac;
|
||||
plat_dat->fix_mac_speed = ipq806x_gmac_fix_mac_speed;
|
||||
plat_dat->multicast_filter_bins = 0;
|
||||
|
Loading…
Reference in New Issue
Block a user