mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-28 17:48:58 +00:00
gettext-full: updated to 0.18.2.1
Signed-off-by: Russell Senior <russell@personaltelco.net> SVN-Revision: 36400
This commit is contained in:
parent
2da62933d7
commit
f2f1233149
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006-2012 OpenWrt.org
|
# Copyright (C) 2006-2013 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=gettext-full
|
PKG_NAME:=gettext-full
|
||||||
PKG_VERSION:=0.18.1.1
|
PKG_VERSION:=0.18.2.1
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=gettext-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=gettext-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@GNU/gettext
|
PKG_SOURCE_URL:=@GNU/gettext
|
||||||
PKG_MD5SUM:=3dd55b952826d2b32f51308f2f91aa89
|
PKG_MD5SUM:=034c8103b14654ebd300fadac44d6f14
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/gettext-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/gettext-$(PKG_VERSION)
|
||||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/gettext-$(PKG_VERSION)
|
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/gettext-$(PKG_VERSION)
|
||||||
|
|
||||||
|
@ -1,17 +0,0 @@
|
|||||||
uclibc defines __GLIBC__ but it does not expose struct shed_param as much as glibc
|
|
||||||
and is not needed too per standard. gnulib attempts to use it but we have to account
|
|
||||||
for it because in this case uclibc does not behave like glibc.
|
|
||||||
|
|
||||||
-Khem
|
|
||||||
|
|
||||||
--- a/gettext-tools/gnulib-lib/spawn.in.h
|
|
||||||
+++ b/gettext-tools/gnulib-lib/spawn.in.h
|
|
||||||
@@ -31,7 +31,7 @@
|
|
||||||
|
|
||||||
/* Get definitions of 'struct sched_param' and 'sigset_t'.
|
|
||||||
But avoid namespace pollution on glibc systems. */
|
|
||||||
-#ifndef __GLIBC__
|
|
||||||
+#if !defined __GLIBC__ || defined __UCLIBC__
|
|
||||||
# include <sched.h>
|
|
||||||
# include <signal.h>
|
|
||||||
#endif
|
|
@ -1,22 +0,0 @@
|
|||||||
--- a/gettext-runtime/intl/localename.c
|
|
||||||
+++ b/gettext-runtime/intl/localename.c
|
|
||||||
@@ -2607,7 +2607,7 @@ gl_locale_name_thread_unsafe (int catego
|
|
||||||
locale_t thread_locale = uselocale (NULL);
|
|
||||||
if (thread_locale != LC_GLOBAL_LOCALE)
|
|
||||||
{
|
|
||||||
-# if __GLIBC__ >= 2
|
|
||||||
+# if __GLIBC__ >= 2 && !defined __UCLIBC__
|
|
||||||
/* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
|
|
||||||
glibc < 2.12.
|
|
||||||
See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
|
|
||||||
--- a/gettext-tools/gnulib-lib/localename.c
|
|
||||||
+++ b/gettext-tools/gnulib-lib/localename.c
|
|
||||||
@@ -2607,7 +2607,7 @@ gl_locale_name_thread_unsafe (int catego
|
|
||||||
locale_t thread_locale = uselocale (NULL);
|
|
||||||
if (thread_locale != LC_GLOBAL_LOCALE)
|
|
||||||
{
|
|
||||||
-# if __GLIBC__ >= 2
|
|
||||||
+# if __GLIBC__ >= 2 && !defined __UCLIBC__
|
|
||||||
/* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
|
|
||||||
glibc < 2.12.
|
|
||||||
See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
|
|
@ -1,36 +0,0 @@
|
|||||||
--- a/gettext-runtime/gnulib-lib/stdio.in.h
|
|
||||||
+++ b/gettext-runtime/gnulib-lib/stdio.in.h
|
|
||||||
@@ -141,7 +141,9 @@ _GL_WARN_ON_USE (fflush, "fflush is not
|
|
||||||
so any use of gets warrants an unconditional warning. Assume it is
|
|
||||||
always declared, since it is required by C89. */
|
|
||||||
#undef gets
|
|
||||||
+#if HAVE_RAW_DECL_GETS
|
|
||||||
_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#if @GNULIB_FOPEN@
|
|
||||||
# if @REPLACE_FOPEN@
|
|
||||||
--- a/gettext-tools/gnulib-lib/stdio.in.h
|
|
||||||
+++ b/gettext-tools/gnulib-lib/stdio.in.h
|
|
||||||
@@ -141,7 +141,9 @@ _GL_WARN_ON_USE (fflush, "fflush is not
|
|
||||||
so any use of gets warrants an unconditional warning. Assume it is
|
|
||||||
always declared, since it is required by C89. */
|
|
||||||
#undef gets
|
|
||||||
+#if HAVE_RAW_DECL_GETS
|
|
||||||
_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#if @GNULIB_FOPEN@
|
|
||||||
# if @REPLACE_FOPEN@
|
|
||||||
--- a/gettext-tools/libgettextpo/stdio.in.h
|
|
||||||
+++ b/gettext-tools/libgettextpo/stdio.in.h
|
|
||||||
@@ -141,7 +141,9 @@ _GL_WARN_ON_USE (fflush, "fflush is not
|
|
||||||
so any use of gets warrants an unconditional warning. Assume it is
|
|
||||||
always declared, since it is required by C89. */
|
|
||||||
#undef gets
|
|
||||||
+#if HAVE_RAW_DECL_GETS
|
|
||||||
_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#if @GNULIB_FOPEN@
|
|
||||||
# if @REPLACE_FOPEN@
|
|
Loading…
Reference in New Issue
Block a user