util-linux: update to v2.40.1

Release Notes:
	https://mirrors.edge.kernel.org/pub/linux/utils/util-linux/v2.40/v2.40-ReleaseNotes
	https://mirrors.edge.kernel.org/pub/linux/utils/util-linux/v2.40/v2.40.1-ReleaseNotes

Remove upstreamed:
	001-meson-properly-handle-gettext-non-existence.patch

New:
	0001-meson-Fix-build-python-option.patch

Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
This commit is contained in:
Thomas Weißschuh 2024-06-16 22:55:41 +02:00 committed by Nick Hainke
parent bc56334428
commit f1b7f45f8c
3 changed files with 36 additions and 32 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=util-linux
PKG_VERSION:=2.39.3
PKG_VERSION:=2.40.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.39
PKG_HASH:=7b6605e48d1a49f43cc4b4cfc59f313d0dd5402fa40b96810bd572e167dfed0f
PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.40
PKG_HASH:=59e676aa53ccb44b6c39f0ffe01a8fa274891c91bef1474752fad92461def24f
PKG_CPE_ID:=cpe:/a:kernel:util-linux
PKG_LICENSE:=GPL-2.0-only
@ -318,7 +318,7 @@ endef
define Package/lsblk
$(call Package/util-linux/Default)
TITLE:=list block devices
DEPENDS:= +libblkid +libmount +libsmartcols
DEPENDS:= +libblkid +libmount +libsmartcols +libncurses
SUBMENU=Disc
endef
@ -623,6 +623,7 @@ MESON_ARGS += \
-Dbuild-write=disabled \
-Dbuild-bash-completion=disabled \
-Dbuild-pylibmount=disabled \
-Dbuild-liblastlog2=disabled \
-Dreadline=disabled \
-Dmagic=disabled \
-Dncursesw=enabled

View File

@ -0,0 +1,31 @@
From b66b70d62e50923502aeb3f6420a5f9c20f769d3 Mon Sep 17 00:00:00 2001
From: Jordan Williams <jordan@jwillikers.com>
Date: Thu, 9 May 2024 15:57:12 -0500
Subject: [PATCH] meson: Fix build-python option
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
The build-python option is for controlling whether or not pylibmount is
built.
Unfortunately, commit b6799cc rendered the option unused.
This change uses the build-python option again.
Signed-off-by: Jordan Williams <jordan@jwillikers.com>
Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
---
libmount/python/meson.build | 40 ++++++++++++++++++-------------------
1 file changed, 20 insertions(+), 20 deletions(-)
diff --git a/libmount/python/meson.build b/libmount/python/meson.build
index 72985eca6b21..5dcdf807da89 100644
--- a/libmount/python/meson.build
+++ b/libmount/python/meson.build
@@ -1,4 +1,6 @@
-build_python = python.found()
+if get_option('build-python').disabled()
+ subdir_done()
+endif
pylibmount_sources = '''
pylibmount.c

View File

@ -1,28 +0,0 @@
From b8bed37a1493b913bf5bda938487ae0c06c11ce7 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Thomas=20Wei=C3=9Fschuh?= <thomas@t-8ch.de>
Date: Sat, 5 Aug 2023 08:57:28 +0200
Subject: [PATCH] meson: properly handle gettext non-existence
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Commit e91a49c9747f ("meson: don't build po if no gettext")
tried to add the possibility to build util-linux without gettext.
Unfortunately by default the call to find_program() would abort the
build if the program is not found.
Avoid aborting the build.
Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
---
po/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/po/meson.build
+++ b/po/meson.build
@@ -1,4 +1,4 @@
-if not find_program('gettext').found()
+if not find_program('gettext', required : false).found()
subdir_done()
endif