mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-15 07:02:09 +00:00
kernel: bump 5.10 to 5.10.50
No deleted or manually refreshed patches. Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com> Signed-off-by: maurerr <mariusd84@gmail.com>
This commit is contained in:
parent
c0a682b627
commit
f099222f59
@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
|
|||||||
endif
|
endif
|
||||||
|
|
||||||
LINUX_VERSION-5.4 = .132
|
LINUX_VERSION-5.4 = .132
|
||||||
LINUX_VERSION-5.10 = .49
|
LINUX_VERSION-5.10 = .50
|
||||||
|
|
||||||
LINUX_KERNEL_HASH-5.4.132 = 8466adbfb3579e751ede683496df7bb20f258b5f882250f3dd82be63736d00ef
|
LINUX_KERNEL_HASH-5.4.132 = 8466adbfb3579e751ede683496df7bb20f258b5f882250f3dd82be63736d00ef
|
||||||
LINUX_KERNEL_HASH-5.10.49 = b0d16de7e79c272b01996ad8ff8bdf3a6a011bc0c94049baccf69f05dde3025e
|
LINUX_KERNEL_HASH-5.10.50 = 8bda327a7d95acfff8f87fb6ef4223e3194fa22195f5551249a9aa3393bfb436
|
||||||
|
|
||||||
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
|
||||||
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
|
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
|
||||||
|
@ -13,7 +13,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
|||||||
|
|
||||||
--- a/drivers/leds/Kconfig
|
--- a/drivers/leds/Kconfig
|
||||||
+++ b/drivers/leds/Kconfig
|
+++ b/drivers/leds/Kconfig
|
||||||
@@ -928,6 +928,17 @@ config LEDS_ACER_A500
|
@@ -929,6 +929,17 @@ config LEDS_ACER_A500
|
||||||
This option enables support for the Power Button LED of
|
This option enables support for the Power Button LED of
|
||||||
Acer Iconia Tab A500.
|
Acer Iconia Tab A500.
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/mtd/parsers/redboot.c
|
--- a/drivers/mtd/parsers/redboot.c
|
||||||
+++ b/drivers/mtd/parsers/redboot.c
|
+++ b/drivers/mtd/parsers/redboot.c
|
||||||
@@ -85,12 +85,18 @@ static int parse_redboot_partitions(stru
|
@@ -90,12 +90,18 @@ static int parse_redboot_partitions(stru
|
||||||
|
|
||||||
parse_redboot_of(master);
|
parse_redboot_of(master);
|
||||||
|
|
||||||
@ -19,7 +19,7 @@
|
|||||||
return -EIO;
|
return -EIO;
|
||||||
}
|
}
|
||||||
offset -= master->erasesize;
|
offset -= master->erasesize;
|
||||||
@@ -103,10 +109,6 @@ static int parse_redboot_partitions(stru
|
@@ -108,10 +114,6 @@ static int parse_redboot_partitions(stru
|
||||||
goto nogood;
|
goto nogood;
|
||||||
}
|
}
|
||||||
}
|
}
|
||||||
@ -30,7 +30,7 @@
|
|||||||
|
|
||||||
printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
|
printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
|
||||||
master->name, offset);
|
master->name, offset);
|
||||||
@@ -179,6 +181,11 @@ static int parse_redboot_partitions(stru
|
@@ -184,6 +186,11 @@ static int parse_redboot_partitions(stru
|
||||||
}
|
}
|
||||||
if (i == numslots) {
|
if (i == numslots) {
|
||||||
/* Didn't find it */
|
/* Didn't find it */
|
||||||
|
@ -267,7 +267,7 @@
|
|||||||
case IPV6_2292HOPOPTS:
|
case IPV6_2292HOPOPTS:
|
||||||
--- a/net/ipv6/exthdrs.c
|
--- a/net/ipv6/exthdrs.c
|
||||||
+++ b/net/ipv6/exthdrs.c
|
+++ b/net/ipv6/exthdrs.c
|
||||||
@@ -949,7 +949,7 @@ static bool ipv6_hop_jumbo(struct sk_buf
|
@@ -948,7 +948,7 @@ static bool ipv6_hop_jumbo(struct sk_buf
|
||||||
goto drop;
|
goto drop;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/mfd/Kconfig
|
--- a/drivers/mfd/Kconfig
|
||||||
+++ b/drivers/mfd/Kconfig
|
+++ b/drivers/mfd/Kconfig
|
||||||
@@ -2141,6 +2141,14 @@ config RAVE_SP_CORE
|
@@ -2142,6 +2142,14 @@ config RAVE_SP_CORE
|
||||||
Select this to get support for the Supervisory Processor
|
Select this to get support for the Supervisory Processor
|
||||||
device found on several devices in RAVE line of hardware.
|
device found on several devices in RAVE line of hardware.
|
||||||
|
|
||||||
|
@ -23,7 +23,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
|
|||||||
.width = 2,
|
.width = 2,
|
||||||
--- a/drivers/mtd/parsers/redboot.c
|
--- a/drivers/mtd/parsers/redboot.c
|
||||||
+++ b/drivers/mtd/parsers/redboot.c
|
+++ b/drivers/mtd/parsers/redboot.c
|
||||||
@@ -79,6 +79,7 @@ static int parse_redboot_partitions(stru
|
@@ -84,6 +84,7 @@ static int parse_redboot_partitions(stru
|
||||||
int nulllen = 0;
|
int nulllen = 0;
|
||||||
int numslots;
|
int numslots;
|
||||||
unsigned long offset;
|
unsigned long offset;
|
||||||
@ -31,7 +31,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
|
|||||||
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
|
#ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
|
||||||
static char nullstring[] = "unallocated";
|
static char nullstring[] = "unallocated";
|
||||||
#endif
|
#endif
|
||||||
@@ -185,6 +186,16 @@ static int parse_redboot_partitions(stru
|
@@ -190,6 +191,16 @@ static int parse_redboot_partitions(stru
|
||||||
goto out;
|
goto out;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -48,7 +48,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
|
|||||||
for (i = 0; i < numslots; i++) {
|
for (i = 0; i < numslots; i++) {
|
||||||
struct fis_list *new_fl, **prev;
|
struct fis_list *new_fl, **prev;
|
||||||
|
|
||||||
@@ -205,10 +216,10 @@ static int parse_redboot_partitions(stru
|
@@ -210,10 +221,10 @@ static int parse_redboot_partitions(stru
|
||||||
goto out;
|
goto out;
|
||||||
}
|
}
|
||||||
new_fl->img = &buf[i];
|
new_fl->img = &buf[i];
|
||||||
|
@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
"__kstrtabns_" #sym ": \n" \
|
"__kstrtabns_" #sym ": \n" \
|
||||||
--- a/scripts/Makefile.build
|
--- a/scripts/Makefile.build
|
||||||
+++ b/scripts/Makefile.build
|
+++ b/scripts/Makefile.build
|
||||||
@@ -366,7 +366,7 @@ targets += $(lib-y) $(always-y) $(MAKECM
|
@@ -367,7 +367,7 @@ targets += $(lib-y) $(always-y) $(MAKECM
|
||||||
# Linker scripts preprocessor (.lds.S -> .lds)
|
# Linker scripts preprocessor (.lds.S -> .lds)
|
||||||
# ---------------------------------------------------------------------------
|
# ---------------------------------------------------------------------------
|
||||||
quiet_cmd_cpp_lds_S = LDS $@
|
quiet_cmd_cpp_lds_S = LDS $@
|
||||||
|
@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
|
|
||||||
--- a/include/net/sch_generic.h
|
--- a/include/net/sch_generic.h
|
||||||
+++ b/include/net/sch_generic.h
|
+++ b/include/net/sch_generic.h
|
||||||
@@ -611,12 +611,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
|
@@ -623,12 +623,13 @@ extern struct Qdisc_ops noop_qdisc_ops;
|
||||||
extern struct Qdisc_ops pfifo_fast_ops;
|
extern struct Qdisc_ops pfifo_fast_ops;
|
||||||
extern struct Qdisc_ops mq_qdisc_ops;
|
extern struct Qdisc_ops mq_qdisc_ops;
|
||||||
extern struct Qdisc_ops noqueue_qdisc_ops;
|
extern struct Qdisc_ops noqueue_qdisc_ops;
|
||||||
|
@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
|
|
||||||
--- a/lib/vsprintf.c
|
--- a/lib/vsprintf.c
|
||||||
+++ b/lib/vsprintf.c
|
+++ b/lib/vsprintf.c
|
||||||
@@ -957,8 +957,10 @@ char *symbol_string(char *buf, char *end
|
@@ -983,8 +983,10 @@ char *symbol_string(char *buf, char *end
|
||||||
struct printf_spec spec, const char *fmt)
|
struct printf_spec spec, const char *fmt)
|
||||||
{
|
{
|
||||||
unsigned long value;
|
unsigned long value;
|
||||||
@ -23,7 +23,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
if (fmt[1] == 'R')
|
if (fmt[1] == 'R')
|
||||||
@@ -975,8 +977,14 @@ char *symbol_string(char *buf, char *end
|
@@ -1001,8 +1003,14 @@ char *symbol_string(char *buf, char *end
|
||||||
|
|
||||||
return string_nocheck(buf, end, sym, spec);
|
return string_nocheck(buf, end, sym, spec);
|
||||||
#else
|
#else
|
||||||
|
@ -12,7 +12,7 @@ Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
|
|||||||
|
|
||||||
--- a/drivers/mtd/parsers/redboot.c
|
--- a/drivers/mtd/parsers/redboot.c
|
||||||
+++ b/drivers/mtd/parsers/redboot.c
|
+++ b/drivers/mtd/parsers/redboot.c
|
||||||
@@ -300,6 +300,7 @@ static int parse_redboot_partitions(stru
|
@@ -305,6 +305,7 @@ static int parse_redboot_partitions(stru
|
||||||
|
|
||||||
static const struct of_device_id mtd_parser_redboot_of_match_table[] = {
|
static const struct of_device_id mtd_parser_redboot_of_match_table[] = {
|
||||||
{ .compatible = "redboot-fis" },
|
{ .compatible = "redboot-fis" },
|
||||||
|
@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|||||||
|
|
||||||
--- a/drivers/mtd/parsers/redboot.c
|
--- a/drivers/mtd/parsers/redboot.c
|
||||||
+++ b/drivers/mtd/parsers/redboot.c
|
+++ b/drivers/mtd/parsers/redboot.c
|
||||||
@@ -274,14 +274,21 @@ static int parse_redboot_partitions(stru
|
@@ -279,14 +279,21 @@ static int parse_redboot_partitions(stru
|
||||||
#endif
|
#endif
|
||||||
names += strlen(names)+1;
|
names += strlen(names)+1;
|
||||||
|
|
||||||
|
@ -311,7 +311,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
|
|||||||
/**
|
/**
|
||||||
* ip6_tnl_addr_conflict - compare packet addresses to tunnel's own
|
* ip6_tnl_addr_conflict - compare packet addresses to tunnel's own
|
||||||
* @t: the outgoing tunnel device
|
* @t: the outgoing tunnel device
|
||||||
@@ -1306,6 +1454,7 @@ ipxip6_tnl_xmit(struct sk_buff *skb, str
|
@@ -1304,6 +1452,7 @@ ipxip6_tnl_xmit(struct sk_buff *skb, str
|
||||||
u8 protocol)
|
u8 protocol)
|
||||||
{
|
{
|
||||||
struct ip6_tnl *t = netdev_priv(dev);
|
struct ip6_tnl *t = netdev_priv(dev);
|
||||||
@ -319,7 +319,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
|
|||||||
struct ipv6hdr *ipv6h;
|
struct ipv6hdr *ipv6h;
|
||||||
const struct iphdr *iph;
|
const struct iphdr *iph;
|
||||||
int encap_limit = -1;
|
int encap_limit = -1;
|
||||||
@@ -1405,6 +1554,18 @@ ipxip6_tnl_xmit(struct sk_buff *skb, str
|
@@ -1403,6 +1552,18 @@ ipxip6_tnl_xmit(struct sk_buff *skb, str
|
||||||
fl6.flowi6_uid = sock_net_uid(dev_net(dev), NULL);
|
fl6.flowi6_uid = sock_net_uid(dev_net(dev), NULL);
|
||||||
dsfield = INET_ECN_encapsulate(dsfield, orig_dsfield);
|
dsfield = INET_ECN_encapsulate(dsfield, orig_dsfield);
|
||||||
|
|
||||||
|
@ -19,7 +19,7 @@
|
|||||||
},
|
},
|
||||||
[PORT_NPCM] = {
|
[PORT_NPCM] = {
|
||||||
.name = "Nuvoton 16550",
|
.name = "Nuvoton 16550",
|
||||||
@@ -2699,6 +2699,11 @@ serial8250_do_set_termios(struct uart_po
|
@@ -2712,6 +2712,11 @@ serial8250_do_set_termios(struct uart_po
|
||||||
unsigned long flags;
|
unsigned long flags;
|
||||||
unsigned int baud, quot, frac = 0;
|
unsigned int baud, quot, frac = 0;
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/drivers/leds/Kconfig
|
--- a/drivers/leds/Kconfig
|
||||||
+++ b/drivers/leds/Kconfig
|
+++ b/drivers/leds/Kconfig
|
||||||
@@ -928,6 +928,16 @@ config LEDS_ACER_A500
|
@@ -929,6 +929,16 @@ config LEDS_ACER_A500
|
||||||
This option enables support for the Power Button LED of
|
This option enables support for the Power Button LED of
|
||||||
Acer Iconia Tab A500.
|
Acer Iconia Tab A500.
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user