mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
kernel: fix sdhci-msm build error
A missing upstream stable backport leads to the following build error: CC drivers/mmc/host/sdhci-msm.o drivers/mmc/host/sdhci-msm.c:1158:3: error: 'const struct sdhci_ops' has no member named 'write_w' .write_w = sdhci_msm_write_w, ^~~~~~~ drivers/mmc/host/sdhci-msm.c:1158:13: warning: excess elements in struct initializer .write_w = sdhci_msm_write_w, ^~~~~~~~~~~~~~~~~ drivers/mmc/host/sdhci-msm.c:1158:13: note: (near initialization for 'sdhci_msm_ops') scripts/Makefile.build:326: recipe for target 'drivers/mmc/host/sdhci-msm.o' failed Solve the issue by backporting commit 99d570da30 ("mmc: Kconfig: Enable CONFIG_MMC_SDHCI_IO_ACCESSORS") from linux-stable. Ref:528508ae8b (commitcomment-32049231)
Fixes:528508ae8b
("kernel: bump 4.14 to 4.14.95") Signed-off-by: Jo-Philipp Wich <jo@mein.io>
This commit is contained in:
parent
e906a75e67
commit
f01044e85c
@ -0,0 +1,23 @@
|
||||
From: Vijay Viswanath <vviswana@codeaurora.org>
|
||||
Date: Wed, 27 Sep 2017 11:04:42 +0530
|
||||
Subject: [PATCH v2 3/4] mmc: Kconfig: Enable CONFIG_MMC_SDHCI_IO_ACCESSORS
|
||||
|
||||
Enable CONFIG_MMC_SDHCI_IO_ACCESSORS so that SDHC controller specific
|
||||
register read and write APIs, if registered, can be used.
|
||||
|
||||
Signed-off-by: Vijay Viswanath <vviswana@codeaurora.org>
|
||||
Acked-by: Adrian Hunter <adrian.hunter@intel.com>
|
||||
---
|
||||
drivers/mmc/host/Kconfig | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
--- a/drivers/mmc/host/Kconfig
|
||||
+++ b/drivers/mmc/host/Kconfig
|
||||
@@ -420,6 +420,7 @@ config MMC_SDHCI_MSM
|
||||
tristate "Qualcomm SDHCI Controller Support"
|
||||
depends on ARCH_QCOM || (ARM && COMPILE_TEST)
|
||||
depends on MMC_SDHCI_PLTFM
|
||||
+ select MMC_SDHCI_IO_ACCESSORS
|
||||
help
|
||||
This selects the Secure Digital Host Controller Interface (SDHCI)
|
||||
support present in Qualcomm SOCs. The controller supports
|
Loading…
Reference in New Issue
Block a user