diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index a4901b583f5..ccba046d120 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -102,9 +102,7 @@ ifeq ($(DUMP),)
 			echo "$(1)" >> $(PKG_INSTALL_STAMP)
         endif
       else
-        compile: $(1)-disabled
-        $(1)-disabled:
-		@echo "WARNING: skipping $(1) -- package not selected" >&2
+        $$(info WARNING: skipping $(1) -- package not selected)
       endif
     endif
     endif