mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-12 05:35:38 +00:00
uboot-imx6: update to 2013.10
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38625
This commit is contained in:
parent
672a8cd6ba
commit
ed676cf0ff
@ -8,7 +8,7 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=u-boot
|
PKG_NAME:=u-boot
|
||||||
PKG_VERSION:=2013.07
|
PKG_VERSION:=2013.10
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
@ -16,7 +16,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|||||||
PKG_SOURCE_URL:= \
|
PKG_SOURCE_URL:= \
|
||||||
http://mirror2.openwrt.org/sources \
|
http://mirror2.openwrt.org/sources \
|
||||||
ftp://ftp.denx.de/pub/u-boot
|
ftp://ftp.denx.de/pub/u-boot
|
||||||
PKG_MD5SUM:=8445162690052e6afd4b8f87af2bb557
|
PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -98,13 +98,11 @@ UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin
|
|||||||
endif
|
endif
|
||||||
|
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
|
||||||
$(UBOOT_CONFIG)_config
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) CROSS_COMPILE=$(TARGET_CROSS)
|
||||||
CROSS_COMPILE=$(TARGET_CROSS)
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/uboot/install/default
|
define Package/uboot/install/default
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/include/configs/wandboard.h
|
--- a/include/configs/wandboard.h
|
||||||
+++ b/include/configs/wandboard.h
|
+++ b/include/configs/wandboard.h
|
||||||
@@ -51,7 +51,7 @@
|
@@ -48,7 +48,7 @@
|
||||||
#define CONFIG_CMD_BMODE
|
#define CONFIG_CMD_BMODE
|
||||||
#define CONFIG_CMD_SETEXPR
|
#define CONFIG_CMD_SETEXPR
|
||||||
|
|
||||||
@ -9,17 +9,14 @@
|
|||||||
|
|
||||||
#define CONFIG_SYS_MEMTEST_START 0x10000000
|
#define CONFIG_SYS_MEMTEST_START 0x10000000
|
||||||
#define CONFIG_SYS_MEMTEST_END (CONFIG_SYS_MEMTEST_START + 500 * SZ_1M)
|
#define CONFIG_SYS_MEMTEST_END (CONFIG_SYS_MEMTEST_START + 500 * SZ_1M)
|
||||||
@@ -103,15 +103,18 @@
|
@@ -101,13 +101,15 @@
|
||||||
|
|
||||||
#if defined(CONFIG_MX6DL)
|
#if defined(CONFIG_MX6DL) || defined(CONFIG_MX6S)
|
||||||
#define CONFIG_DEFAULT_FDT_FILE "imx6dl-wandboard.dtb"
|
#define CONFIG_DEFAULT_FDT_FILE "imx6dl-wandboard.dtb"
|
||||||
+#define CONFIG_OWRT_NAME "openwrt-imx6dl-wandboard-uImage.itb"
|
+#define CONFIG_OWRT_NAME "openwrt-imx6-imx6dl-wandboard-fit-uImage.itb"
|
||||||
#elif defined(CONFIG_MX6Q)
|
#elif defined(CONFIG_MX6Q)
|
||||||
#define CONFIG_DEFAULT_FDT_FILE "imx6q-wandboard.dtb"
|
#define CONFIG_DEFAULT_FDT_FILE "imx6q-wandboard.dtb"
|
||||||
+#define CONFIG_OWRT_NAME "openwrt-imx6q-wandboard-uImage.itb"
|
+#define CONFIG_OWRT_NAME "openwrt-imx6-imx6q-wandboard-fit-uImage.itb"
|
||||||
#elif defined(CONFIG_MX6S)
|
|
||||||
#define CONFIG_DEFAULT_FDT_FILE "imx6s-wandboard.dtb"
|
|
||||||
+#define CONFIG_OWRT_NAME "openwrt-imx6s-wandboard-uImage.itb"
|
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
#define CONFIG_EXTRA_ENV_SETTINGS \
|
#define CONFIG_EXTRA_ENV_SETTINGS \
|
||||||
@ -27,9 +24,9 @@
|
|||||||
- "uimage=uImage\0" \
|
- "uimage=uImage\0" \
|
||||||
+ "uimage=" CONFIG_OWRT_NAME "\0" \
|
+ "uimage=" CONFIG_OWRT_NAME "\0" \
|
||||||
"console=ttymxc0\0" \
|
"console=ttymxc0\0" \
|
||||||
|
"splashpos=m,m\0" \
|
||||||
"fdt_high=0xffffffff\0" \
|
"fdt_high=0xffffffff\0" \
|
||||||
"initrd_high=0xffffffff\0" \
|
@@ -136,11 +138,11 @@
|
||||||
@@ -139,11 +142,11 @@
|
|
||||||
"mmcargs=setenv bootargs console=${console},${baudrate} " \
|
"mmcargs=setenv bootargs console=${console},${baudrate} " \
|
||||||
"root=${mmcroot}\0" \
|
"root=${mmcroot}\0" \
|
||||||
"loadbootscript=" \
|
"loadbootscript=" \
|
||||||
@ -44,7 +41,7 @@
|
|||||||
"mmcboot=echo Booting from mmc ...; " \
|
"mmcboot=echo Booting from mmc ...; " \
|
||||||
"run mmcargs; " \
|
"run mmcargs; " \
|
||||||
"if test ${boot_fdt} = yes || test ${boot_fdt} = try; then " \
|
"if test ${boot_fdt} = yes || test ${boot_fdt} = try; then " \
|
||||||
@@ -158,30 +161,6 @@
|
@@ -155,30 +157,6 @@
|
||||||
"fi; " \
|
"fi; " \
|
||||||
"else " \
|
"else " \
|
||||||
"bootm; " \
|
"bootm; " \
|
||||||
@ -75,7 +72,7 @@
|
|||||||
"fi;\0"
|
"fi;\0"
|
||||||
|
|
||||||
#define CONFIG_BOOTCOMMAND \
|
#define CONFIG_BOOTCOMMAND \
|
||||||
@@ -191,10 +170,10 @@
|
@@ -188,10 +166,10 @@
|
||||||
"else " \
|
"else " \
|
||||||
"if run loaduimage; then " \
|
"if run loaduimage; then " \
|
||||||
"run mmcboot; " \
|
"run mmcboot; " \
|
||||||
|
Loading…
x
Reference in New Issue
Block a user