mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-12 05:35:38 +00:00
kernel: fix arm compressed images build on mac os x
SVN-Revision: 31274
This commit is contained in:
parent
93b8648b15
commit
ec667208e6
@ -0,0 +1,11 @@
|
|||||||
|
--- a/arch/arm/boot/compressed/Makefile
|
||||||
|
+++ b/arch/arm/boot/compressed/Makefile
|
||||||
|
@@ -127,7 +127,7 @@ ccflags-y := -fpic -fno-builtin -I$(obj)
|
||||||
|
asflags-y := -Wa,-march=all
|
||||||
|
|
||||||
|
# Supply kernel BSS size to the decompressor via a linker symbol.
|
||||||
|
-KBSS_SZ = $(shell size $(obj)/../../../../vmlinux | awk 'END{print $$3}')
|
||||||
|
+KBSS_SZ = $(shell $(CROSS_COMPILE)size $(obj)/../../../../vmlinux | awk 'END{print $$3}')
|
||||||
|
LDFLAGS_vmlinux = --defsym _kernel_bss_size=$(KBSS_SZ)
|
||||||
|
# Supply ZRELADDR to the decompressor via a linker symbol.
|
||||||
|
ifneq ($(CONFIG_AUTO_ZRELADDR),y)
|
Loading…
x
Reference in New Issue
Block a user