mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-24 15:56:49 +00:00
ralink: update the usb phy driver to the version sent upstream
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 48114
This commit is contained in:
parent
9b675a2a33
commit
eb9fccc440
@ -396,7 +396,7 @@
|
|||||||
};
|
};
|
||||||
|
|
||||||
usbphy: usbphy {
|
usbphy: usbphy {
|
||||||
compatible = "ralink,mt7620a-usbphy";
|
compatible = "mediatek,mt7620-usbphy";
|
||||||
#phy-cells = <1>;
|
#phy-cells = <1>;
|
||||||
|
|
||||||
resets = <&rstctrl 22 &rstctrl 25>;
|
resets = <&rstctrl 22 &rstctrl 25>;
|
||||||
|
@ -255,7 +255,7 @@
|
|||||||
};
|
};
|
||||||
|
|
||||||
usbphy: usbphy {
|
usbphy: usbphy {
|
||||||
compatible = "ralink,mt7620a-usbphy";
|
compatible = "mediatek,mt7620-usbphy";
|
||||||
#phy-cells = <1>;
|
#phy-cells = <1>;
|
||||||
|
|
||||||
resets = <&rstctrl 22 &rstctrl 25>;
|
resets = <&rstctrl 22 &rstctrl 25>;
|
||||||
|
@ -341,11 +341,11 @@
|
|||||||
};
|
};
|
||||||
|
|
||||||
usbphy: usbphy {
|
usbphy: usbphy {
|
||||||
compatible = "ralink,mt7628an-usbphy", "ralink,mt7620a-usbphy";
|
compatible = "ralink,mt7628an-usbphy", "mediatek,mt7620-usbphy";
|
||||||
#phy-cells = <1>;
|
#phy-cells = <1>;
|
||||||
|
|
||||||
resets = <&rstctrl 22>;
|
resets = <&rstctrl 22 &rstctrl 25>;
|
||||||
reset-names = "host";
|
reset-names = "host", "device";
|
||||||
};
|
};
|
||||||
|
|
||||||
sdhci@10130000 {
|
sdhci@10130000 {
|
||||||
|
@ -253,7 +253,7 @@
|
|||||||
};
|
};
|
||||||
|
|
||||||
usbphy {
|
usbphy {
|
||||||
compatible = "ralink,rt3xxx-usbphy";
|
compatible = "ralink,rt3352-usbphy";
|
||||||
|
|
||||||
resets = <&rstctrl 22 &rstctrl 25>;
|
resets = <&rstctrl 22 &rstctrl 25>;
|
||||||
reset-names = "host", "device";
|
reset-names = "host", "device";
|
||||||
|
@ -358,7 +358,7 @@
|
|||||||
};
|
};
|
||||||
|
|
||||||
usbphy: usbphy {
|
usbphy: usbphy {
|
||||||
compatible = "ralink,rt3xxx-usbphy";
|
compatible = "ralink,rt3352-usbphy";
|
||||||
#phy-cells = <1>;
|
#phy-cells = <1>;
|
||||||
|
|
||||||
resets = <&rstctrl 22 &rstctrl 25>;
|
resets = <&rstctrl 22 &rstctrl 25>;
|
||||||
|
@ -270,7 +270,7 @@
|
|||||||
};
|
};
|
||||||
|
|
||||||
usbphy: usbphy {
|
usbphy: usbphy {
|
||||||
compatible = "ralink,rt3xxx-usbphy";
|
compatible = "ralink,rt3352-usbphy";
|
||||||
#phy-cells = <1>;
|
#phy-cells = <1>;
|
||||||
|
|
||||||
resets = <&rstctrl 22 &rstctrl 25>;
|
resets = <&rstctrl 22 &rstctrl 25>;
|
||||||
|
@ -1,19 +1,44 @@
|
|||||||
From a10fc0cb650be725157eca50e2ceb34efc281ac2 Mon Sep 17 00:00:00 2001
|
From b00b5eafa7e8d059bd0ce844e66f648916953270 Mon Sep 17 00:00:00 2001
|
||||||
From: John Crispin <blogic@openwrt.org>
|
From: John Crispin <blogic@openwrt.org>
|
||||||
Date: Mon, 22 Apr 2013 23:20:03 +0200
|
Date: Sun, 3 Jan 2016 19:11:22 +0100
|
||||||
Subject: [PATCH 29/53] phy: usb: add ralink phy
|
Subject: [PATCH 2/3] phy: ralink-usb: add driver for Mediatek/Ralink
|
||||||
|
|
||||||
|
Add a driver to setup the USB phy on Mediatek/Ralink SoCs.
|
||||||
|
The driver is trivial and only sets up power and host mode.
|
||||||
|
|
||||||
Signed-off-by: John Crispin <blogic@openwrt.org>
|
Signed-off-by: John Crispin <blogic@openwrt.org>
|
||||||
---
|
---
|
||||||
drivers/phy/Kconfig | 5 ++
|
.../devicetree/bindings/phy/ralink-usb-phy.txt | 17 ++
|
||||||
drivers/phy/Makefile | 1 +
|
drivers/phy/Kconfig | 8 +
|
||||||
drivers/phy/phy-ralink-usb.c | 175 ++++++++++++++++++++++++++++++++++++++++++
|
drivers/phy/Makefile | 1 +
|
||||||
3 files changed, 181 insertions(+)
|
drivers/phy/phy-ralink-usb.c | 171 ++++++++++++++++++++
|
||||||
|
4 files changed, 197 insertions(+)
|
||||||
|
create mode 100644 Documentation/devicetree/bindings/phy/ralink-usb-phy.txt
|
||||||
create mode 100644 drivers/phy/phy-ralink-usb.c
|
create mode 100644 drivers/phy/phy-ralink-usb.c
|
||||||
|
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/Documentation/devicetree/bindings/phy/ralink-usb-phy.txt
|
||||||
|
@@ -0,0 +1,17 @@
|
||||||
|
+Mediatek/Ralink USB PHY
|
||||||
|
+
|
||||||
|
+Required properties:
|
||||||
|
+ - compatible: ralink,rt3352-usbphy or mediatek,mt7620-usbphy
|
||||||
|
+ - #phy-cells: should be 0
|
||||||
|
+ - resets: the two reset controllers for host and device
|
||||||
|
+ - reset-names: the names of the 2 reset controllers
|
||||||
|
+
|
||||||
|
+Example:
|
||||||
|
+
|
||||||
|
+usbphy: phy {
|
||||||
|
+ compatible = "mediatek,mt7620-usbphy";
|
||||||
|
+ #phy-cells = <0>;
|
||||||
|
+
|
||||||
|
+ resets = <&rstctrl 22 &rstctrl 25>;
|
||||||
|
+ reset-names = "host", "device";
|
||||||
|
+};
|
||||||
--- a/drivers/phy/Kconfig
|
--- a/drivers/phy/Kconfig
|
||||||
+++ b/drivers/phy/Kconfig
|
+++ b/drivers/phy/Kconfig
|
||||||
@@ -331,6 +331,11 @@ config PHY_XGENE
|
@@ -331,6 +331,14 @@
|
||||||
help
|
help
|
||||||
This option enables support for APM X-Gene SoC multi-purpose PHY.
|
This option enables support for APM X-Gene SoC multi-purpose PHY.
|
||||||
|
|
||||||
@ -21,13 +46,16 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||||||
+ tristate "Ralink USB PHY driver"
|
+ tristate "Ralink USB PHY driver"
|
||||||
+ select GENERIC_PHY
|
+ select GENERIC_PHY
|
||||||
+ depends on RALINK
|
+ depends on RALINK
|
||||||
|
+ help
|
||||||
|
+ This option enables support for the Ralink USB PHY found inside
|
||||||
|
+ RT3352 and MT7620.
|
||||||
+
|
+
|
||||||
config PHY_STIH407_USB
|
config PHY_STIH407_USB
|
||||||
tristate "STMicroelectronics USB2 picoPHY driver for STiH407 family"
|
tristate "STMicroelectronics USB2 picoPHY driver for STiH407 family"
|
||||||
depends on RESET_CONTROLLER
|
depends on RESET_CONTROLLER
|
||||||
--- a/drivers/phy/Makefile
|
--- a/drivers/phy/Makefile
|
||||||
+++ b/drivers/phy/Makefile
|
+++ b/drivers/phy/Makefile
|
||||||
@@ -46,3 +46,4 @@ obj-$(CONFIG_PHY_QCOM_UFS) += phy-qcom-
|
@@ -46,3 +46,4 @@
|
||||||
obj-$(CONFIG_PHY_TUSB1210) += phy-tusb1210.o
|
obj-$(CONFIG_PHY_TUSB1210) += phy-tusb1210.o
|
||||||
obj-$(CONFIG_PHY_BRCMSTB_SATA) += phy-brcmstb-sata.o
|
obj-$(CONFIG_PHY_BRCMSTB_SATA) += phy-brcmstb-sata.o
|
||||||
obj-$(CONFIG_PHY_PISTACHIO_USB) += phy-pistachio-usb.o
|
obj-$(CONFIG_PHY_PISTACHIO_USB) += phy-pistachio-usb.o
|
||||||
@ -38,7 +66,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||||||
+/*
|
+/*
|
||||||
+ * Allwinner ralink USB phy driver
|
+ * Allwinner ralink USB phy driver
|
||||||
+ *
|
+ *
|
||||||
+ * Copyright (C) 2014 John Crispin <blogic@openwrt.org>
|
+ * Copyright (C) 2016 John Crispin <blogic@openwrt.org>
|
||||||
+ *
|
+ *
|
||||||
+ * Based on code from
|
+ * Based on code from
|
||||||
+ * Allwinner Technology Co., Ltd. <www.allwinnertech.com>
|
+ * Allwinner Technology Co., Ltd. <www.allwinnertech.com>
|
||||||
@ -83,94 +111,76 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||||||
+#define USB_PHY_UTMI_8B60M BIT(1)
|
+#define USB_PHY_UTMI_8B60M BIT(1)
|
||||||
+#define UDEV_WAKEUP BIT(0)
|
+#define UDEV_WAKEUP BIT(0)
|
||||||
+
|
+
|
||||||
+static atomic_t usb_pwr_ref = ATOMIC_INIT(0);
|
+struct ralink_usb_phy {
|
||||||
+static struct reset_control *rstdev;
|
+ struct reset_control *rstdev;
|
||||||
+static struct reset_control *rsthost;
|
+ struct reset_control *rsthost;
|
||||||
+static u32 phy_clk;
|
+ u32 clk;
|
||||||
+static struct phy *rt_phy;
|
+ struct phy *phy;
|
||||||
+
|
+};
|
||||||
+static void usb_phy_enable(int state)
|
|
||||||
+{
|
|
||||||
+ if (state)
|
|
||||||
+ rt_sysc_m32(0, phy_clk, RT_SYSC_REG_CLKCFG1);
|
|
||||||
+ else
|
|
||||||
+ rt_sysc_m32(phy_clk, 0, RT_SYSC_REG_CLKCFG1);
|
|
||||||
+ mdelay(100);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static int ralink_usb_phy_init(struct phy *_phy)
|
|
||||||
+{
|
|
||||||
+ return 0;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static int ralink_usb_phy_exit(struct phy *_phy)
|
|
||||||
+{
|
|
||||||
+ return 0;
|
|
||||||
+}
|
|
||||||
+
|
+
|
||||||
+static int ralink_usb_phy_power_on(struct phy *_phy)
|
+static int ralink_usb_phy_power_on(struct phy *_phy)
|
||||||
+{
|
+{
|
||||||
+ if (atomic_inc_return(&usb_pwr_ref) == 1) {
|
+ struct ralink_usb_phy *phy = phy_get_drvdata(_phy);
|
||||||
+ int host = 1;
|
+ u32 t;
|
||||||
+ u32 t;
|
|
||||||
+
|
+
|
||||||
+ usb_phy_enable(1);
|
+ /* enable the phy */
|
||||||
|
+ rt_sysc_m32(0, phy->clk, RT_SYSC_REG_CLKCFG1);
|
||||||
+
|
+
|
||||||
+ if (host) {
|
+ /* setup host mode */
|
||||||
+ rt_sysc_m32(0, RT_SYSCFG1_USB0_HOST_MODE, RT_SYSC_REG_SYSCFG1);
|
+ rt_sysc_m32(0, RT_SYSCFG1_USB0_HOST_MODE, RT_SYSC_REG_SYSCFG1);
|
||||||
+ if (!IS_ERR(rsthost))
|
|
||||||
+ reset_control_deassert(rsthost);
|
|
||||||
+ if (!IS_ERR(rstdev))
|
|
||||||
+ reset_control_deassert(rstdev);
|
|
||||||
+ } else {
|
|
||||||
+ rt_sysc_m32(RT_SYSCFG1_USB0_HOST_MODE, 0, RT_SYSC_REG_SYSCFG1);
|
|
||||||
+ if (!IS_ERR(rstdev))
|
|
||||||
+ reset_control_deassert(rstdev);
|
|
||||||
+ }
|
|
||||||
+ mdelay(100);
|
|
||||||
+
|
+
|
||||||
+ t = rt_sysc_r32(RT_SYSC_REG_USB_PHY_CFG);
|
+ /* deassert the reset lines */
|
||||||
+ dev_info(&_phy->dev, "remote usb device wakeup %s\n",
|
+ reset_control_deassert(phy->rsthost);
|
||||||
+ (t & UDEV_WAKEUP) ? ("enabbled") : ("disabled"));
|
+ reset_control_deassert(phy->rstdev);
|
||||||
+ if (t & USB_PHY_UTMI_8B60M)
|
+
|
||||||
+ dev_info(&_phy->dev, "UTMI 8bit 60MHz\n");
|
+ /*
|
||||||
+ else
|
+ * The SDK kernel had a delay of 100ms. however on device
|
||||||
+ dev_info(&_phy->dev, "UTMI 16bit 30MHz\n");
|
+ * testing showed that 10ms is enough
|
||||||
+ }
|
+ */
|
||||||
|
+ mdelay(10);
|
||||||
|
+
|
||||||
|
+ /* print some status info */
|
||||||
|
+ t = rt_sysc_r32(RT_SYSC_REG_USB_PHY_CFG);
|
||||||
|
+ dev_info(&phy->phy->dev, "remote usb device wakeup %s\n",
|
||||||
|
+ (t & UDEV_WAKEUP) ? ("enabled") : ("disabled"));
|
||||||
|
+ if (t & USB_PHY_UTMI_8B60M)
|
||||||
|
+ dev_info(&phy->phy->dev, "UTMI 8bit 60MHz\n");
|
||||||
|
+ else
|
||||||
|
+ dev_info(&phy->phy->dev, "UTMI 16bit 30MHz\n");
|
||||||
+
|
+
|
||||||
+ return 0;
|
+ return 0;
|
||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
+static int ralink_usb_phy_power_off(struct phy *_phy)
|
+static int ralink_usb_phy_power_off(struct phy *_phy)
|
||||||
+{
|
+{
|
||||||
+ if (atomic_dec_return(&usb_pwr_ref) == 0) {
|
+ struct ralink_usb_phy *phy = phy_get_drvdata(_phy);
|
||||||
+ usb_phy_enable(0);
|
+
|
||||||
+ if (!IS_ERR(rstdev))
|
+ /* disable the phy */
|
||||||
+ reset_control_assert(rstdev);
|
+ rt_sysc_m32(phy->clk, 0, RT_SYSC_REG_CLKCFG1);
|
||||||
+ if (!IS_ERR(rsthost))
|
+
|
||||||
+ reset_control_assert(rsthost);
|
+ /* assert the reset lines */
|
||||||
+ }
|
+ reset_control_assert(phy->rstdev);
|
||||||
|
+ reset_control_assert(phy->rsthost);
|
||||||
+
|
+
|
||||||
+ return 0;
|
+ return 0;
|
||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
+static struct phy_ops ralink_usb_phy_ops = {
|
+static struct phy_ops ralink_usb_phy_ops = {
|
||||||
+ .init = ralink_usb_phy_init,
|
|
||||||
+ .exit = ralink_usb_phy_exit,
|
|
||||||
+ .power_on = ralink_usb_phy_power_on,
|
+ .power_on = ralink_usb_phy_power_on,
|
||||||
+ .power_off = ralink_usb_phy_power_off,
|
+ .power_off = ralink_usb_phy_power_off,
|
||||||
+ .owner = THIS_MODULE,
|
+ .owner = THIS_MODULE,
|
||||||
+};
|
+};
|
||||||
+
|
+
|
||||||
+static struct phy *ralink_usb_phy_xlate(struct device *dev,
|
|
||||||
+ struct of_phandle_args *args)
|
|
||||||
+{
|
|
||||||
+ return rt_phy;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
+static const struct of_device_id ralink_usb_phy_of_match[] = {
|
+static const struct of_device_id ralink_usb_phy_of_match[] = {
|
||||||
+ { .compatible = "ralink,rt3xxx-usbphy", .data = (void *) (RT_CLKCFG1_UPHY1_CLK_EN | RT_CLKCFG1_UPHY0_CLK_EN) },
|
+ {
|
||||||
+ { .compatible = "ralink,mt7620a-usbphy", .data = (void *) (MT7620_CLKCFG1_UPHY1_CLK_EN | MT7620_CLKCFG1_UPHY0_CLK_EN) },
|
+ .compatible = "ralink,rt3352-usbphy",
|
||||||
|
+ .data = (void *) (RT_CLKCFG1_UPHY1_CLK_EN |
|
||||||
|
+ RT_CLKCFG1_UPHY0_CLK_EN)
|
||||||
|
+ },
|
||||||
|
+ {
|
||||||
|
+ .compatible = "mediatek,mt7620-usbphy",
|
||||||
|
+ .data = (void *) (MT7620_CLKCFG1_UPHY1_CLK_EN |
|
||||||
|
+ MT7620_CLKCFG1_UPHY0_CLK_EN) },
|
||||||
+ { },
|
+ { },
|
||||||
+};
|
+};
|
||||||
+MODULE_DEVICE_TABLE(of, ralink_usb_phy_of_match);
|
+MODULE_DEVICE_TABLE(of, ralink_usb_phy_of_match);
|
||||||
@ -180,20 +190,38 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
|
|||||||
+ struct device *dev = &pdev->dev;
|
+ struct device *dev = &pdev->dev;
|
||||||
+ struct phy_provider *phy_provider;
|
+ struct phy_provider *phy_provider;
|
||||||
+ const struct of_device_id *match;
|
+ const struct of_device_id *match;
|
||||||
|
+ struct ralink_usb_phy *phy;
|
||||||
|
+
|
||||||
|
+ phy = devm_kzalloc(dev, sizeof(*phy), GFP_KERNEL);
|
||||||
|
+ if (!phy)
|
||||||
|
+ return -ENOMEM;
|
||||||
+
|
+
|
||||||
+ match = of_match_device(ralink_usb_phy_of_match, &pdev->dev);
|
+ match = of_match_device(ralink_usb_phy_of_match, &pdev->dev);
|
||||||
+ phy_clk = (int) match->data;
|
+ if (!match)
|
||||||
|
+ return -ENODEV;
|
||||||
+
|
+
|
||||||
+ rsthost = devm_reset_control_get(&pdev->dev, "host");
|
+ phy->clk = (int) match->data;
|
||||||
+ rstdev = devm_reset_control_get(&pdev->dev, "device");
|
|
||||||
+
|
+
|
||||||
+ rt_phy = devm_phy_create(dev, NULL, &ralink_usb_phy_ops);
|
+ phy->rsthost = devm_reset_control_get(&pdev->dev, "host");
|
||||||
+ if (IS_ERR(rt_phy)) {
|
+ if (IS_ERR(phy->rsthost)) {
|
||||||
+ dev_err(dev, "failed to create PHY\n");
|
+ dev_err(dev, "host reset is missing\n");
|
||||||
+ return PTR_ERR(rt_phy);
|
+ return PTR_ERR(phy->rsthost);
|
||||||
+ }
|
+ }
|
||||||
+
|
+
|
||||||
+ phy_provider = devm_of_phy_provider_register(dev, ralink_usb_phy_xlate);
|
+ phy->rstdev = devm_reset_control_get(&pdev->dev, "device");
|
||||||
|
+ if (IS_ERR(phy->rstdev)) {
|
||||||
|
+ dev_err(dev, "device reset is missing\n");
|
||||||
|
+ return PTR_ERR(phy->rstdev);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ phy->phy = devm_phy_create(dev, NULL, &ralink_usb_phy_ops);
|
||||||
|
+ if (IS_ERR(phy->phy)) {
|
||||||
|
+ dev_err(dev, "failed to create PHY\n");
|
||||||
|
+ return PTR_ERR(phy->phy);
|
||||||
|
+ }
|
||||||
|
+ phy_set_drvdata(phy->phy, phy);
|
||||||
|
+
|
||||||
|
+ phy_provider = devm_of_phy_provider_register(dev, of_phy_simple_xlate);
|
||||||
+
|
+
|
||||||
+ return PTR_ERR_OR_ZERO(phy_provider);
|
+ return PTR_ERR_OR_ZERO(phy_provider);
|
||||||
+}
|
+}
|
||||||
|
Loading…
Reference in New Issue
Block a user