mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-21 09:42:09 +00:00
tools/squashfskit4: drop unused tool
Drop squashfskit4 tool as it got replaced by new version of squashfs4 tool. Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
This commit is contained in:
parent
a33b97dcb1
commit
eac6fe6f74
@ -1,41 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2009-2012 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=squashfskit4
|
||||
PKG_VERSION:=4.14
|
||||
PKG_RELEASE:=3
|
||||
PKG_SOURCE:=squashfskit-v$(PKG_VERSION).tar.xz
|
||||
PKG_SOURCE_URL:=https://github.com/squashfskit/squashfskit/releases/download/v$(PKG_VERSION)/
|
||||
PKG_HASH:=5761aaa3aedc4f7112b708367d891c9abdc1ffea972e3fe47923ddba23984d95
|
||||
|
||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/squashfskit-v$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
define Host/Compile
|
||||
+$(HOST_MAKE_VARS) \
|
||||
$(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
|
||||
XZ_SUPPORT=1 \
|
||||
LZMA_XZ_SUPPORT=1 \
|
||||
XATTR_SUPPORT=1 \
|
||||
LZMA_LIB="$(STAGING_DIR_HOST)/lib/liblzma.a" \
|
||||
EXTRA_CFLAGS="-I$(STAGING_DIR_HOST)/include" \
|
||||
mksquashfs unsquashfs
|
||||
endef
|
||||
|
||||
define Host/Install
|
||||
$(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/mksquashfs $(STAGING_DIR_HOST)/bin/mksquashfs4
|
||||
$(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/unsquashfs $(STAGING_DIR_HOST)/bin/unsquashfs4
|
||||
endef
|
||||
|
||||
define Host/Clean
|
||||
rm -f $(STAGING_DIR_HOST)/bin/mksquashfs4
|
||||
rm -f $(STAGING_DIR_HOST)/bin/unsquashfs4
|
||||
endef
|
||||
|
||||
$(eval $(call HostBuild))
|
@ -1,21 +0,0 @@
|
||||
--- a/squashfs-tools/version.sh
|
||||
+++ b/squashfs-tools/version.sh
|
||||
@@ -27,13 +27,11 @@ if [ -z "$OUTPUT" ] ; then
|
||||
fi
|
||||
|
||||
our_date() {
|
||||
-case $(uname) in
|
||||
-NetBSD|OpenBSD|DragonFly|FreeBSD|Darwin)
|
||||
- date -r "$1" "$2"
|
||||
- ;;
|
||||
-*)
|
||||
- date -d "@$1" "$2"
|
||||
-esac
|
||||
+ if date --version 2>&1 | grep -q "GNU coreutils"; then
|
||||
+ date -d "@$1" "$2"
|
||||
+ else
|
||||
+ date -r "$1" "$2"
|
||||
+ fi
|
||||
}
|
||||
|
||||
try_version() {
|
@ -1,41 +0,0 @@
|
||||
From fe2f5da4b0f8994169c53e84b7cb8a0feefc97b5 Mon Sep 17 00:00:00 2001
|
||||
From: Sergei Trofimovich <slyfox@gentoo.org>
|
||||
Date: Sun, 26 Jan 2020 18:35:13 +0000
|
||||
Subject: [PATCH] squashfs-tools: fix build failure against gcc-10
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
On gcc-10 (and gcc-9 -fno-common) build fails as:
|
||||
|
||||
```
|
||||
cc ... -o mksquashfs
|
||||
ld: read_fs.o:(.bss+0x0):
|
||||
multiple definition of `fwriter_buffer'; mksquashfs.o:(.bss+0x400c90): first defined here
|
||||
ld: read_fs.o:(.bss+0x8):
|
||||
multiple definition of `bwriter_buffer'; mksquashfs.o:(.bss+0x400c98): first defined here
|
||||
```
|
||||
|
||||
gcc-10 will change the default from -fcommon to fno-common:
|
||||
https://gcc.gnu.org/PR85678.
|
||||
|
||||
The error also happens if CFLAGS=-fno-common passed explicitly.
|
||||
|
||||
Reported-by: Toralf Förster
|
||||
Bug: https://bugs.gentoo.org/706456
|
||||
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
|
||||
---
|
||||
squashfs-tools/mksquashfs.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
--- a/squashfs-tools/mksquashfs.h
|
||||
+++ b/squashfs-tools/mksquashfs.h
|
||||
@@ -133,7 +133,7 @@ struct append_file {
|
||||
#define BLOCK_OFFSET 2
|
||||
|
||||
extern struct cache *reader_buffer, *fragment_buffer, *reserve_cache;
|
||||
-struct cache *bwriter_buffer, *fwriter_buffer;
|
||||
+extern struct cache *bwriter_buffer, *fwriter_buffer;
|
||||
extern struct queue *to_reader, *to_deflate, *to_writer, *from_writer,
|
||||
*locked_fragment, *to_process_frag;
|
||||
extern struct append_file **file_mapping;
|
@ -1,37 +0,0 @@
|
||||
--- a/squashfs-tools/xattr.c
|
||||
+++ b/squashfs-tools/xattr.c
|
||||
@@ -113,6 +113,7 @@ static int get_prefix(struct xattr_list
|
||||
|
||||
static int read_xattrs_from_system(char *filename, struct xattr_list **xattrs)
|
||||
{
|
||||
+#if defined(linux)
|
||||
ssize_t size, vsize;
|
||||
char *xattr_names, *p;
|
||||
int i;
|
||||
@@ -222,6 +223,10 @@ failed:
|
||||
free(xattr_list);
|
||||
free(xattr_names);
|
||||
return 0;
|
||||
+#else
|
||||
+ *xattrs = NULL;
|
||||
+ return 0;
|
||||
+#endif
|
||||
}
|
||||
|
||||
|
||||
--- a/squashfs-tools/unsquashfs_xattr.c
|
||||
+++ b/squashfs-tools/unsquashfs_xattr.c
|
||||
@@ -34,6 +34,7 @@ extern int user_xattrs;
|
||||
|
||||
void write_xattr(char *pathname, unsigned int xattr)
|
||||
{
|
||||
+#if defined(linux)
|
||||
unsigned int count;
|
||||
struct xattr_list *xattr_list;
|
||||
int i;
|
||||
@@ -136,4 +137,5 @@ void write_xattr(char *pathname, unsigne
|
||||
}
|
||||
|
||||
free_xattr(xattr_list, count);
|
||||
+#endif
|
||||
}
|
@ -1,14 +0,0 @@
|
||||
--- a/squashfs-tools/xz_wrapper.c
|
||||
+++ b/squashfs-tools/xz_wrapper.c
|
||||
@@ -192,7 +192,10 @@ static void xz_display_options(void *buf
|
||||
if(size != sizeof(struct comp_opts))
|
||||
goto failed;
|
||||
|
||||
- SQUASHFS_INSWAP_LZMA_COMP_OPTS(comp_opts);
|
||||
+#if __BYTE_ORDER == __BIG_ENDIAN
|
||||
+ comp_opts->dictionary_size = inswap_le32(comp_opts->dictionary_size);
|
||||
+ comp_opts->flags = inswap_le32(comp_opts->flags);
|
||||
+#endif
|
||||
|
||||
dictionary_size = comp_opts->dictionary_size;
|
||||
flags = comp_opts->flags;
|
Loading…
x
Reference in New Issue
Block a user