mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 05:38:00 +00:00
tools/flex: override SUBDIRS variable with Makefile
Instead of editing the SUBDIRS variable with a patch, it can be overriden at the end of the command line when invoking Make. Skip the build for po files as well, which is causing a conflict depending on the version of gettext detected, and macros present. Signed-off-by: Michael Pratt <mcpratt@pm.me>
This commit is contained in:
parent
89a8269c10
commit
e764a909e3
@ -21,13 +21,17 @@ include $(INCLUDE_DIR)/host-build.mk
|
|||||||
|
|
||||||
HOST_CONFIGURE_ARGS += --disable-shared
|
HOST_CONFIGURE_ARGS += --disable-shared
|
||||||
|
|
||||||
|
define Host/Compile
|
||||||
|
$(call Host/Compile/Default,SUBDIRS='src tools')
|
||||||
|
endef
|
||||||
|
|
||||||
define Host/Install
|
define Host/Install
|
||||||
$(call Host/Install/Default)
|
$(call Host/Compile/Default,install SUBDIRS='src tools')
|
||||||
$(LN) flex $(STAGING_DIR_HOST)/bin/lex
|
$(LN) flex $(STAGING_DIR_HOST)/bin/lex
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Host/Uninstall
|
define Host/Uninstall
|
||||||
-$(call Host/Compile/Default,uninstall)
|
-$(call Host/Compile/Default,uninstall SUBDIRS='src tools')
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Host/Clean
|
define Host/Clean
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -43,10 +43,7 @@ EXTRA_DIST = \
|
|
||||||
|
|
||||||
SUBDIRS = \
|
|
||||||
src \
|
|
||||||
- doc \
|
|
||||||
- examples \
|
|
||||||
po \
|
|
||||||
- tests \
|
|
||||||
tools
|
|
||||||
|
|
||||||
# Create the ChangeLog, but only if we're inside a git working directory
|
|
Loading…
Reference in New Issue
Block a user