toolchain: glibc: Update to version 2.34

glibc version 2.34 does not provide versioned shared libraries any more,
it only provides shared libraries using the ABI version. Do not try to
copy them any more.

The functions from libpthread and librt were integrated into the main
binary, the libpthread.so and librt.so are only used for backwards
compatibility any more.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
Hauke Mehrtens 2021-12-28 21:25:16 +01:00
parent 4d1f133561
commit e708bf76d5
4 changed files with 9 additions and 12 deletions

View File

@ -519,10 +519,9 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(INSTALL_DIR) $(1)/lib $(INSTALL_DIR) $(1)/lib
$(CP) \ $(CP) \
$(TOOLCHAIN_DIR)/lib/ld*.so.* \ $(TOOLCHAIN_DIR)/lib/ld*.so.* \
$(TOOLCHAIN_DIR)/lib/ld-$(LIBC_SO_VERSION).so \
$(1)/lib/ $(1)/lib/
for file in libanl libc libcidn libcrypt libdl libm libnsl libnss_dns libnss_files libresolv libutil; do \ for file in libanl libc libcidn libcrypt libdl libm libnsl libnss_dns libnss_files libresolv libutil; do \
for file in $(TOOLCHAIN_DIR)/lib/$$$$file.so.* $(TOOLCHAIN_DIR)/lib/$$$$file-$(LIBC_SO_VERSION).so; do \ for file in $(TOOLCHAIN_DIR)/lib/$$$$file.so.*; do \
if [ -e "$$$$file" ]; then \ if [ -e "$$$$file" ]; then \
$(CP) $$$$file $(1)/lib/; \ $(CP) $$$$file $(1)/lib/; \
fi; \ fi; \
@ -561,7 +560,6 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
ifneq ($(CONFIG_USE_MUSL),y) ifneq ($(CONFIG_USE_MUSL),y)
$(CP) \ $(CP) \
$(TOOLCHAIN_DIR)/lib/libpthread.so.* \ $(TOOLCHAIN_DIR)/lib/libpthread.so.* \
$(TOOLCHAIN_DIR)/lib/libpthread-$(LIBC_SO_VERSION).so \
$(1)/lib/ $(1)/lib/
endif endif
endef endef
@ -581,7 +579,6 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
ifneq ($(CONFIG_USE_MUSL),y) ifneq ($(CONFIG_USE_MUSL),y)
$(CP) \ $(CP) \
$(TOOLCHAIN_DIR)/lib/librt.so.* \ $(TOOLCHAIN_DIR)/lib/librt.so.* \
$(TOOLCHAIN_DIR)/lib/librt-$(LIBC_SO_VERSION).so \
$(1)/lib/ $(1)/lib/
endif endif
endef endef

View File

@ -7,13 +7,13 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=glibc PKG_NAME:=glibc
PKG_VERSION:=2.33 PKG_VERSION:=2.34
PKG_RELEASE:=2 PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION) PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=9b01145592fdbffbcbb949d680c152ed2bf2375d PKG_SOURCE_VERSION:=d5ba02f67dd62a63e29c29eebd6c543722aa6b5b
PKG_MIRROR_HASH:=a1bf0858828ee0f68c7847ce9504bb10ce943d0c8fe801d7ba307add2a238c5b PKG_MIRROR_HASH:=19e49929c7ea3480a0d1213b6763a23a5ed8129a34fe201a985498927c583ce1
PKG_SOURCE_URL:=https://sourceware.org/git/glibc.git PKG_SOURCE_URL:=https://sourceware.org/git/glibc.git
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz

View File

@ -469,7 +469,7 @@ provides them.
* Encode Binary Data:: Encoding and Decoding of Binary Data. * Encode Binary Data:: Encoding and Decoding of Binary Data.
* Argz and Envz Vectors:: Null-separated string vectors. * Argz and Envz Vectors:: Null-separated string vectors.
@end menu @end menu
@@ -2426,73 +2426,73 @@ functionality under a different name, su @@ -2423,73 +2423,73 @@ functionality under a different name, su
systems it may be in @file{strings.h} instead. systems it may be in @file{strings.h} instead.
@end deftypefun @end deftypefun
@ -596,7 +596,7 @@ provides them.
/* The enhanced internationalization capabilities according to XPG4.2 /* The enhanced internationalization capabilities according to XPG4.2
are present. */ are present. */
#define _XOPEN_ENH_I18N 1 #define _XOPEN_ENH_I18N 1
@@ -1129,17 +1132,25 @@ ssize_t copy_file_range (int __infd, __o @@ -1146,17 +1149,25 @@ ssize_t copy_file_range (int __infd, __o
extern int fdatasync (int __fildes); extern int fdatasync (int __fildes);
#endif /* Use POSIX199309 */ #endif /* Use POSIX199309 */
@ -627,7 +627,7 @@ provides them.
range [FROM - N + 1, FROM - 1]. If N is odd the first byte in FROM range [FROM - N + 1, FROM - 1]. If N is odd the first byte in FROM
--- a/stdlib/stdlib.h --- a/stdlib/stdlib.h
+++ b/stdlib/stdlib.h +++ b/stdlib/stdlib.h
@@ -962,6 +962,12 @@ extern int getsubopt (char **__restrict @@ -968,6 +968,12 @@ extern int getsubopt (char **__restrict
#endif #endif

View File

@ -2,7 +2,7 @@ add /usr/lib to default search path for the dynamic linker
--- a/Makeconfig --- a/Makeconfig
+++ b/Makeconfig +++ b/Makeconfig
@@ -601,6 +601,9 @@ else @@ -610,6 +610,9 @@ else
default-rpath = $(libdir) default-rpath = $(libdir)
endif endif